Audio devices not showing ⬆️

Roon Core Machine

MacBook Pro running macOS Monterey 12.6

Networking Gear & Setup Details

Unify dream machine whole home wifi
VPM l2tp server

Connected Audio Devices

Lyngdorf 1120
Lyngdorf MP-60.2

Number of Tracks in Library

Description of Issue

since upgrading to 2.0 none of the previously seen audio devices show up …

Hi @Rod_Bolanos,

This may very well be due to changes in how Roon interacts with MacOS sleep settings. Previously, Roon interfered with a Mac’s Energy Saver settings. Now we are finding that audio devices disappear when it does sleep.

Can you please change your settings to mirror this and reboot?
Screen Shot 2022-10-24 at 10.47.19 AM

If this doesn’t work, it’s possible something is corrupted but I suspect my first point is relevant. Below are the steps to completely restore Roon. Please note the first step carefully before proceeding and let me know your outcome.

Wes

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “Roon” and “RAATServer”
  • Rename “Roon” to “Roon_old” and “RAATServer” to “RAATServer_old”
  • Reinstall Roon from our Downloads Page

Wes,

I tried the steps Recommended except that I could not find a file with RAAT at all which I’m wondering if that may be the issue. I have a feeling I’m missing some of the files.

I haven’t tried deleting anything related to Roon as far as files are concerned and then downloading the Roon software again. That did not work either. Is it possible that in addition to the most recent Roon software version that I need to download some other Roon files?

I’m accompanying some of the snapshots from the Mac computer screen.




Both the folders should be in your user library, as shown in my screen grab below:

If you’ve checked that location, and the RAATServer folder is definitely not there, then something odd is going on. If you’re not sure you checked the right location, here’s the instructions on how to access your library folder:

1 Like

Thank you, @DaveN.

@Rod_Bolanos I’ve been a Windows IT support guy most of my life and this is a little quirk of MacOS that I’ve only recently learned about.

Let us know what you find!

Wes

1 Like

There is a RAATServer and a Roon file folder in the library but NO “Roon Server” file folder … could this be the issue?

My bad, I’ve misled you. If you take a look at Wes’s original message you’ll see that he mentioned the “Roon” folder and the “RAATServer” folder, both of which you have. In my case, as I’m running the stand alone version of the core, I also have the RoonServer folder. In you case, you just need to follow Wes’s original instructions …