Audio devices unavailable after restarting Roon

To start off I’ve had multiple similar issues before so if I had to guess it might be on my side but I have not the slightest clue where. With that being said I thought I’d provide some logs to see if there is anything obviously wrong before I go and do a Windows re-install again…

Description of issue:

After a fresh install of Roon, I am able to log in, see audio devices, and music playback works as expected.

If the application is closed at all, for restoring backups, changing the theme, or just through normally exiting the program, audio devices are no longer accessible. Either not showing up at all or stuck enabling before disappearing.


Not working after closing Roon -!RI1SyKYR!3TYe7Lz937VsdPPQfnHlR1FVP7Kpz6UeaXhqfpxbhts

Working before closing Roon -!tYdwjJzb!dDfy0SFF60ZBmQoCUfXOgF7TJz3iWYrEA-q4PFNd0Cg


OS: Windows 10 Pro version 1709 OS Build 16299.192
Roon Version: 1.4 (build 294) stable (64bit)
PC spec: i7 6850k, 32gb ddr4, gtx 1080,
Library location: internal WD Red 4tb hdd
specs cont. -
Library size: approximately 30k tracks
DAC - Chord Mojo, latest drivers from Chord


Thanks for the report @Rumiho, sorry to hear of the troubles.

Moving forward, I have downloaded the provided logs (thank you) and have passed them over to our techs for analysis. Once I get some feedback from the team I will be sure to provide you an update ASAP.


1 Like

Hi @Rumiho ----- Thank you for your patience here while our tech team has been examining the traces found in the provided logs.

To bring you up to speed, the team has informed me that they are not seeing anything conclusive in the Roon logs that is pointing to the potential cause of this behavior with your audio device. In light of this the team has asked if you have RAATServer logs available from the same time from as Roon logs above.

Let me know, many thanks!

I do not have the logs from the same time as the above but I recreated the issue and have a full set from today.

Interestingly, if I do not delete the RAATServer folder in appdata before the new install, the issue persists.

Working -!lcMnRJLR!jJtRcKTeAxF7YlJ1hL3IMgQYOkXUBFAN8dykBa48UjY

Not working -!4ZVTVKpa!jHnD7RI6ozUsFZs9DGsMjnL0zOwv1N4Rya0D2A7_82Y

*edit - added a different set of logs from the original post time


Thanks for the follow up @Rumiho and providing me with a new set of logs. I am going to be updating my report and passing these latest log sets over for evaluation.

Once my report has been passed back I will be sure to share the team’s thoughts/findings with you in a timely manor.


I’m not sure why I didn’t try this before but, if I just delete the RAATServer folder in AppData without a reinstall and before launching Roon the audio devices need to be enabled but work. So this workaround at least lets me use Roon for now without a Windows re-install which I don’t know if it would even fix the issue.

Hi @Rumiho ---- Thank you again for your continued feedback and more importantly, thank you for your patience while our tech team has been looking into this issue for you.

Moving forward, the team has updated my report and mentioned that they are still not seeing anything conclusive in the latest set of Roon and RAATServer logs. The team thinks that this could be occurring because of a frozen RAAT process, but again, this is just a theory based on the symptoms being described in your report.

I know in the past you said you have handled the issue by doing a reinstall of Windows but have you tried rolling back to the previous Win10 Pro build?


Alright, so I tried to run a system restore back as far as I could to a previous update and that ended up corrupting my Windows install, forcing me to re-install Windows fresh. After the re-install, it is now working again normally.

As this seems to be a recurring issue would you like a set of current logs to see if there is anything visibly different? I also have installed program lists from before and after the re-install.

Also, thank you for the help in trying to diagnose the issues I’ve been having. I love Roon when it works and will continue to use it, but it is a bit of an inconvenience to have to re-install Windows intermittently for a single program to function.


I’ve come to the conclusion that I’m somehow incredibly unlucky when it comes to computers. I spoke too soon, it is now back to the same behavior after a reboot … which is rather unfortunate.

To note again, every other source of audio and music playback software I try works perfectly, it is just Roon that has the issues.

Hi @Rumiho ----- Thank you for the follow ups and I am sorry to hear that this issue has continued.

Moving forward, do you have the capability of trying to run your Roon core (temporarily of course) on a different device? I am more than willing to have our techs examine another set of logs from the affected computer but I am curious as to how things perform elsewhere.

This will provide us with a good data point because based on the outcome we will have a clearer sense if something is happening on the OS level or with the application itself. Let me know and we can go from there.


I was able to test and confirm that it works perfectly connecting to the same core on a MacBook Pro (macOS ver. 10.13.2) as well as another Windows desktop (Windows 10 Pro, Version 1607, Build 14393.1198)

I can also see all of the audio devices attached to the other systems as well as play to them from my main desktop

The below screenshot shows the audio devices of the main computer immediately after starting Roon before they disappear.

New support package -!xJ8RyLDI!m1uejnIJUcCfZcKEG9lJQ7PY1rATZLu5JyYHtk1h320


Hi @Rumiho ----- Thank you for touching base with me and sharing the observations you have made after performing the proposed test. The insight is appreciated!

Moving forward, I have received the provided logs and have placed them in our queue for evaluation by our tech team to see if there is anything we we can do here to help with the affected Win10 computer.

Additionally, I know you and I had discussed rolling back to a previous Win10 pro build and I am curious, did you try the same build that is working on the other Win10 machine you performed the above test with?


OS: Windows 10 Pro version 1709 OS Build 16299.192


OS: Windows 10 Pro, Version 1607, Build 14393.1198


I was unable to easily try the older build of Windows on my main system so instead tried the reverse and updated the system that was working from Version 1607 to 1709 and it still functions perfectly in Roon.


Thanks for sharing that insight with me @Rumiho!

While this may sound elementary can you confirm that there are not active firewalls or antivirus application running on the affected device? The reason I ask is because you mentioned that a work around for you has been to delete the RAATServer folder and I am wondering if something is causing RAATServer to crash.

Looking forward to your feedback!

Currently only Windows Defender is running but both roon.exe and raatserver.exe are being allowed through the firewall so that should not be an issue unless I am missing some other exe.

I did test however with the firewall completely disabled and the issue persisted.


Hi @Rumiho ----- Thank you for the feedback and sharing the observations you have made with Windows defender completely disabled. The insight is very appreciated and my sincerest apologies for the slow response here.

Continuing forward, I would be interested to see what the experience is like for you when the Roon core is hosted another device that you know isn’t exhibiting these issues. You had mentioned in your first post that this is not the first time you have encounter problems with the mentioned Win10 machine, so my feeling is that this is going to keep popping up after “x” amount of time. At the very least this would help us understand if the issue is that machine OR if something else is occurring in your setup.

Additionally, you could also try (if you have not already) hosting RoonServer on the computer, instead of the “full” Roon install to see how things hold up.

Let me know what you think and we will do our best to try and help here.


Hi, thanks for the reply. I tested the following scenarios as suggested.

Windows 10 A - not working (system with the main issues)
Windows 10 B - working (separate Windows 10 device)
Both systems running Windows 10 Pro, Version 1709, OS Build 16299.248 and most recent versions of Roon

Test case 1:

Roon Server Windows 10 A + Roon Bridge -> Roon Remote on iPad -> output to audio devices on Windows 10 A

Audio devices appear when the app is started but disappear replicating the issue.

Test case 2:

Roon Core on Windows 10 B -> accesses music files on Windows 10 A over network -> Roon Bridge on Windows 10 A -> Output to audio devices on Windows 10 A

All audio devices function normally and there are no issues

With that tested it would appear that there is some issue with the affected machine. This has occurred on two different hardware configurations with this system so I have to assume that I’m either unlucky and somehow got bad hardware somewhere each time or that something in my set-up process that would be the same is causing some issue with seemingly only Roon.


@eric Update just to let you know that the 1.5 update happened to finally resolve the issue I was having. I was using batch files to clear settings on launch but it now works perfectly without those and devices are correctly found and enabled. Regardless of what happened to fix it thanks to the Roon team for the great continued development.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.