Audio hiccups with Bluesound Node 2

Hi all,

My Roon Core runs on an Intel i5 NUC; music library on a QNAP TS 253Be. I also use Tidal.

Playback through two old Squeezebox devices, laptop and phone [both with Dragonfly], works perfect all the time.

Trouble is in playback Roon through my Node 2 in my main system [Meridian amp and Martin Logon speakers]. Since a week or so, I hear hiccups [Tidal and library]. Tidal direct to the Node 2 works OK.

Connections main system are all wired, except remotes by phone or tablet. I have shut down all and restarted, have newest firmware/drivers and have not change a thing in my setup the last two years, so I have no idea what suddenly went wrong!

Has anybody the same experience and/or hopefully a solution?


1 Like

I had a similar problem since an BluOS update.

I don’t know if this will help you, but you can try of course.

In the BluOS app go to ‘Settings’ -> ‘Player’ -> ‘Audio’.

You will see an option there called ‘Audio clock trim’.

If it’s ‘On’ turn it ‘Off’.

If it is turned ‘Off’ turn it ‘On’.

And see if the problem is solved.

Good luck.

Same issues with my Node 2i. Previous to the latest update, Wi-Fi was rock solid. Now, I am seeing disconnects when using it as a Roon endpoint. So, I went back to the Apple Airport Express bridge and all is well.

My router is the last generation of Apple Airport Extreme + TimeCapsule … it’s possible that the problem is with that device and not the Node 2i’s Wi-Fi stack; except that this is the only device with which I have problems.

I didn’t have any connection problems. My problem, which is solved now, was hiccups with the sound.

Hi Henri,

Hopeful I changed the Audio clock trim setting from On to Off.

But it didn’t matter; the hiccups are still here.

Anybody another suggestion?


Sorry @Erry_Grootenboer that’s about the extent of what I could surmise about your problem.

I would advise you to contact the people from Bluesound here:

I found them to be helpful.

That’s a good idea!
I will contact them.

Thank you!!

1 Like

Glad to ‘help’.

I have the same issue with Roon. I am using now bluos to play my music. I hope it will solve quickly.

Not sure that hoping alone will fix this :smiley:

It’s true hope is not enough, it is why I have open a ticket on the bluos support team. I have seen your post on the bluos community but until now there is non answer or idea from the community about the Roon issue with bluenode 2
I will keep you inform as soon as I have an answer from the support team

I noticed that the way the BlueOS app integrates with Roon has completely changed in the recent update.
It used to replicate some of Roon’s functionality directly within BlueOS, but now just shows what’s playing and gives a link out to the Roon app.
Technically this actually makes sense, but the finish and feel of the BlueOS app is now much reduced - it feels like an update without a lot of love.
Possibly there has been some shoddy work in the latest update, maybe as a consequence of reduced budgets and reduced team size. Most businesses have been negatively affected by coronavirus.
Obviously this is just speculation.
Luckily the performance of my Node 2i is unaffected, but I’m on an ethernet connection.

Nice! I wil wait therefore with my own ticket for the support team.

I do hope my Node 2 isn’t affected bij the coronavirus aftermath, but it is stille strange than after two years my Node 2 started having hiccups.
Hope the Roon support team will pick this up

Got a reply from the Bluesound support team that worked fine for me.
The hiccups problem is history!

If TIDAL Connect to the NODE seems fine, it might be just a temporary networking hiccup between ROON and the NODE. I would recommend the following:

  • Please power down your players and any other network-attached devices. (Laptops, tablets and smartphones you can simply put in Airplane Mode).
  • Unplug your router for 30 seconds then plug it back in
  • Wait 5 minutes
  • Start powering up all your Players and network devices.
  • Reconnect your tablets and laptops
  • Relaunch the app to test
  • Test with ROON

This will reset your network router’s cached addresses.

1 Like

Great to hear! Glad that it is solved. :slight_smile:

Thanks to have share the Bluesound support reply.

I have followed all the recommandation, and the sound using Roon is now very good. But i still have an issue with some slight random sizzling on the speakers.
I have done several tests:
If i play my CD player no sizzling.
If i play the bluOS app, no sizzling.(Qobuz or my library)
If i play Roon i have sizzling, as well in my main system in the living room as in the Pulse Mini in the bedroom.
I have the core is on a iMac, and the bluenode 2 and the pulse mini is connect with ethernet cat6e

Thats’s means for me that the issue is coming only when using Roon since the Bluos update 3.12.2.

If someone as an idea, please let me know


I was having the ‘hiccup’ as well after the previous update. - They pushed a new build yesterday, 3.12.6 and things seem better…?

Yes a little bit better, but not great as it was before the 3.12.2 release. First I have light random sizzling in the speakers and the sound had lost density and details.
Let’s wait I opened a new ticket to the bluos support team.

I suggest you try the Bluesound steps once more and take more time, my first try was not successful, because I’m not the waiting type…