Audio MIDI settings stuck on last played track on a Mac

Roon Core Machine

14" MacBook Pro M1 Pro (binned) on MacOS Ventura 13.2 with 16 GB unified memory and 512 SSD

Networking Gear & Setup Details

Mac is connected wirelessly to a router - Spectrum cable internet - gigabit speeds, usually 800+ Mbps down and 40+ Mbps up - No VPN

Connected Audio Devices

Using an iFi Zen DAC V2, connected via USB to a CalDigit T3 docking station, which is connected via Thunderbolt to my Mac. I then either use external speakers connected via a quarter-inch unbalanced connection to the DAC, or I plug in my Sennheiser HD 650’s via a balanced connection to the DAC.

Number of Tracks in Library

Unknown - Didn’t import it all yet - Right now, just testing the application out - Connected to my trial subscription to Qobuz and using that.

Description of Issue

I have 5 screenshots but I do not have the ability to upload them as I do not see any option to do so. The issue is this:

  • The default bitrate output is 16-bit 44.1 kHz. If I play a YouTube video, that is what the Apple Audio MIDI settings will be at.
  • I open ROON and connect to my Qobuz service and play a song. In this case, the song is at 24/96. The Apple Audio MIDI application shows that and my DAC registers the higher bit rate.
  • If I close out of ROON and then go back to playing a YouTube video, the issue is that the bit rate is “stuck” at the last track I played in ROON, in this case, its still at 24/96, and it does not revert back to the default 16/44.1. I have to manually make that change in the MIDI application.
  • I have exclusive mode selected. Not sure if there is another setting I need to update or not

Please advise. Thank you.

It seems that you might have enabled System Output rather than your DAC in Roon Settings>Audio

Here SMSL is my DAC and you can see the other options are not enabled.

If this doesn’t solve it post a screenshot of your Signal Path and we’ll have a better idea of what is happening.

Your hanging of the midi settings does happen if you before quit roon disable the Zen Dac from roon audio settings? After that if you select from audio preferences default and reselect the Zen Dac it works? I suspect Ventura it is the cause for this but have you tried connecting the Zen Dac in any other way than thru the CalDigit Docking sistem?

I have a Zen Dac v2 on a m1 mini with Ventura 13.2 but never happened to me (I rarely use Netflix so I output audio to Zen)

1 Like

Here are my original screen shots

I went ahead and disabled system output and restarted Roon, but that did not solve the issue.

Here is my signal path

I have not tried connecting the DAC directly to my Mac yet. Possible, but would not be ideal in my set up. It also doesn’t matter if I’m watching a YouTube video after using Roon because whatever I’m doing, the audio settings have been changed to 24/96 (in this case) and Roon (or MacOS) is not reverting the audio back to its original setting.

This looks correct.

I’ve never noticed the midi audio settings thing before either.
Although I’m not in the habit of checking.

1 Like

Why re you using the Audio MIDI app at all? The Mac will handle switching when it needs to, and Roon will output what is input, e.g. Qobuz hi-res or flacs or whatever, at the bitrate of the source/file.

Yes, but just to check up if osx still hangs, basically if osx still thinks that the dac is in exclusive mode in roon when in reality roon is being closed
What about if you do not check exclusive mode in roon?
What about if you disconnect dac and reconnect when osx is frozen?
If osx set to default, use roon with 24/96, quit roon and only after that switch osx from default to iFi, does that have the same issue?
Usually in Ventura the error was that after using roon exclusive for the dac when using osx with the respective the dac core audio drivers would freeze. Slightly a version of your problem (or exactly your problem). And I have tried to make a clone of the dac in audio midi, just for the roon to use and another one for osx. Never solved those issues, only from Ventura 13.0 to 13.1 they went away

Well I’m not using the MIDI app, just utilizing it to see the bit rate changes (or lack there of in this case).

The iFi Zen DAC will change colors depending on the bit rate it is receiving. Since that did not change when I closed down Roon, that’s how I started opening the MIDI app to see what the bit rate was left at.

After playing around for a bit, I realized that Roon was leaving the last bit rate played on my Mac (or my Mac simply wasn’t updating it).

Either way, I’m not using it per se, just to verify what bit rate is being passed to my DAC.

1 Like

I think this is the case. Unfortunately I do not know any automated work around. There are many that want to use the dac with roon and with osx so it is an inconvenience (the first post with this problem was with a Schiit dac, I did replicate the problem at that time using Zen Dac and also a CA 200M). From what I understood from one of the support guys Ventura has added one more layer to the core audio drivers that might be causing this.


I did in fact connect the Zen DAC directly to my Mac with a USB C to USB A adapter and the same issue happens.

I guess it’s a MacOS issue (which doesn’t surprise me), but I will await to see if anyone else has a suggestion.

1 Like

Hi @Traian_Boldea, @William_Watson

If you haven’t already, hard-kill the core audio on your Mac by opening the Terminal and entering this command line:

sudo killall coreaudiod

Restart both the computer and Roon.

As others have mentioned, Ventura contained significant changes to the Mac OS audio drivers. We’re still ironing out inconsistencies behind the scenes between Ventura Cores, other Mac all-in-one Roon Cores, and different operating systems. Apple’s most recent Ventura update also contained stability fixes that resolved a large number of audio-dropout-related problems (much to the relief of pro and consumer audio communities).


Thank you @connor
I did not know this. It would be of any benefit to do this also if I have non Ventura osx comps and I do use them as endpoints?

I sincerely appreciate your advice.
I’ll check the status for a while.

  • I feel that the sound quality has also improved.
1 Like

Hi @Traian_Boldea,

You shouldn’t need to kill the OS audio kernel unless audio is misbehaving outside of Roon. Usually, mismatches between the OS and Roon can be resolved by refreshing RAATServer:

  • Create a Backup of your current Roon database
  • Exit out of Roon
  • Navigate to your Roon’s Database Location
  • Find the folder that says “RAATServer”
  • Rename the “RAATServer” folder to “RAATServer_old”
  • Restart the Roon App to generate a new RAATServer folder

Hi everyone,

Reopening this thread to check in here. Many users have reported Mac OS audio kernel issues resolved - or changed - with update to 13.3.1 and above.

The team can reproduce this and related MacOS system output issues sporadically and the investigative ticket remains open (see here: Strange Audio Issues w/ Ventura [Roon Investigating; Known Apple Issues w/ Ventura System Audio].

However, most users on the latest Roon and Ventura releases are seeing symptoms relieved or improved.

Have you updated Ventura at all on the affected Macs, and if so, are symptoms any different?

1 Like