Audio Out Can Not See My Ayre Codex (Problem Solved)

Hi DrTone,

I can select the music files in NAS, and stream it to my Ayre device as screen shot below.

Doesn’t look so. Your MBP isn’t shown as Core, only as Control/Bridge. Your Core is still missing in Settings|Audio.

I think he misspoke. He was asked to keep the core on the Qnap and set the DAC up on a client (the MAC) to see if the Core could see the DAC on the remote client machine. Which he did and the Qnap core did see and play to the Ayre while it was connected to the MAC.

The basic issue is that the Qnap is not recognizing the Ayre when the Ayre is plugged into the Qnap and running Roon. Other Qnap music players are seeing the Ayre on the Qnap’s USB.

The basic issue is that the core is not recognized at all by Roon Controls (even the local sound card is missing in Settings|Audio). The QNAP itself, and also the Roon Core running on it, recognizes it’s sound card and the DAC well as proved by the screenshots of the OP.

Thanks guys. When I tried the MBP, I used it as a core. On remote(iphone) it showed two cores, QNAP and MBP, so I chose MBP and it recognised Ayre DAC on remote and played it successfully. When I switched it back to QNAP as a core, then I can not see any sound device, neither QNAP’s own sound card nor USB connected DAC.

QNAP has a cell phone app called Qmusic, which can be worked as remote controller on phone to stream music in QNAP’s stored music station. And it is working fine to find Ayre DAC remotely, which I would like to get that from Roon remote.

I’ve read various review articles for QNAP HS453DX before purchased it, and those reviews are mostly testing Roon and had no issues. I do’t think either that this model is having compatibility issue with Roon.

I did a search and found a few threads with problematic direct USB DAC connection to a QNAP (but there are others who got it working with different models / QTS), this thread is more informative:

Thanks Peter.

I checked that thread and see he replaced to another Qnap model and solve s the issue. I have suspected that Roon Core version might be an issue. I had tried un-installed and then installed again the Roon server on my Qnap, but it does not make any difference. However that was Roon software in Qnap app list. I wonder if I download the version from Roon webpage and install it again, would that be any difference. Not sure if they are the same version.

I am also desperate now…

Try to run the same commands brian mentioned in the thread, see what results you get. Let’s see if @crieke has any thoughts on this.

And here is a another one with the same symptoms:

Different Core (Antipodes DX), different DAC (Hugo TT2) but maybe the same country (China)? I don’t know if the country matters (GFW) here. In both setups Roon fails to make the audio devices of the core available to the controls. This is usually caused by network problems (firewall, multicast errors, unusual network setups [virtualization], …).

Though that one seemed also from Hong Kong, me too lived in Hong Kong, but unlikely is region related issue. I wonder if there is new version changed lately and having bugs for all these similar issues come up at this time.

Hi cliff,
Can you check on your qnap if you unticked the ‘Disable Multimedia functions’ in the QNAP Control Panel? They are located in the general section.

Manually downloading Roon Server from the Roonlabs website won‘t change anything, as the QNAP package already does the same thing during installation.

1 Like

Hi Chris,

Thanks for the advice. I’ll check when I go home tonight. But do you mean I should have that “ticked” or “unticked”? Which one is correct?


It should be unticked ( = the multimedia functions should not be disabled and hidden).
It was just a guess yesterday, normally the web-ui of the QNAP should also give you an info if this, if the multimedia functions are disabled (= box ticked).

Also be aware, that the info about audio devices in the QNAP Roon Server web-ui reads only the audio devices of the QNAP system at /proc/asound/cards.
It is not linked to Roon Server and was originally put there as an option to troubleshoot and get some info about connected devices

Hi Chris,

Unfortunately it was un-ticketed already as I checked. I have tried ticked and unticked, but nothing has been changed. My core connected audio devices are still missing on Roon remote.

You can login to your router, go to IPTV, change the position of the multicast switch there (if there is one) and check if that changes something in Roon (you might want to reboot the core to be sure).

According to Cliff’s RAATServer logfiles (have been sent in a private message), Roon does nit detect any ALSA support on the HS-453DX.

04/14 04:56:53 Info: Starting RAATServer v1.6 (build 401) stable on linuxx64
04/14 04:56:53 Warn: [RAATServer] detected no ALSA support

I am currently checking the QNAP firmware file for that model to find out why…


Thanks for everyone’s helps these days. Problem solved.

I tried restart the Qnap NAS today, it took several minutes to turn down and then restart. And magically when I check the Roon remote agin, all the sound devices attached to NAS are shown up, including my Ayre Codex DAC. The next thing is enable it and I’m listening to music now. Not sure what had happened , but restart worked.

Thanks again for all your helps.



Hi @Cliff_Chou,

Glad to hear that the issue resolved itself! I am not sure why it did, but glad that the reboot helped. I will be marking this case as [Solved] but if things do change over the next days, do let me know. Otherwise I hope you continue having an enjoyable Roon experience!


1 Like

My speculation is that the setting might originally be in an invalid state and it gets corrected after ticking, unticking and reboot. I also sent a PM to a Hong Kong dealer (not a Lumin dealer), who sells prepackaged HS-453DX for Roon, asking him about direct USB DAC connection 3 days ago, but unfortunately he has not replied me yet. I’m glad this issue is solved for you.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.