Audio Out Can Not See My Ayre Codex (Problem Solved)


(Cliff Chou) #1

Hi,

I have installed Roon Server in my QNAP HS-453DX with USB connected to DAC Ayre Codex, Roon tested device. I have also installed Roon at my ipad and desktop. The issue is when I checked from ipad or desktop, I can not find Ayre Codex in audio zone shown. Therefore I can not output music to Ayre Codex. But when I log into the roon server, it shows it connected to Ayre USB device. So my question is what did I do wrong, and how can I make it work. Please help with this. Thanks.

Cliff


#2

The Roon server is in control of any devices/zones in your network. Make sure you only have one Roon Core (a.k.a. server) running in your network. You should only run Roon Control on the other devices.
Then you should go to Setup|Audio in Roon and activate your device there so it becomes available as zone.


(Cliff Chou) #3

Hi Jack,

I have only one Roon core running in my network, and run Roon control on my other devices. The issue is I can not see my device available in zone (Setup/Audio as you mentioned), so no way to activate it. How can I have it seen?


#4

Make sure the DAC is turned on and it’s input is set to USB.

It could also be of further help if you provide screenshots of what you are seeing (Server and Setup | Audio) here.

I also think it’s a good idea to move this to the #support section.


(Cliff Chou) #5

Hi BlackJack,

Yes the NAS has connected to DAC and its input is set at USB. Here you may see one is my Roon remote screen shot which does not detect Ayre DAC, and another pic is screen shot from roon server which shows it connected to Ayer device. Hope this explains
My question. Thanks.


(Noris) #7

Hello @Cliff_Chou,

Thanks for sharing those screenshots as BlackJack requested! It appears that you might have some kind of firewall blocking Roon’s discovery process since I noticed that the Networked area of your screenshot does not display any info.

Can you please let me know how the QNAP is connected to the network and how the iPad is? What is the exact model/manufacturer of your router and any switches/range extenders/powerline adapters in this setup?

On your Windows Roon Remote, can you please check to make sure you have added both Roon.exe and RAATServer.exe as an exception to your Windows firewall by using these instructions? You can find Roon.exe and RAATServer.exe by navigating to your Database Location/Applications folder and I would also add this as an exception to any antivirus firewalls you might have.

Thanks,
Noris


(Cliff Chou) #8

Hi Noris,

The Qnap Nas is connected to Tenda AC18 router by Ethernet cable. My PC is also connect to router by cable, and iPad is using Wi-Fi from the same router. I had not checked firewall setting, will do it when I return home from business trip later this week.

I have installed roon remote on PC as well, similarly it can not find my Ayre device. But if I just connected the NAS from PC and played music file in NAS not by Roon, it does stream out to my Ayre DAC.

Thanks
Cliff


(Noris) #9

Hi @Cliff_Chou,

Thanks for confirming that. I would check the firewall settings next to make sure it’s properly configured and then also take a look at the router web configuration. I suspect that you may have multicast disabled or something might be going wrong with IGMP settings.

We have a few routers documented at the end of our Networking Best Practices Guide as needing additional configuration options to work properly with Roon, and while your router doesn’t currently fall under this category it is possible that it might still need some of these settings applied.

Do let me know how the firewall checks and multicast settings checks go.

Thanks,
Noris


(Cliff Chou) #10

Hi Noris,

I checked the fire wall has included Roon.exe and RAATServer.exe, and I have checked router setting which does not have setting similar to listed routers would have. But it does not change any thing, and I still can not find my Ayre DAC from Roon remote. What else I can do to fix this?

Thanks
Cliff


(Daniel Beyer) #11

What if you connect the Ayre to the Windows PC running the Roon Client, does it show up?


(Noris) #12

Hi @Cliff_Chou,

I would give Rugby’s suggestion a try, if the Ayre shows up via USB on your desktop that will be a good data point to have. The main thing here is that I am not seeing anything show up in your Networking tab. Do you have other devices that should show up there, Apple TVs, Chromecasts, other Roon Remotes, ect?

Since it seems like nothing is being detected under Networked, this leads me to believe there is still a firewall somewhere blocking Roon from properly accessing your networked devices. Would you by any chance have additional firewalls in place on the QNAP or the router?

Thanks,
Noris


(Cliff Chou) #13

I have Chromecast shown up Will take my laptop to give it a try.


(Cliff Chou) #14

I have used a MacBook Pro as core to connect my Ayre DAC, and use iPhone as Roon remote to locate the device, and it worked. So it is only issue when connecting to my Qnap NAS. I have also tried to cancel fire wall, and it did not make any difference.

I am now at 14 days free trials, and guess it will be expired by 18th, if I can not sort this out, I will have to give up. I do not know what else I can do. Please help.


(Jeff) #15

Does Qnap’s own Music Station recognize the Ayre DAC and allow playback?


#16

What I miss on all this screenshots is the section about the core, like this from my core:
grafik
It’s not only the USB DAC missing, also the local sound card HDA Intel in’t there.

This makes me believe that it’s either a IGMP multicast issue or an issue with the device (HS-453DX) itself. QNAP itself advertises Roon on this device though.


But this relatively new device runs QTS 4.4 (Kernel 4.14) whereas most other QNAP devices run QTS 4.3 (Kernel 4.2.8 or even 3.X).


(Cliff Chou) #18

Hi DrTone,

I can select the music files in NAS, and stream it to my Ayre device as screen shot below.


#19

Doesn’t look so. Your MBP isn’t shown as Core, only as Control/Bridge. Your Core is still missing in Settings|Audio.


(Daniel Beyer) #20

I think he misspoke. He was asked to keep the core on the Qnap and set the DAC up on a client (the MAC) to see if the Core could see the DAC on the remote client machine. Which he did and the Qnap core did see and play to the Ayre while it was connected to the MAC.

The basic issue is that the Qnap is not recognizing the Ayre when the Ayre is plugged into the Qnap and running Roon. Other Qnap music players are seeing the Ayre on the Qnap’s USB.


#21

The basic issue is that the core is not recognized at all by Roon Controls (even the local sound card is missing in Settings|Audio). The QNAP itself, and also the Roon Core running on it, recognizes it’s sound card and the DAC well as proved by the screenshots of the OP.


(Cliff Chou) #22

Thanks guys. When I tried the MBP, I used it as a core. On remote(iphone) it showed two cores, QNAP and MBP, so I chose MBP and it recognised Ayre DAC on remote and played it successfully. When I switched it back to QNAP as a core, then I can not see any sound device, neither QNAP’s own sound card nor USB connected DAC.

QNAP has a cell phone app called Qmusic, which can be worked as remote controller on phone to stream music in QNAP’s stored music station. And it is working fine to find Ayre DAC remotely, which I would like to get that from Roon remote.

I’ve read various review articles for QNAP HS453DX before purchased it, and those reviews are mostly testing Roon and had no issues. I do’t think either that this model is having compatibility issue with Roon.