Audio stops on mono audio setting change

Roon Core Machine

Windows 11 /w latest update

Networking Gear & Setup Details

Connected Audio Devices

SPL Crimson 2

Number of Tracks in Library

500 via Tidal

Description of Issue

Music is playing in Roon.
In the Windows 11 control panel, go to System → Sound → Mono audio and switch from off to on or from on to off. You can find this setting by typing “mono audio” in the start menu.

Music stops in Roon. Pause button is still displayed and indicates music should be still playing. Sometimes Roon displays the message that it lost control of the audio interface.

Clicking on next button resumes audio.

Foobar works fine during the switch, but the audio stops for <1s.

Hey @Adrian_Stanciu,

Thanks for getting in touch to share this behavior. We’re really sorry we didn’t get a chance to reply sooner than this… :pleading_face:

Is there a reason you want to enable and disable this feature from the Windows interface? Would you be willing to give this a try instead?

I was testing improper headphone balance. Since I had 2 sources of music, Roon and Foobar, it made sense to use a single configuration point.

Thanks for letting me know about the Roon’s DSP. It is a feature I wasn’t aware of.

Anyway, I found out Roon’s robustness can be improved and I expect an update to fix this. Having the pause button active while the music is not playing is a no go, don’t you think?