Audio Stops when a call comes in or a zoom starts

Roon Core Machine

Synology NAS, but I have experienced this with core on multiple devices.

Networking Gear & Setup Details

Unifi - its not a networking question

Connected Audio Devices


Number of Tracks in Library

Tons, but not the issue.

Description of Issue

When playing music via Roon. Usually the app on my Mac, always to Sonos speakers or Sonos Amps. If a call comes in on my iPhone, or if I start or join a Zoom meeting, the music stops playing.

Where is this setting controlled?

Hey @Tim_Pearson,

The first thing to check would be your iOS notification settings for each app causing issues.

Another thing to test, does this happen on other streaming services? If not, take a look at mirroring the specific settings you have for that streaming service, and apply it to Roon on the affected device :+1:

I’ll be on standby for your reply.

So here’s a bit more info - and its happening on MacOS.
I’m using the Roon app connected to a different core server. Playing to Sonos speakers.

So I had just been in meetings for a couple hours straight and Roon continued to play. That was cool/fine.

I took my AirPods Pro off, so they could charge, connected via bluetooth, but not plugged into my computer, and when I did that, Roon paused.

So now I tested, put headphones back on, Roon continued to play. Take headphones off, Roon pauses.

This is opposite of what was happening previously, but its repeatable.

What setting do you think I should be looking for? Something in my bluetooth settings on my Mac?

Hey @Tim_Pearson,

From your reply above, it sounds like you’re not wanting Roon to be connected to your Airpods. Which device are your airpods connected to? It could be a situation where Roon is connected to the same device, playing music to the output of the device which is connected to your airpods, making your airpods the final endpoint for Roon.

I would take a look at the settings of the device your airpods are connected to. You could also take a look at your Roon Settings> Audio and disable the device connected to the airpods.

If you could test this and let me know the outcome that would be helpful, and let me know if I’ve understood your situation properly :pray:

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.