Audio stream to MicroRendu interrupted when accessing Roon Remote on iOS

My Setup:
Mac Pro 2013 (plenty of system resources) running Roon (latest version)
MicroRendu connected to TPLink AV2000 power line adapter. (running sonicorbiter 2.3 - 2.5 upgrade is in the mail)
Wireless network based on Apple Airport hardware
Roon remote on iOS (iPhone 7 plus)

I’m having an issue recently where the Roon audio stream to the MicroRendu drops when I the Roon remote on my iPhone connects to the Roon server running on my Mac. I usually get a message indicating that a file is loading slowly when it happens. It doesn’t happen 100% of the time, but it’s more than 70%, and always happen the moment that the remote connects and loads the display (thumbnails, etc). It seems unlikely that this little bit of network activity is swamping my network - the same network connection streams 4k with no issues.

I know that Roon recently changed from UDP to TCP - don’t know if this is related? Nothing else has really changed and I’m at a loss. My background is software and systems engineering so it’s safe to say I’ve tried all of the obvious stuff.

Many thanks for your help

Hi @Brian_Breneman ----- Thank you for the report and sharing your observations with us. The insight is greatly appreciated!

I have reviewed the details of your network configuration/topology and the devices that make up the chain of communication. As you have noted, there have indeed been some changes made to our streaming protocol “RAAT” (using TCP instead of UDP to transmit the audio stream as cited in build 234’s release notes), but these changes have been stable for the vast majority of our users.

As you can see we had another user who changed nothing in their setup before the update but had to make a slight adjustment to their switch to return to a stable state.

With all of that being said, I would recommend the following tests to try and isolate some variables:

  1. If the 2013 Mac Pro is accessing the network via WiFi, try testing with a hardwired connection.

  2. Have you tested with any other devices acting as a Roon remote besides the iPhone 7 plus? If so, what was the experience like?

  3. If possible I would strongly recommend testing with the Rendu mounted to your Airport. Running this test will help us understand whether the issue is related to the EoP setup, or whether there’s something else going on here. We don’t do any in-house testing with EoP and we generally recommend against it, as we’ve traced a huge array of networking issues to the technology going back over a decade.

That said, our latest release was designed to make these environments more stable, and we know that many users are running EoP without issue.

We can absolutely do some additional testing and investigation here, assuming we’re able to localize your issue to EoP. This test will help us make that determination.

Looking forward to the results of this test!

I’m going to test #1 and #2 first - much easier based on the setup of my house (listening system on 2nd floor, network setup in my office on first floor). The issue only happens when I launch and connect the remote…normal playback is just fine and is rarely interrupted.

I’ve disabled the wifi interface on the Mac Pro (both wifi and ethernet were active and connected) and if it still happens after that, I’m going to test with a MacBook running Roon as a remote.


1 Like

Please define EoP? Tnx.


Ethernet over Powerline

Tnx Brian.


An update to this based on last night’s testing: I turned off the wifi interface on the Mac Pro so that only the ethernet interface was active. In several tests, I was unable to replicate the problem. It’s a little too early to proclaim it solved, but this was a big step in the right direction.