Audio sync problems - MacOS and RPi [Resolved]

Hi @support,

I’m having an issue with zone audio sync. I have 3 Roons:
MacOS (core) running High Sierra, v1.4 (306)
MacOS (bridge) running High Sierra tried with and without a USB DAC, clock master = default, v1.4 (306)
RaspberryPi (bridge) connected via the built-in HDMI to an Onkyo amp, clock master = 1, v1.0 (141)

All are connected by a wired gigabit network.

When I group the two output zones, and start music playing, they are perfectly in sync for about 5 minutes then gradually drift apart. Pausing then restarting the music resyncs for another 5 minutes or so, before drifting again.

I’ve tried also using a Linux core in an LXC container, and combining the MacOS core and bridge onto a single machine (with and without the USB DAC). In all cases the sync issue persists. I haven’t tried adding a delay, as the sync delay isn’t constant - it grows over time.

Any help would be much appreciated.

Thank you for the report and sharing your feedback with us @Kiril_Dunn! The insight is very appreciated!

Moving forward, can you please verify the make/model of the USB DAC that is being used (on occasion) with the “bridge” computer? Additionally, during your troubleshooting have you tried setting the bridge computer’s “clock master priority” to “1 - highest” and then setting the RPi bridge’s “clock master priority” to “lowest”?


I resolved this by uninstalling and reinstalling Roon on every device. Not really sure what the problem was, but it no longer occurs.