Audio zone not available while Roonbridge is visible to Roon [Resolved]

While it used to work flawlessly my NuPrime IDA-8 USB DAC doesn’t show up as an audio zone. This setup used to work fine but failed a couple of weeks ago.

It is connected through Roonbridge on RPI3. Roonbridge does show up in Roon - settings / about. Had this with Roon 1.3 and 1.4. All running the latest versions and Roon does play on a Bluesound Flex and an iMac

I’m using the latest DietPI with only roonbridge, raspotify and netdata installed. The DAC works on aplay and with raspotify. Both using using plughw device as in:

“aplay -D plughw:1,0 /usr/share/sounds/alsa/Front_Center.wav”.

Any tips on pointing Roonbridge to the correct device?

Hi, @Nick_Ebels, thanks for the report and apologies for the troubles! After reading your post I have a few questions . Could you please give a more detailed description of your setup here? Also may ask you to describe your network topology?

I know that this is a simple step, but have you tried rebooting all devices that are running Roon software?

Thanks!


Ivan

Hi @Ivan Thanks for your quick response. RoonServer is running in a docker container, using the host network. The host is CoreOS running on an VM ESXi server, router is pfsense - running on a VM on the same server, RPI3 is connected wired through 2 switches - one near the host, one near the RPI3. So no WiFi in the chain. I’m fairly certain it is not a network issue, as that has been rock solid. Raspotify plays nicely on the same RPI, other clients connect fine to the server (Mac, phone, flex, …)

Tried restarting the container and RPI, did a fresh dietPI install. Tried stopping raspotify service to make the alsa device available to Roon. Will try install roonserver on a clean vm to rule out docker as the cause.

My guess it is something that blocks Roon from accessing the sound device.

Edit - while the original server didn’t work either, I noticed that after switching back to the docker install, I could enable the nuprime in the audio menu. Might have been there all along… no idea why it needed re-enabling but problem solved!

Nick