Automatic and manual backups of Roon DB fail

After the most recent update of the Roon core software, automatic backups and forced backups of the Roon database are failing.
Roon version: 1.4 (build 294) stable (64bit)

My configuration is:
Windows 10 Pro
Dell XPS 8920
Intel® Core™ i7-7700K CPU @ 4.20GHz, 4200 Mhz, 4 Core(s), 8 Logical Processor(s)
ASUS Wireless Router RTAC66U Router AC1750
The above PC that runs the Roon Core is ethernet wired to the router and the Core software is installed on C: drive which is a 512 SSD
The NAS that holds the music files is a Synology DiskStation 211j and is ethernet wired to the router
The Backup NAS is a Synology DiskStation 216 and is ethernet wired to the router (I have tried backing up to a different location, and it still did not work.)

Thanks for any help you can provide.

Luis Puncel

Attached is a screenshot of the error message:

Hi @Luis_Puncel ----- Thank you for the PM and sharing this observation you have made with us. The feedback is appreciated and sorry to hear of the troubles. We typically try to handle any support related questions on the “support” thread of the community site. Would you mind if I made this PM a public post and we can continue from there? Let me know.

In the meantime, from your report you mentioned that trying to create a backup to another location failed, my assumption is you tried to perform the backup to the one of the NAS units you have, please confirm. Secondly, by chance have you tested the dropbox backup feature? Just curious what the experience was like if you have.


Thanks for the response. I thought I was posting to the “support” thread rather than a private message. I’ll have to do it more carefully in the future. It is okay to post it in the support thread.

I had only tried creating the backup on another NAS device. Your question prompted me to try backing up to a USB drive, and the backup was successful. So I guess the problem is with NAS devices. I haven’t tried the dropbox feature. I’ll give that a try now and let you know.


FYI, I tried backing up to Dropbox. It didn’t go very well. I took 7 1/2 hours to complete. It kept stopping with a message saying it lost the connection, and then it would start back up on its own, but because of that, it took too long to be a practical solution.

The only way for me to back up at this point is to a USB drive.

Thanks for the follow up @Luis_Puncel and sharing the observations you have made while testing with the dropbox back up feature. A few things moving forward.

Additional data gathering:

  • Just to reconfirm, you have tried performing backups to both of the mentioned Synology devices, correct?

  • There are no other networking devices (i.e switches, extenders, etc) in your setup, correct? Just the mentioned Asus router with the core machine and NASs mounted directly to it via ethernet, yes?

  • While this may seem a bit elementary, can you verify that there is enough space available on the “Z:” drive of the PC hosting your Roon core.

Log gathering:

  • Please reproduce the issue and note the time when the error occurs.

“…automatic backups and forced backups of the Roon database are failing”

  • Once I have sense when the failure happens I will go ahead and enable diagnostics on your account so we can try to get a better sense of what is causing the issue with your backups.

Note: During this troubleshooting exercise please make sure you are trying to backup to the mentioned location in the provided screenshot



Sorry for the delay in my response. I have just been working a lot of hours and couldn’t take my eye off the ball. Somehow, the situation seems to have corrected itself. However, to answer your questions as to while I was still having the problem:

I tried backing up manually to multiple NAS devices and none of the back-ups were successful. As I mentioned the only type of backup I could get to work was to a USB drive. Also, the back-up to DropBox theoretically worked, but it took so long due to frequent timeouts, it isn’t a practical alternative.

The NAS drives are connected by ethernet cable, and there is an ethernet switch between the NAS and the router.

There was an abundance of space on Z (NAS) as well as all network shares on all of the NAS devices.

For some unknown reason, I haven’t been able to reproduce the issue. I can’t recall an event or trigger that may have fixed the problem. I have now done “Backup Now” to multiple NAS drives that have all been successful. Roon hasn’t yet backed up according to the scheduled backup, so I don’t yet know if that will be successful. I’ll let you know if the scheduled backup doesn’t work.

Thanks a lot for your help as well as your patience in between my replies.


1 Like

Thanks for touching base with me @Luis_Puncel, the feedback is very appreciated and no apologies necessary. I am very pleased to hear things have stabilized since we last spoke.

I am going to be closing this thread out BUT if the issue happens to resurface just drop me a PM and I will be glad to help continue troubleshooting.

Happy listening!