Automatic Backups Not Found in Roon Backups

I have configured Roon to backup every week to a network share. The latest backup is “successful” (July 29 at 4am):

But, when I view the backup folder:

I only see one backup listed (from July 8).

@support, how do I find the weekly backups?

Hi Nathan,

In Find Backups, what happens if you go one folder further into RoonBackups?

Or, in Scheduled Backups, click 3 dots icon and select Clean/Restore. What do you see there?

Cheers, Greg

Roon appears to use the same backup directory for all backups. If you drill into that 10…b6 directory, there will be a bunch of sub directories, each with a bunch of smallish files in them. Then there will be an ‘xx’ directory at the end, with a file for each backup performed. The file is basically an index into the other directories for the files that represent that backup. Doing this, if there are parts of the database that don’t change from one version to the next, they don’t have to back them up, they just increment their reference count. It makes for versioned, incremental backups and is actually a fairly advanced way of doing backups.

But it is true that it’s not exactly user friendly or obvious when it comes to checking on it, or wanting to do a restore. But is it worth spending the resources to enhance a GUI element that hopefully most users will never need to use vs. work on more important, wide-spread usage features? Instead, support can just help walk users through a restore if they need the assistance.

Hello Greg. Same result: a single July 8 backup.

Another question, what are you using as a Roon Remote and what version of Roon is it running?

May need to turn this over to @support.

Cheers, Greg

I am not sure I understand. If there is no way to verify a backup, and no way to do a restore via the GUI, then why do scheduled backups? I’d be better off just running a backup manually (perhaps using different folders), just to ensure a restore? Or am I missing something?

It used to be that the Roon GUI listed multiple snapshots, so I am uncertain whether this current behaviour is a bug or an enhancement.

iOS iPad 333
Windows 10 334
Core: 334

If you go the route of backing up the database yourself, make sure you shut down the Roon server while performing the backup. Otherwise, you’ll likely have some files that are out of sync because they haven’t had the database engine commit its changes to disk.

And Roon is making multiple backups. But its doing it in a version controlled manner, to a single backup ‘container’. What would be nice is if they had a backup integrity check option, like many “big boy” backup platforms provide. This would make it read the index files for each backup snapshot and ensure all the underlying raw files are present and readable without CRC error.

I just checked my system. When I click on the ‘Find backups’ button, it then gives me the browser. I select the “RoonBackups” folder in the root of the network share on my NAS that I send the Roon backups to. It then showed me multiple backup versions available there. (The screenshot shows only three, since I am a new user of Roon, myself, and three is all it has taken in the ~two weeks I’ve been using Roon.)

Thanks. I meant doing an on-demand backup using the Roon GUI, so yes the server is stopped as part of that process. Good reminder though.

I appreciate the assistance.

Edit: saw your post. I don’t get the listing that you get, regardless of how far I migrate. And, there seem to be two folders, one in RoonBackups and one at the parent level.

Is it possible the 10… folder you have is from an older version of Roon, and 1.5 now uses the ‘RoonBackups’ top level folder? Again, I’m new to Roon, so I’ve only ever used version 1.5.

Actually, no, because I created this folder and schedule this month. I think the duplicate folders must be the problem, that somehow the scheduled backup updates the parent folder but the GUI looks in RoonBackups.

Maybe the thing to do then is just purge everything from that network mount point at let Roon start over from scratch?

Hello @Nathan_Wilkes,

Thanks for contacting support, I’d be happy to take a look over this issue with you. Can you please let me know how you’ve accessed the Backup Manager window so far? Has it been through Settings -> Backups -> Find Backups or through Settings -> Backups -> Schedule Backups -> 3-dot Drop Down -> Clean/Restore? Is the result the same when using both methods?

I would also double check that you have the correct folder location selected, the automatic backups should be listed under RoonBackups folder and not the root directory. It seems that you may have used this folder location for a manual backup at some point and Roon may just be reading the manual backup you made instead of the automatic ones, not sure why that would be the case.

A few other suggestions, can you try selecting another folder on your hard drive and see if automatic backups work to that location? If you perform a few manual backups, do those all show up in Roon? Are you able to successfully restore from the manual backups? (you can try to do so on another machine if you want to be cautious). Can you please let me know what kind of NAS you are using as your backup destination?

Please let me know the above information when possible.


@noris thank you for your help.

Yes, same result.

This is not my experience of the GUI. Using my iPad, I can select the parent folder, the nested RoonBackups folder, and even any of the buried folders, and the GUI finds the same available backups.

In my case, using the scheduled task functionality in a dedicated folder, only the initial backup is displayed as available, even though recent tasks state backups as successful, as per my initial screenshots.

I didn’t, but I understand that you have to take my word for it. When you say manual, do you mean using the GUI? And, if I did (for some reason), are you saying that the scheduled task would finish but create unavailable snapshots in that scenario, that they use mutually exclusive syntax?

Yes, this works fine, as that was one of the first tests I performed in a separate folder. Do you need a screenshot?

I don’t have another machine at home, and I am loathe to test a restore on the production NUC for obvious reasons.

Synology 415+

I have not tried creating a new share, devoted completely to a Roon backup schedule, but I may do this just to solve my problem. The reason I brought the issue to support is that to my knowledge using the Roon GUI I have a scenario where the messages say that backups are made but they are not actually usable in practice. At a minimum this is a precarious state to be in, as it should not be possible to have reported “success” that either isn’t true or not accessible to the user. I would hate for another person to depend on the backup mechanism and find out that in fact it hasn’t worked for them.

I have spent no time trying to figure out whether there are some dot files I could edit to repoint things, or tried to merge the two folders using rsync, or whatnot. As I said, I’ll simply recreate everything. But for whatever reason [Edit: snipped some poor choice of words] I get quite nervous when backup systems are fragile, or at least appear to be so.

I appreciate your help. Nathan

Hello @Nathan_Wilkes,

Thanks for letting me know your reply to the above questions. I have started a case for you with our QA team and we are investigating why this behavior may have occurred. They have asked if it would be possible for you to archive the affected backup folder and send it to us as a .zip file for analysis. I will PM you instructions shortly on how to send that to us, as it would be very helpful in diagnosing the cause of this issue.


Hello @Nathan_Wilkes,

Appreciate your patience while the QA team reviewed the files you sent to us. They have unfortunately been unable to reproduce the issue you have but did notice that there seems to be a problem with the file header for that folder’s backup structure. If you create a new folder in that share and use that new folder only for automatic backups, are you still having any issues with the backups restoring? Please let us know when possible.


Thanks for the update @noris . To recap:

  • Share: “unix-backups”
  • Parent folder: “ROCK-backups-2018” # Folder only used for Roon backups, never any other functionality.

Config files that I see:

_roon_backup_root_ ("ROON BACKUP ROOT v2", modified Aug 5)
10c.../_roon_backup_ ("ROON BACKUP ROOT v2", modified Aug 5)
10c.../xx/* #weekly backup summary files here as expected, inlcuding the first July 9 scheduled backup

This is what is being updated via the scheduled task, and success reported. Modified file dates within 10c…/* confirm this, as well as xx/* summary files as expected.

RoonBackups/_roon_backup_root_ ("ROON BACKUP ROOT v2", modified July 8)
RoonBackups/_roon_backup_ ("ROON BACKUP ROOT v2", modified July 9) # only file within RoonBackups/* that seems to have been modified by the scheduled task on July 9
RoonBackups/10c.../_roon_backup_ ("ROON BACKUP ROOT v2" modified July 8)

This folder (“RoonBackups”) is what the view functionality sees as an available backup location, and reports only July 8, as xx/* only contains July 8.

Presumed order of events:

  1. Manual backup July 8. Creates RoonBackups folder and subsequent RoonBackups/10c…/* data. Records file in xx/ for July 8.
  2. Schedule creation for weekly 4am using same parent folder.
  3. Scheduled task creates 10c… folder (at parent folder level), and updates this folder instead of RoonBackups/. Success reported in GUI every week. Weekly summary files in xx/, including initial July 9 at 4am.
  4. View backups (or clean) only sees RoonBackups/* as a viable backup location (is this hard coded?), but only the initial July 8 (presumably manually created) backup is available. No other backups found by GUI outside of this location (so 10c…/* folder is somehow either incomplete or ruled out by software).


My intended procedure to start fresh:

  1. Create empty folder
  2. Create manual backup
  3. Create scheduled backup using same folder.

Is this correct, or are these actions incompatible?


  1. The manual backup functionality creates a “RoonBackups” folder automatically. When one creates a scheduled task intended for the same “location”, does one select the parent folder (and the tool knows to use or create the “RoonBackups” folder), or the “RoonBackups” folder?

  2. Or, should one only use the scheduled task to make the first backup?

Hello @Nathan_Wilkes,

Thanks for letting me know the recap. I have forwarded your comments to the QA team and they have advised if you can run the backup test in the following way:

  1. Create an empty folder
  2. Set the empty folder as your automatic backup location
  3. Only let the automatic backups occur in that folder, do not an initial manual backup to that folder.

The actions you listed for the start fresh procedure should also work but I want to confirm that automatic backups in itself work for your machine first, so for your questions I would go with option #2.

Hope this helps and please let me know how the test goes!



@noris, thank you for the update. As requested, I have started a new backup schedule in a new empty folder, and this seems to be successful:

Obviously, I’ll wait for the next event in a week, and let you know. (I decided to not set a more aggressive schedule and then edit later – I wanted the generic use case.)

I would like to comment on the GUI though. When one views the summary page, in my case the status reflects the last manual backup rather than the latest successful backup (which was via a scheduled task and more recent). I’d suggest either separating the two processes, or (better) reflect the latest backup (and maybe indicate whether manual or scheduled). Let me know if it would be helpful to mock this up.