B1191/B129 ARC "Can't connect to your Roon Core" message both on home wifi and on cell network [Resolved]

I am all up to date. ARC B129 on Android, B1191 on ROCK. Port is open, static public IP, can successfully connect to the port from phone network with a port scanner, Roon ARC settings says Ready.

However, ARC says “Can’t connect to your Roon Core” and “Core last seen 13 days ago”. Even when I am on the home wifi, and same from cell network or work LAN (where it worked before as well)

From Christmas to 13 days ago, I was traveling and ARC worked. The next 7 days I didn’t try to use it and didn’t have the ARC app open. Then I tried 6 days ago and had the same messages (except it was saying that Core last seen 7 days ago, obviously). I thought maybe it was because of B116 not coming through the Play Store, so I didn’t report.

But now same issue after updating.

The previously downloaded albums can still be played. (Though as usual the album art is missing from many when it’s offline, though not all of them, and where it exists it is in very low-res. This is although every file has the hi-res art embedded. Super annoying, hope this will be fixed soon as well)

Thanks for reporting this. I’ve seen similar behavior and we’re investigating it now.

1 Like

Now with B130 it says “Core last seen 1 month ago”, which is definitely wrong even for loose definitions of 1 month, because I definitely used it on Dec 29 as described above. When it said “13 days ago” at the time of opening the thread (2 days ago), that was reasonable (even though normally it should have been able to see it)

No change with B1197/B132. Any idea when I might be able to use ARC again? Anything I can do to help?

From December to the beginning of January, AVM released new Fritzbox updates. Could that be the reason?

You could check when the last update was, under System settings.

No, I have the same OS 7.29 that I had since I owned the Fritzbox in September. (Last autocheck on the 19th, it does find the new 7.50 now when I check manually)

And I have the “can’t connect to core” issue on the home wifi as well, this makes no sense at all :slight_smile:

Edit: No change after updating the FritzOS to 7.50

Okay, have you ever tried ARC with another device, other phone or tablet, just to rule out any default settings on your phone being to blame?

I have a static public IP, purchased just for ARC. It worked on this same phone until at least December 29 when I traveled back from Christmas holidays. I know because I used it on the train. Then it stopped working out of the blue.

I had no updates on my phone when the problem started as far as I know. It’s a Fairphone 4 running the latest FP4.FP4I.A.175.20221207 update, which was released on Dec 19. I am nearly sure that I ran that update as soon as it was released, i.e. considerably before the problem started.

Otherwise no update in Roon during that time, nor anywhere.

Even if the problem is something with the phone update, it should ideally be fixed / worked around in ARC because ARC stopping to work randomly because of minor Android updates is not acceptable in real life. I’m not going to fix it every month, and I am sure Roon doesn’t want users requiring support after it already worked and although nothing major changed. It just has to be more resilient IMHO

As mentioned, it makes no sense whatsoever that ARC can’t find the core on the home wifi. The regular remote can, including on the same phone, and everything else in my home network works. (It’s a simple one as well, the Fritzbox and a switch)

The Roon ARC settings claim that it’s “ready” for outside access, just like it did when it worked. The port forwarding is fine. I can scan the port from the outside and get “open” as I should.

Michael wrote above that they have seen something like this and are investigating, and I’m willing to remain as a test case. It would just be nice to get info if there is any progress and when I might be able to use it again.
(We have had 2 updates since my report. The first one changed nothing except that it started to display a nonsensical date for when it last saw the core, as it definitely saw the core longer than on Dec 13 because I used it on Dec 29.
The new update now changed nothing visible at all.)

I can try it on a tablet in the home wifi, good point (none of my tablets can do cell networks), but even if that works it doesn’t explain why it fails on the phone and this needs to be fixed anyway. If Michael wants me to try that, let me know - that’s why I am in EA, to help.

I deliberately haven’t reset or reinstalled the ARC app on the phone because I don’t want to destroy a possible test case. (Plus I don’t want to redownload my albums yet again, but it’s fine if it comes to that if I am advised to do it)

I see. However, there must be a cause. The problem does not appear to be widespread, so I’d put Roon on the back end as the sole cause.
There are other options:

  1. Your phone’s incompatibility, for whatever reason, which you might find out by using another device.
  2. Any service change from your ISP that you are not aware of.
  3. A quirk in your Fritzbox that you don’t know about. It wouldn’t be the first flaw.

So, in case you have some free time and you do mind waiting to use ARC again, you could check:

You can try to clean up your FB MAC list in Home Network Overview > Network Connections, making sure there’s no conflicts, and recreate the forwarding rules.

Make sure that LAN guest access is disabled.

Also port forwarding to a range like 55000-55002 instead of forwarding to a single port.

Under settings check Internet => filter, click the Parental Controls tab and check if internet usage is restricted for the device to be accessed.

Also under “Filter” click on the “Listen” tab.
Click on “Globale Filtereinstellungen” to view all filter settings.
Try to disable the “NetBIOS filter activ” option.

(Not an issue for me, because my FB is used in another network just for failover and telephony)

After saving the settings, it might help to unplug the box for a few minutes and then reboot everything.

Thanks, but my problem is that this whole thing should not happen in the first place. All your suggestions about forwarding rules, port range, blocked IPs, etc. should not affect ARC access from the LAN at all. If they did, it would be a flaw in ARC that needs fixing.

I reported the issue, was told that something like this has been seen before and they are investigating, and since then I’ve been left hanging without further instructions or information.

Any change on my side could destroy a relevant test case, so I have been avoiding them. I am happy to make all kinds of changes and perform tests, but I’d prefer if @michael told me so

Hi, @Suedkiez, could you, please, provide more info about your network setup? May I also ask you to specify the model of device you are having issues with? Do you have another device you can try on the same environment? If yes, does it exhibit the same behaviour and cannot connect to your core while being on the same network.



Thanks for getting back.

Core is ROCK, wired to a dumb switch and from there to the Fritzbox (model see below).

Remotes are on MacOS Ventura, iPad Pro with iOS 16, my Fairphone 4 (remote and ARC currently only on that one), an Android phone (Motorola G8 Power, Android 11 I think) and an Android tablet (Samsung Tab A 10.1, also Android 11). All up to date with latest earlyaccess builds.

All of these remotes can connect to the core without issues on the home wifi. Including the Fairphone, just ARC on the Fairphone can’t, neither on the home wifi nor externally.

As mentioned above, the Fairphone is running Android 11 with the latest FP4.FP4I.A.175.20221207 update, which was released on Dec 19. I am, however, nearly sure that I ran that update as soon as it was released, i.e. considerably before the problem started (some time after December 29). You can find the precise dates, as well as I managed at the time, in my above posts in this thread.

ISP is Vodafone Germany cable, which uses DS Lite in residential contracts, so to be on the safe side I switched to a business contract that includes a static public IPv4.

Router is a Fritzbox 6690 Cable, it is my own private one. It used FritzOS 7.29 during all that time while ARC worked (starting in September after I got it until today’s morning, when I updated it to the new 7.50 to see if it makes a difference - it didn’t)

I used UPnP to configure port forwarding. The Fritzbox allows enabling UPnP for specific devices to be chosen by their network name, so that seemed most sensible. The rule had a green light when I checked this morning, so seems still OK.

After having this setup, my public interface worked. ARC worked just fine and I could port scan the public IP from external and the port showed as open. Obviously, ARC also worked on the home wifi.

I used ARC over Christmas while traveling and the last time on December 29 when traveling home. Then I didn’t use it, as described in the OP, and 13 days ago I noticed the issue described in the OP

  • Message: Can’t connect to core
  • Message occurs in my home wifi and in external networks (cell and work LAN; ARC previously worked from both)
  • Roon ARC settings in remote says “ready”
  • I can still port scan the IP from external and the ARC port still shows as open

When I noticed the issue, I was still on the pre-Christmas ARC build, I think 111, as 116 was stuck in Google review. I didn’t report then because I thought I might need 116 and didn’t want to install the APK. Then I got build 129 and nothing changed apart from the “core last seen” message now showing a nonsensical date (“one month ago” immediately after 129 installed, which would have been significantly before I definitely last used ARC on the journey). That didn’t change with the latest B130. Find more exact details in my previous posts, please.

I can try ARC on the other Android phone (the Motorola G8 Power) and the Android tablet (Samsung Tab A 10.1). The phone could also use my SIM card for external testing, the tablet can only do wifi but might also be helpful as the issue occurs in wifi as well. Both have Android 11 IIRC.

As mentioned, I have avoided resetting/reinstalling ARC on the Fairphone in order not to destroy a test case, and because I would prefer not losing my downloads for the fifth time.

Please let me know what I should try. Obviously, resetting/reinstalling ARC on the FP4 is also ok if need be

Thank you for your reply. Could you, please, do this

It’s going to be a good data point here.



Will do tonight. Can obviously also try on the iPad

Thanks! Looking for to hearing about the results.


Results are in. For now I only installed ARC on the Samsung Galaxy Tab, on my home wifi. It found the core, synced, no issues. I guess that’s good enough to show that there is no major issue with the core nor with my account or its ARC credential magic in the Roon cloud.

I would say next step is to make the Fairphone’s ARC find my core again in my home wifi. I am pretty sure that after that works, the external connection will be just fine. Agreed?

So I guess the question is how. I can just reinstall ARC on the Fairphone and see if it works again. If it does, the evidence for why it crapped out for no obvious reason will be gone, I suppose. (If it still doesn’t work, we have narrowed it down to something with the Fairphone). Do you want to get anything off my Fairphone (I don’t know, some ARC files, logs, whatever) before I try that?

Or any other suggestion? Please let me know your preferred next step

Thank you for your reply, @Suedkiez. I think good next steps here will be the following:

  • While you are still in that state, collect ADB logs (Android OS level logs) from your Fairphone. Here’s how you can do this:

Connect your PC to Android phone and install ADB (instructions are here (all platforms)). Then:

  1. Type adb shell in terminal
  2. Type logcat v (ref: Ferramenta de linha de comando Logcat  |  Desenvolvedores Android  |  Android Developers)
  3. Reproduce the problem and let terminal print logs for 3-5 more seconds
  4. Select output from the moment you started the reproduction of the bug till the very end
  5. Upload the log here and let us know once you have done so – https://workdrive.zohoexternal.com/collection/8i5239cc05950ac07456889838d9319545a82/external
  • When it’s done, if you are OK with that, I’d ask you to reinstall Roon ARC on your device affected by the issue and see how it goes



1 Like

Hey @Suedkiez, @ivan
Reading your answer, something came to mind from an old thread when ARC was new to early access:

Because I was thinking at the time whether a Fairphone could be something for me, I asked myself what this bug was all about?
Maybe you still know and it could be useful in clearing up this matter here.

This bug was fixed by Fairphone months ago and was something completely different. Note how my old post you linked was talking about cell data not working. Here in this current case, the most simple incarnation of my current issue is that the Fairphone has suddenly stopped finding the core on wifi as well, as I have written several times. Until it works on wifi, none of the port forwarding and cell network stuff matters, let us deal with that later if necessary :slight_smile:

(In the old issue, my then-new Fairphone did not get a cell data connection on the Vodafone network at all, using the default APN settings on the Vodafone SIM. However, as it turned out eventually, creating a new APN entry with the exact same settings and using this, it worked. It was super annoying at the time because of additional complexity while sorting out the port forwarding with VF (or rather the full-range port block imposed by VF apparently accidentally, if I remember correctly that this was the issue at this particular point in time :rofl:). Baffling too, as Vodafone was also selling Fairphones in their mobile contracts and did not know about the issue when I called their support, but the Fairphone forum was full of new FP owners on VF experiencing this issue. Some forum members had already identified the APN settings as a cause, but had not fully understood it. Then it took me half a day of dicking around in APN settings to figure out the details and make it 100% reproducible (there had to be a very specific sequence of doing things), and to report the findings to Fairphone. I think it was some issue with reading the APN supplied by VF from the SIM, so the same settings in a new APN entry worked around it, before it was fixed)

(If you considered a Fairphone, by the way, after this initial obstacle I am really happy with it. There is another cosmetic issue I reported that I still find mildly annoying but YMMV: They show traffic arrows in the notification bar top right, next to the cell network icon, but they forgot to reserve space for them. So when the traffic status changes, the other notifications jump a bit when the traffic arrows appear or disappear, i.e., all the time when you do something on the phone. If this doesn’t bother you, it’s a fine phone. No featherweight though)

1 Like

I’ll supply the ADB logs tomorrow or so

1 Like