B475 Roon won’t load after upgrade (MacBook Pro. OS 10.10.5)

Core Machine (Operating system/System info/Roon build number)
MacBook Pro. OS 10.10.5

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
I received an upgrade prompt a couple of days ago. Roon has not finished loading since. I saw the posting regarding the OS issue to be resolved. I know that I might be able to rebuild with an older version but I thought the next upgrade prompt received would resolve this issue.

I just responded to the second prompt. It still doesn’t load. The timer just keeps running. Please resolve and prompt for next up-issue.


I think there is a solution for this somewhere here, but I don’t know what it is. You might want to search around a little.

@support there is an issue that involves going back to B416 and there is a direct link that support will PM you.

Having same problem on my 10.10.5. After last update, launching roon icon bounces but never run . . help me please! thx

Hi @Gerhard_Martan and @mario_imperia,

Please see my post here:

thx a lot for your efforts!

Same problem for me with 10.10.5. I’ve gone back to Build 416 as instructed. Thank you for posting the fix… One suggestion: Turning off Automatic updates requires finding the Gear icon.

how can i disable automatic updating ???

Go to Settings/About, and click on the gear icon by your Core…

Done. thanx!

… this only works with a PC (Windows or OS X) version of Roon and is not available on mobile (Android or iOS) versions.

1 Like

When you fix this can there be an update prompt that will resolve this without having to do a fresh install? Possible ETA? Meanwhile, it’s vinyl…

Hi @Gerhard_Martan,

The only thing to install here is the 416 client — This does not impact your database. You can install 416 without having to completely start fresh with Roon.

OK. I took it back to B416 and, after a long time, it did reload OK. I turned auto-updates off but Roon still kept prompting to upgrade which I ignored. Since doing this I am having a lot of trouble with Tidal being slow to load songs. This morning, instead of streaming to my AURALIC Vega G2, I connected my Dragonfly Red to the Mackbook Pro USB port. It did not show up in Roon so I rebooted the MacBook. It appears that Roon did it’s upgrade again now and won’t complete loading.

Any ETA about when this might be resolved?

This just got interesting. Although all upload speeds are 20 Mbps, my download speeds for all devices on my network is 70mbps with one exception, the MacBook Pro that is running Roon. It only reaches 13.4mbps regardless of whether it is WIFI or Ethernet connected. This is likely why Tidal is slow to load on Roon although neither the Tidal app or Audirvana exhibit this issue. I know that this is not related to the B416 issue. The MacBook is late 2008 with 4 GB 1067 MHz DDR3 and a 500Gb SSD. Can anyone confirm if this is normal for a MacBook of this age?

That’s an ancient machine spec to run a roon core on, even with an ssd

It was left over after we all went to tablets. Up to now it has worked really well. You just can’t use DSP much but that is also true of the basic Nucleus per the description.

Hi @Gerhard_Martan,

As wizardofoz mentioned, it’s definitely an older machine that may be more prone to performance issues.

It’s hard to say exactly why that’s happening, but it can definitely be impacting Roon’s ability to play TIDAL content.

What is the router you’re using?

Right now I am using the Actiontec T3200 from my ISP/carrier. Both the MacBook Pro and my Windows 10 PC are plugged into it with 6 feet of CAT 6 cable yet the PC tests out at 4 times the download speed of the Mac. Upload speeds are identical. I’ll get it independently checked tomorrow. If that is normal for the year then it is upgrade time.

I hope, though, that the Roon update for the software issue is soon resolved even though I am really enjoying vinyl and SACD disks again. Everything else, CDs and HiRez downloads, is on the MacBook.

Maybe get a MAC compatible USB wifi dongle… I’ve done that for a few ol MBP’s that the wifi had died on.