Backup creating strange files on Synology NAS

I’ve spent years meticulously curating my music collection, with folders for each artist containing folders for each album. Now that’s all gone. This is what I find now:

I can still play music with Roon fine, just can’t find any of the folders. I’ve read that in 1.2 there was an “organized” folder function which could maybe do this, but I started with 1.3.

I’m running 1.3 (200) on a sonicTransporter i5.
The music folder in question is on a Synology NAS.

I can’t help with an answer to why your music folder looks like that. But if you have only used Roon 1.3 and never used Roon 1.0, 1.1 or 1.2, then I don’t think Roon is the culprit. From v1.3, I don’t think Roon has the capability to edit your files, move or rename them. So it’s hard to see how Roon could have done it.

Since all those folders and files were created about 2am today, perhaps check and see if you had any other processess scheduled for 2am - backups, disk maintenance, anything else?

Hope you have backups of your music folder.

David please check the folder names via the FileManager in Symbology’s DSM desktop. If my hunch is right you will find the folder names all in tact via FileManager. If my hunch is correct you’ll also find that the folder names have used a special character not permitted SMB. Here is a link to a thread that I worked out a similar issue.

Hopefully my hunch is right and this helps you.

I think rayski is right, I’ve had this issue with a USB drive plugged into the sonicTransporter.

From my iMac the folder names looked messed up, when browsing the USB drive over the network.

But when the USB drive was plugged into the iMac, all the folder names were fine.

But the affected folders had characters like ! and ? in them. I’ve manually changed most now.

This is a relatively common issue when mounting shared from certain NAS’s on Macs. It is impacting the Mac’s ability to understand the filenames. So it’s displaying “mangled names”–placeholders–instead.

This is not a symptom associated with any kind of data loss. The files haven’t been renamed or moved around by anyone, they are just displaying incorrectly.

I’ve never run into this situation with a NAS personally, so I don’t know exactly what the fix is going to be. Hopefully someone else here has a good answer. Synology’s support team may also be able to help.

This stackexchange thread might be a decent starting point:

The actual behavior is called “mangled names”–that might help you with search terms. I’d start with “synology mac mangled names”.

But I wanted to reassure you:

  • Roon did not move your files around–even pre-1.3 we did not create directory structures that looked like this, and 1.3+ builds no longer contain code that moves media files around at all.
  • Your data is almost certainly just fine. Once you resolve the configuration issue things should be back to how they’re supposed to be.

Obvious but having a backup is always good.


The joys of SMB mounts…

Thanks @rayski. This sounded plausible, but I think it’s more complicated. See below.

Hi David,
Are you connecting by smb or afp to your Synology?
Does the file nameing change when switching the protocol from smb to afp or vice versa?

@brian Thanks so much for the reply. I think, and hope, that you’re right about my data being intact. However, I don’t think this is just an SMB naming issue. I’ve been connecting to this NAS via SMB for years with no problem. I tried connecting to the NAS via the Synology DSM FileManager. It kept hanging with a non responsive script, but I eventually got it to load. What I find is 27K files related to Roon backup.

These all seem to have been created 2/12/17 at 2 am, which is when Roon was scheduled to backup. Ronn says the backup was successful.

Not sure how to connect via AFP

It looks like you created backups in your Music directory.
Can you post a screenshot of your scheduled backups settings of Roon? Like this one:

Yes, I put the back ups in the Music folder. Guess that’s a no-no?

However, all these 27K files are not in the folder I created called RoonBackups.

Whoa :open_mouth:!

It would appear that rather than create a folder called RoonBackups to contain all of the backup files (which then results in a fairly deep directory tree containing tens of thousands of files) Roon created a bunch of folders with names that contained the full path name in the folder title! Yikes!

For instance my backup tree looks like this:

… and it just goes on from there.

Why this is happening is something that needs to be solved, but in the mean time I’m 99.9999% confident that your music folders are not impacted. If you click on the >| at the bottom of that file browser window you should see the tail end of your artist folders.

These folder names that got created are extremely long, which isn’t a problem for the Synology or Sonic Transporter (Linux), but they’re too long for some SMB implementations so the path names are getting mangled in the Mac’s finder view. On the Mac things that start with a non-alphabetical character are shown first so that’s why you’re seeing all of the gibberish first in the display.

So how to clean up? Well, if it were me I would just go into Roon’s backup settings and clean (delete) all of the prior backups, which should result in all of those files being removed… but that’s just me and I have multiple backups of my library so even if I blow something up recovery of the library is a click away.

I think it’s wise to get @support pulled back in here just to make sure that we don’t make the problem worse.

The backup is being run on your Sonic Transporter which is writing files to the Synology. There could be an issue with the SMB implementation that the Sonic Transporter uses which could be leading to this rather ugly bug. I’m running a couple of cores on Linux accessing a Synology share for backup and have never had a problem like this pop up so I’m more inclined to say that this is an issue with the ST’s implementation of SMB rather than how Roon is doing its backups.

My concern here is that the Sonic Transporter’s writing of your backups created the issue in the first place and I wouldn’t want to see an attempted mass cleanup result in an accidental destruction of your library. That shouldn’t happen, but neither should the problem that you’re trying to correct!

looking into this… the problem is that somewhere backslashes are getting inserted into the filenames for the backups…

@vova has tried to reproduce and failed to reproduce this issue…

@David_Frantz – can you work with @vova to figure out how your situation differs from his tests?

Thanks Danny! Glad to work with @vova. In the meantime I’m manually deleting the backups. Can only do 1,000 at a clip, so it’s a little labor intensive.

I’m thinking about making a new place to back up to, at least temporarily.

Hey @David_Frantz,

I PM’ed you with a detailed instruction how to send us logs and few questions.

Excuse me? Temporarily? Er no, one should never, ever, ever use the music folder to hold backups. :wink:

I’ve made it so the next build will ignore RoonBackups from the music folders, but yah, you shouldnt really use the music folder to hold your backups…