Backup failing (Warn: [backup] failed to sync: putfile hash:)

Roon 1.8 build 783 running on QNAP TS453-BE (NAS2)
Library stored on QNAP (NAS2)
Backups are set on 2 locations NAS2 + Synology DS213+ (NAS)

Backups on NAS2 are ok.

Backups on my secondary storage location (NAS) are unable to complete. They were working perfectly for a while until I disconnect the NAS for a few months and brought it online yesterday. Now they consistently fail.

You will find below 2 different occurrences, the 1st on the initial location

\NAS\Backup\Roon\RoonBackups

and the 2nd on a new defined location
\NAS\Backup

I guess there is no problem with file access protocols and shares configurations or permissions as in both cases we have a lot of stuff that are written but still I might be wrong :slight_smile:

Thanks for your help here,
Cheers,
Fabrice

Full logs are here:

https://1drv.ms/u/s!Apw_SwC0TXUogwJvKbOwoHmslOD-?e=FJPA3E

04/03 12:42:44 Warn: [backup] failed to sync: putfile hash: AttachedDir:/mnt/RoonStorage_7cd312293a7baac3ccd01ff57d32359844c46d71/Roon/RoonBackups/f4024d5e-da74-3db1-0cce-7af310fee133/a0/63/a063ce65fde5df0341104cef56495592c0a0c8aa0a8da3ee5fc2c4289fd2bc9d: Result[Status=UnexpectedError, ErrorText=System.IO.IOException: file move failed: -1 errno=EHOSTDOWN
  at Base.IO.LongPathFile.Move (System.String srcpath, System.String dstpath) [0x0006c] in <f2349cb8930a4218a7fa0c14ec58c0d6>:0 
  at Roon.FileSystem.AttachedFileSystem+<>c__DisplayClass15_0.<PutFile>b__0 () [0x000a7] in <36423a3eaa0a45c6b4af61daf2b02c58>:0 
  at System.Threading.Tasks.Task`1[TResult].InnerInvoke () [0x0000f] in <49e2691b1d1a45389d419b3a01a2b89a>:0 
  at System.Threading.Tasks.Task.Execute () [0x00000] in <49e2691b1d1a45389d419b3a01a2b89a>:0 
--- End of stack trace from previous location where exception was thrown ---


04/04 07:29:01 Warn: [backup] failed to sync: putfile hash: AttachedDir:/mnt/RoonStorage_7cd312293a7baac3ccd01ff57d32359844c46d71/f4024d5e-da74-3db1-0cce-7af310fee133/2d/83/2d8399a047d597cd710dcebe5bb258ab957e5bc08e6cf988d4075c5b74960ff0: Result[Status=UnexpectedError, ErrorText=System.IO.IOException: file move failed: -1 errno=EHOSTDOWN
  at Base.IO.LongPathFile.Move (System.String srcpath, System.String dstpath) [0x0006c] in <f2349cb8930a4218a7fa0c14ec58c0d6>:0 
  at Roon.FileSystem.AttachedFileSystem+<>c__DisplayClass15_0.<PutFile>b__0 () [0x000a7] in <36423a3eaa0a45c6b4af61daf2b02c58>:0 
  at System.Threading.Tasks.Task`1[TResult].InnerInvoke () [0x0000f] in <49e2691b1d1a45389d419b3a01a2b89a>:0 
  at System.Threading.Tasks.Task.Execute () [0x00000] in <49e2691b1d1a45389d419b3a01a2b89a>:0 
--- End of stack trace from previous location where exception was thrown ---

  at Roon.FileSystem.AttachedFileSystem.PutFile (System.IO.Stream srcfile, Roon.FileSystem.IFileSystemDir parent_, System.String destname, System.Boolean overwrite, System.Threading.CancellationToken canceltoken) [0x000df] in <36423a3eaa0a45c6b4af61daf2b02c58>:0 ]
04/04 07:29:01 Warn: [broker/backups] failed sync on FileBrowser.Entry: \\NAS, backup : \: Result[Status=UnexpectedError]
04/04 07:29:01 Debug: [broker/backups] on done, auto: False
04/04 07:29:01 Debug: [broker/filebrowser/volumeshare] Use dispose, id: \\NAS\backup
04/04 07:29:01 Info: [broker/filebrowser/volumeshare] Volume's removable changed: True

It looks like the Synology is going offline during the backup process.

Hi Martin,
I need to check this out, thanks!

I have just checked. There is no power saving plan configured, including disk hibernation. NAS is supposed to operate 24/7.

Cheers,

The logs say that Roon was unable to complete an operation because there is no response from the host.

Hi @Fabrice75017

As Martin suggested, it looks like the Roon is unable to properly communicate with the NAS during this time. Does this happen even if you were to do a Backup Now while you know that the NAS is online? Were you doing Scheduled Backups before?

Hi Dylan, Martin,

I understand your first assumption.
Still, the issue occurs at each and every backup execution, planned or manual.
I have tested this a couple of times and the extracts that I provided where issued from manual backups.
The log files will show both, planned or manual. Results are strictly the same.
NAS has been restarted a couple of times, when manual i’m actively monitoring and make sure that NAS operates normal, not idle or any other suspended state…
Also, I’ve been doing scheduled since 2y on NAS before it stopped working.
Cheers,
Fabrice

How are the NAS and Roon Core connected to your network?

Hi, everything is connected through my netgear r8000

Ethernet or Wi-Fi?

Sorry, ethernet !

1 Like

As mentioned in an earlier post, the error message clearly shows that the Plextor PX-NAS2 is dropping the connection. It should be noted that the error doesn’t mean the NAS2 is unreachable but rather the NAS2 is closing the connection for some reason. This could be caused by a number of reasons including depreciated software (the NAS2 is very old now) or performance bottlenecks. Do you have access to logs on the NAS2? That’s where I would start.

Humm…
NAS2 is the QNAP TS453BE. I have no issue on this one, when backuping locally. (Roon installed here).

NAS is the Synology 213+ (pretty old now) and is used a the second backup destination. Issues are on this one.

Do you really mean NAS2 ?

Hi @Fabrice75017

Can you try using the IP address to connect to the share instead of the Hostname? Any change when doing so?

Hi @dylan
I have already tried that with no success.
I can provide the latest set of logs if that helps.
Cheers,
Fabrice