Backup scheduling using UTC instead of local time [Ticket In]

My core is on a NUC8i7HVK and my OS is AudioLinux (Archlinux). Since Roon 4.6 (Build 416] backup scheduling has been using UTC but reporting back in local time. Before Build 416 both were in local time. Is there a way to correct this?

I confirm this issue
Dirk

@support
After further testing, I realize that there is no problem other than with the line
“Last successful backup at …”
It is reporting the wrong time. My time zone is EDT = GMT-4. The line in question is reporting EDT-4. Could this be a coding mistake?

Hello @ronfint,

Thank you for your report here, we are aware of this behavior and have an active ticket with the dev team regarding it.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved.

Thanks again for the report!

– Noris

Hello together,

i’m running a roon server on a nuc system with ubunto 18.04. And it works fine. :slight_smile:

I have only a question about how roon use the time from the server.

The roon server use the local time zone (Europe/Berlin, UTC +0200). The windows client runs also on local time.

I have done a backup and the roon client shows me the success messages with 2 hours in future. I will try to upload a picture with this.

RoonServerTimes

Do i have to switch the time zone on the roon server to UTC or is there a configuration parameter to tell the roon server the correct time zone?

Regards, Henry

Hi @Henry,

Thanks for the report, we are aware of this behavior and have an active ticket with the dev team. I have moved your post into this thread as to keep all the reports in one place.

– Noris

G’day,

I always setup to run two backups each day, one at 2am to the ROCK attached USB stick and another at 3am to a Synology NAS. When I first set them up over a year ago there were problems with the scheduling. I’m in Melbourne, Australia and the backups were running in the afternoon instead of the early morning. This problem was reported and a workaround given by changing the scheduled times to allow for timezone differences. Eventually in an update the problem was fixed, the scheduled times changed to what they should be, and everything worked okay.

After doing the most recent updates I checked on the status of my backups. See attached screen shot. The backups are now running in the afternoon again.

It would help in the diagnosis of this sort of problem if the system date and time of the ROCK were reported on its status page.

Best regards, Lloyd Borrett.

Hi @Lloyd_Borrett,

We are aware of an issue surrounding the reported “Last Successful Backup” time and there is a ticket in for this behavior, please see the thread above. I believe this is the behavior you are reporting here but do correct me if I am mistaken.

– Noris

Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

TEXT GOES HERE

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

TEXT GOES HERE

Description Of Issue

When I backup my Nucleus +, the time stamp that’s displayed upon completion is roughly 7 hours off. How do I reset the Nucleus + time setting?

Hello @Tom_Gurgui,

Thank you for your report here, we are aware of this behavior and have an active ticket with the dev team regarding it.

While I can’t say for certain when this bug will be fixed, getting things reproduced in-house is a critical first step, and I will keep this thread up to date as the team passes along feedback and work begins to get this resolved.

Thanks again for the report!

– Noris

I am seeing the same issue, except my backups are tagged -4 hours from my Time Zone (which does not correspond to any logical Time Zone I can think of. Maybe PST without daylight savings time? It is certainly not GMT).

It seems like there is no way (that I have found) to set the Time Zone in the Nucleus+ software.

It would be very handy to have the backups happen in the Time Zone you are in (for obvious reasons).

Hello @MvB,

Your Nucleus will always operate in UTC time, there is no way to change this, however your Roon Remotes should be displaying backups in the local time.

As mentioned above, this is a bug and we have an active ticket with the devs regarding this behavior.

Thanks @noris.

The question remains, what time is the backup actually happening at?

If I set the backup time to be 1AM Eastern, does the backup happen at 1 AM Eastern? Or should I be setting the backup for -4 hours i.e. 9PM Eastern? Or is this completely a display issue?

Hi @MvB,

The bug here is that the status message is displaying in UTC instead of the local time. The backups should be running according to the local time you specified on your Roon Remote.

@noris I ran a backup today 8-3-2019 and the Last Successful Backup time was not UTC, as best as I can determine. I’m in USA and CDT zone and the backup ended approximately 2:30 pm CDT which from my research is 7:30 pm UTC. Therefore, is this bug still not fixed?

I fear there’s no bug-fix without a new release first.

Hi @RD_A2Z,

Thanks for the additional ping regarding this issue. We have addressed this issue in our next release, however I can’t say when this will be published. Please keep a close eye on our Release Notes Section of this site for when the next release ships.

Hello All,

We’ve just released Roon 1.7 (Build 500) which includes changes that should improve this behavior. Please give it this a try and let us know how it goes!

You can read the full release notes here:


Thanks,
The Team at Roon Labs

Yes, this is working correctly now. Thank you.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.