Backup seems to be ok, but restoring failed


I am switching from a Innuos Zenith back to a MacMini (and then to a NUC).

I tried to backup my Roon database with the Innuos OS, selected the USB HDD. Then I tried to backup ROON with ROON. I got an error massage after 100% finished.

Then I tried it with an SanDIsk 32 GB stick and got the message that the backup was successful.

If I try to restore this backup on my MacMini I select the backup folder on the stick (2 files in there) I got the message wrong path etc.

The audio files were on a second USB-SD which is connected to the MacMini. I selected this in ROON.

What´s going wrong ?

Hi @midi,

Thanks for contacting us, I have a few questions to clarify the issue:

  • What how is the flash drive formatted? I would recommend using exFAT for transferring the backup across platforms.
  • What was the specific error message that you received when the backup failed the first time around?
  • Can you share a screenshot or two of the backup folder hierarchy?


I am not sure, if you get my answer - here once again:

Hi @midi,

Thanks for that screenshot. The “wrong path” message would indicate that you did not have the correct folder selected, I would point the Mac Mini to the “RoonBackups” top level folder and not any of the sub-directories. If that does not help, then you might want to format the flash drive as exFat and create another backup from your Zenith on the drive and try again. Please let me know if that helps.


I think „wrong path“ is not the right translation. I can select the folder but I get this german message

It seems to be „recovery failed. Please check backup-directory and try again“.

So it’s not a problem of the stick.

Other ideas ?

Hi @midi,

Can I please ask you to send us the backup for analysis? You can use part 2 & 3 of these instructions to archive it and get it over to us. If you don’t have dropbox or google drive just let me know and I can provide alternate upload instructions.

Also just to confirm here, you formatted the drive as exFAT and created a new backup from the Zenith and that is still not working as expected, correct?


No, I can not make another backup with the Zenith and a FAT stick, because I have sold the Zenith after the backup.

Before selling it, I tried also a backup with Dropbox, but It was so so slow, that I didn’t finished this.

I will send you the stick backup via dropbox.

I am using Mac OS 10.14.3, so NFTS could be still a problem…

I think the Innuos (as Roon Core) has used NFTS, when the backup started (the Innuos OS is formatting the USB device before the backup).

I couldn’t copy the file from the stick to my Mac´s, without getting error messages.

Now I have used OXFuse for the NFTS problem and I have copied the file to my Mac. Then I have copied the file back to an ex-Fat stick, but restoring the backup is still not possible - I get the same error message as before.

So I will send you know via email the link for the file-download.


I have another problem:

I cannot import new music via ROON to the MacMini connected USB-SSD. Its hanging up, after the first track.

The SSD is also NFTS format - created by the Innuos backup function.

Any help ?

I solved the last problem with the new music import, setting up a new USB SSD formatted with Ex-Fat. Now it seems to be ok. So I cannot recommend using a NFTS device.

My first problem with the Roon database is still unsolved.

Hello @midi,

Can you please send the link to the backup you made?
You can private message it to me by clicking my name here on community and then pressing “Message”.


Hi @midi

Thank you for your private message with the link. I have created a case for you with our QA team who will take a look. I appreciate your patience until this request reaches their queue.


Hello @midi,

I have heard back from QA and this issue appears to be due to the roon_backup_root file being saved as an executable instead of the proper format. Can I please ask you to do the following?

  • Connect the drive containing the backup to your Macbook
  • Make another copy of the backup somewhere safe on the macbook
  • Then open Terminal on the OSX
  • Go to the directory where RoonBackups folder is stored (terminal instructions here)
  • Type the following command:
    find RoonBackups/ -type f -exec chmod 644 {} \;
  • This command will turn all of the executables within RoonBackup folder into files we can actually restore from

If you have difficulties performing these steps please let me know so I can clarify further with QA.


1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.