Backups stopped working

Roon Core Machine

ROCK on Intel NUC

Networking Gear & Setup Details

1Gbps wired

Number of Tracks in Library

25K tracks

Description of Issue

Since a few weeks, my Backups are failing. I’m doing my backups on a USB drive connected to my Intel NUC running ROCK. Roon gives a message that “the backup directory is not available”. But obviously, it is available, since I can select it in the backup configuration. If I start a new backup with a new or empty directory, the backup will work the first time. But as from the next day, the error will appear.

I tried : emptying the directory, deleting the directory and creating a new one … same behavior: the backup works the first time, and fails as from the second time.


I can see that Roon actually accessed the folder at the time it says it was unavailable and started the backup, but all the subfolders are not updated.

And yes, there’s enough free space: it’s a 500GB drive , with 450GB remaining.

Thanks for your support.

The drive is probably allowed to sleep and takes too much time to wake up when needed. If you can disable any power saving options for the drive, disable them as a test.

Thanks, but I should have explained that I’ve been using this drive for over year before the issue started. So that’s not it. I’m suspecting it started with one of the latest ROON updates. I don’t know exactly when because I didn’t notice it immediately.

I have a similar issue. Intel NUC with 1GB USB stick inserted. Used to work fine.

While you wrote:

It looks like the drive is connected to your router instead and shared over the network. My thoughts:

  • Routers aren’t very powerful or optimized for being used as a NAS.
  • There are usually updates for routers too. One of them may have changed functionality or sleep support for your drive.

As looking for settings in your router is free, I would do that and see if there is something that can be done about it.

Note: Actual file access, no matter if local or over the network, is actually done by the OS the Roon Server is running on. There is probably not much Roon Labs can do about it.

Disclaimer: Just the two cents from another Roon user.

1 Like

Yes, you’re right, the USB drive is connected to my router, not to my NUC. My mistake.

However, it doesn’t change the problem. And no, like I said, the drive and folder are accessible since I can select them in Roon when configuring the backup settings. Also, the backup works in an empty folder, but fails as from the second day when the backup folder already contains data. So the drive, and the folder, are clearly accessible and functional. Like I said, this drive has been working perfectly for over a year. But thanks for your suggestions.

Wondering why Roon support doesn’t deem my issue worthy of a response ? I see them answer in pretty much every support thread but not this one ?

Hi @AnthonyH, as a test, can you try connecting this drive to your NUC via USB instead of the router? There weren’t any changes in this area in the Roon app, so I wonder if something changed on the router side. The errors you’re receiving typically mean that we are trying to access the drive and are unable to.

This test will help us understand where the failure might be stemming from.

Have you tried any other backup locations since running into this? Do they have the same problem?