Bad Gateway 502 : Netgear R700P as an access point to Bitdefender Box

Roon Core Machine

Roon Nucleus

Networking Gear & Setup Details

Roon Nucleus

Networking Gear & Setup Details

Using Netgear R700P as an access point to Bitdefender Box. The “Box” is setup for UPnP, issues all the IP internal on a 172 network and protects the network and all attached devices. The Nucleus is hardwired to the network.

Connected Audio Devices

This do work within range from my phone, Galaxy S-22 Ultra, but outside, not in range of the router it does not.

Number of Tracks in Library

N/A

Description of Issue

Bad gateway response 502
{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 75.84.xxx.xxx:36185, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“75.84.xxx.xxx”,“router_external_ip”:null},
“natpmp_autoconfig”: {“server_ip”:“172.24.xxx.1”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“172.24.xxx.1”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}

Any advice would be appreciated, and life will go on :slight_smile:

Thanks

Jeff

Hey @jeffzaret,

Thank you for your patience while we’ve diligently worked to reach every request for support with port forwarding. The diagnostics you’ve provided suggest that UPnP is not properly configured on your router.

Please first try the following steps:

  • Try to enable UPnP/NATPMP in the web administration interface for the router directly upstream from your Core
  • Try to manually open the port in your router’s port forwarding configuration
  • Make sure the IP/Port matches the Port listed in Roon → Settings → ARC
  • Check for any VPNs or Firewalls that might be interfering
  • Check if your modem is in Bridge mode

If you continue to experience difficulties, please tag the support team and include the following information:

  1. What is the make and model of your modem and router?
  2. Do you have any additional network hardware, like additional routers or managed switches?
  3. Who is your internet service provider and what is your geographic region?
  4. Is your Modem configured in Bridge Mode so that it operates only as a modem or do you have the ports forwarded on both?

Benjamin,
Sorry for the long response been trying many things besides working for a living. :grinning:
This is kind of complex but solvable. I use Bitdefender Box to issue IP’s and it accesses everything else in the house. Behind that is a Netgear router R7000P. It is in AP mode not bridged. I can add port forwarding through the Bitdefender app for the router, but I am unsure what to use. The only choice is Wan and Lan. I would assume the Wan would be 55000 that Roon ARC defaults too. I did try several others as well asn no luck. The Lan port I would figure would be an used port inside my network. I did run Netstat -a to find was assigned and what was not. My Nucelus has an internal IP as does everything else on my network. It is the 172.24.1.xxx network. There is no place where I can specify an IP. I use Spectrum for internet services. Everything works fine inside my network. I will re-paste the latest error here.
THanks

Jeff

{
“connectivity”: {“status”:“NetworkError”,“status_code”:502,“error”:“error: Error: connect ECONNREFUSED 75.ccc.ddd.eee:55000, response code: undefined, body: undefined”},
“external_ip”: {“actual_external_ip”:“75.ccc.ddd.eee”,“router_external_ip”:“null”},
“natpmp_autoconfig”: {“server_ip”:“172.aaa.bbb.bbb”,“found_natpmp”:true},
“upnp_autoconfig”: {“server_ip”:“172.aaa.bbb.bbb”,“found_upnp”:true,“error”:“<s:Envelope xmlns:s="http://schemas.xmlsoap.org/soap/envelope/\” s:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/\“><s:Body><s:Fault>s:ClientUPnPError<UPnPError xmlns="urn:schemas-upnp-org:control-1-0">718ConflictInMappingEntry</s:Fault></s:Body></s:Envelope>”}
}

Hey @jeffzaret,

Thanks for the info!

You’ll need to set your ISP router to bridge mode here. Do you have the option to do this?

Here is a quick step by step for your router: R7000 steps for Bridge mode - NETGEAR Communities

-Ben

Ben,

Thanks for the reply. I knew I should not have done it but I changed the Netgear R7000P to bridge mode and everything we south. I lost connectivity to everything on the network. After about 2 hours of troubleshooting, I put it back in AP mode and everything started coming back online with new IP addresses. I am finally back up 100% today, Monday. I had some IP cameras which had some issues and I had to call ADT to resolve that issue.

So I guess basically I would say that bridge mode was a bust. I am trying to set a port forward through Bitdefender on the R7000P but am a bit confused because it wants a WAN port and a LAN Port. I would assume the LAN port would be an internal one and when I run netsatat -a it does show what is assigned but not necessarily show what is available.

Any help is appreciated

Jeff

Hey @jeffzaret,

I’m sorry to hear that bridge mode landed you with additional issues and troubleshooting. What happens if you temporarily bypass Bitdefender in regards to setting up manual port forwarding on the R7000P?

You are correct in that the LAN port is what we’d be looking for.

Ben,
If I skip/bypass Bitdefender I lose DHCP, firewall and the AV protection. I can do Port Forwarding through Bitdefender but I am stuck because it asks for a WAN port and a LAN port. I can run nmap to find open ports (LAN ports?) and found a handful and I tried server WAN ports, 55000, 550002, 49686 and several more. I am obviously missing something simple.
Thanks
Jeff

Hey @jeffzaret,

That’s certainly understandable! I’d like to back up and ask again - what is your modem situation? Re-reading the thread, I don’t see a mention of it. This would be the device to put into bridge mode.

Outside of that, let’s focus on Bitdefender.

Take a quick read through these directions on opening ports, and let me know if it was the same process for you. You’d be copying all the same information from the rule you’ve set up on the Netgear router. With that, have you also allowed Roon as an expectation to the Bitdefender firewall? Here is a step-by-step on how to do this.

Have you tried using the IP of your router for the BitDefender WAN? You can head to this site here to quickly get your WAN IP.

:+1: