Bit Depth Conversion 24 bit to 16 bit Bluesound Node

Just signed up again to Roon in anticipation of Linn DSM/Roon solution. For now using Bluesound devices for output (Node, Power Node and Vault in different rooms).
The Node is connected to the Linn DSM via TOSLINK.
Core runs on a MacBook Pro 2.9 GHz Intel Core i5 with 8 GB
Files pulled off Synology DS214play.
All connections to Bluesound devices through Ethernet.
With the Node, Bit Depth Conversion is performed by Roon truncating 24 bit to 16 bit and sound quality is affected. No such issues with Power Node or Vault.

Under device settings, did you by any chance set the max bit depth to 16? I also have a Node and no issues playing 24 bit content.

No that setting is disabled.

Hi @GPD ---- Thank you for the report and sharing your feedback with us. Both are appreciated!

Moving forward, may I kindly ask you for the following:

  1. Screenshots of your “device setup” windows (“general”, “playback”, “zone grouping”) highlighting the setting being used.

  2. Please follow instructions found here and upload us a set of logs.


Here are screenshots and logs.

1 Like

Hi @GPD ----- Thank you for touching base with me and providing the requested screenshots + logs!

Confirming that everything has been received and is in our queue to be evaluated by a member of our tech staff. Once my report has been updated I will be sure to follow up with the team’s thoughts/findings. Your patience is greatly appreciated!

Lastly, and my apologies for not asking this sooner :dizzy_face:, can you please confirm that the latest firmware has been downloaded for the Node. If I am not mistaken I believe it’s Node2 firmware 2.12.1.


Latest firmware is BlueOS 2.12.1

Hi @GPD ---- Thank you for clarifying that information for me and your device is currently running 2.12.1, correct?


Yes that is correct.

1 Like

Thank you for the confirmation, @GPD!

Moving forward, may I kindly ask you to please perform the following:

  • Very important - Please reproduce the issue being reported and note the time in which the observation is made.

  • After the issue has been replicated and the time note…following the instructions found here dump us a set of logs .


Issue noted on Jun 16 at 15:30

Here is link to logs.

Hi @GPD ---- Thank you for the follow up and providing the requested logs, confirming that they’ve been received.

Moving forward, once our tech team has completed their analysis of your logs, I will be sure to follow up promptly with their thoughts/findings. Your patience is appreciated!


Hi @GPD ----- Thank you for your patience while our team has been looking into this behavior you’ve reported to us.

My tech team has updated my report after their extensive testing, and unfortunately they have been unable to reproduce the same results in house :head_bandage: However, in the interest of having a better understanding of what could be causing this to occur in your setup, the team has requested that you test with a fresh install to rule out any possibilities of there being an issues with your DB. Please see below.

  1. Please make a backup of your current DB.

Without the application running…

  • Locate your Roon database according to these instructions
  • Rename the entire Roon folder to roon_old
  • Relaunch Roon, sign in, and configure a new install
  • Let us know if you see this database error again


I have done a fresh install as per your instructions.

I have also upgraded my Bluesound Node to a Node 2 and I guess this has solved part of the problem. I am no longer getting bit depth compression. I don’t know why.

However, none of the 192kHz files play properly. I see the files being read (with a short delay) and the slider moving along the track but no sound. This occurs only when outputting through the digital outputs (I tried with both coax and optical) into my Linn DSM. When I get the signal from the analog output, I hear the files properly. Again no issues with my other 2 Bluesound units (Vault and PowerNode Duo).

Here are the screenshots and a link to the recent logs.

This issue was observed on Jun 28 between 17:30 and 18:15 Eastern.


Hi @GPD ---- Thank you for touching base with us and my apologies for the slow response here. Sorry for the wait.

Confirming that I have received your logs along with the provided time stamp (thank you) and have passed all of your feedback to our tech team for analysis. Once my report has been updated I will be sure to share the team’s thoughts/findings.

Lastly, my assumption is that you are not noticing this with other audio non-bluesound, audio zones. Please confirm.


Correct. For example if I bypass Roon and Bluesound and play files directly on my Linn DSM using Linn Kazoo app, the files play properly.

Hi @GPD ---- Thank you for the follow up!

What is the experience like if you do not bypass Roon and play to a non Bluesound endpoint? Same or different behavior?


The Bluesound devices are my only Roon endpoints. I could go to the Linn DSM through AirPlay but this doesn’t cut it for me (I have tried it in the past and the sound was awful.

Hi @GPD ----- Thank you for your patience here.

I did a bit of research to try and determine what could potentially be causing this behavior to occur with 192 content and came across the following in Linn’s FAQs document in regard to using a TOSLINK connection:

  1. Maximum input sample rate 96KHz (Stereo PCM)

If you were to set your “max sample rate (PCM)” to 96khz and your “max bits per sample (PCM)” to 24, how do things behave?


This works with both TOSLINK and SPDIF.