Bluesound Node 2i problems on WiFi

Core Machine (Operating system/System info/Roon build number)

OS: Ubuntu Server 18.04.4 LTS (Linux 4.15.0-88-generic)
Roon: 1.7 (build 528)
CPU: AMD Ryzen™ 3 3200G

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Core to router: ethernet
Router to streamer: WiFi
Router: Linksys WRT32X

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluesound Node 2i with built in DAC to integrated amplifier.
BluOS: 3.8.3

Description Of Issue

The problem is that it takes a lot of tries before Roon starts successfully stream to Node.
Typical case:

  1. Pick an album
  2. Roon starts sending the song
  3. 1-2 seconds delay
  4. The songs starts to play for 1-5 seconds
  5. Error message ‘An audio file is loading slowly. This may indicate a performance or hardware problem’
  6. Skips to next track.
    This keeps happening until a track suddenly starts playing without a hitch. From this point onward all the tracks work, until I manually select another. At this point the whole dance starts again.

I have tried to put the streamer right next to the router to have the max signal strength, it behaves the same. As soon as I connect an Ethernet cable to the streamer everything works without a problem. I have also tried Raspberry 4 with RoPieee on the same WiFi and it worked without a problem.
The BluOS App also works without a problem.
I also have a NAD - T 758 v3 + BluOS dongle and works without a problem.


Hi @terman,

Welcome to the forum!

When this behavior occurs, what does the Signal Path report as the processing speed? Does this behavior only happen on certain types of tracks (only higher sample rates)?

Hi @noris

When this behavior happens the processing speed is not reported. When everything works the processing speed is 75x or more. I have not noticed any significant changes regarding the sample rates, there might be, just not an obvious one. I have just tried with both Tidal and Qobuz set to lowest possible quality and the skipping is still there.

Another thing I noticed is that Live Radio almost never works, let’s say in works 1 in 30 attempts regardless of streaming bitrate.

I have also monitored network bandwidth while this is happening and it seems fine. I get 5+ MBs download speed (from the internet) into the core and the same speed into the internal network from the core.

The same skipping behavior is present regardless of the music source (Qobuz, Tidal or library directly on the core).


Hi @terman,

Thanks for checking the processing speed.

If the speed is not reported, that means it’s over 100x, which is a good sign that this is not related.

As for next steps, can I please ask that you reproduce this behavior using local library content (not TIDAL/Live Radio) and provide the following information?

  1. What is the exact local time + date + track that this behavior occurred?

  2. Can you send me a copy of your Roon logs after reproducing by using these instructions?

  3. Can you access your NAD logs and send me these as well? You can do so with these instructions: You can get these logs by navigating to Bluesound’s IP Address in a web browser -> Diagnostics -> More -> Copy+ paste the text into a text editor

Please send the logs as a shared Dropbox/Google Drive link. If you don’t have either service, just let me know and I can provide alternate upload instructions.


Hi @noris

The logs are locate here: Link
The file contains Roon logs, Node 2i logs and a readme.txt with the timestamp and track title where the problems begun.


1 Like

Thanks for sending those over @terman, I have requested the technical team review them and once that’s done we will reach out once more.

Hello @terman,

Taking a look at the logs, it appears that the Bluesound Node 2i itself is experiencing errors during playback of the Roon Ready stream.

In the Bluesound logs we see the following traces:

Mar 18 20:45:20 (none) ./ main::HttpRequest ./ (1030) [1] /GetSettings
Mar 18 20:45:23 (none) ./ Controller::pause (1680) PLAYING
Mar 18 20:45:23 (none) ./ Controller::flushRtp (1729) flushRtp
Mar 18 20:45:23 (none) dspout: Command(l=3): f46
Mar 18 20:45:24 (none) user.warn RAAT: [lua@0x1908e94] []  UNKNOWN COMMAND 63
Mar 18 20:45:26 (none) ./ main::HttpRequest ./ (1030) [1] /Volume?etag=6535a26e18fe4f5e4c1c119ac244b0aa&timeout=120
Mar 18 20:45:34 (none) user.warn RAAT: dropout of 363 samples at 0 [2]
Mar 18 20:45:34 (none) user.warn RAAT: dropout of 363 samples at 363 [2]
Mar 18 20:45:34 (none) user.warn RAAT: dropout of 363 samples at 726 [2]

In this section we can see that playback was started successfully, and then approximately 10 seconds later the device starts to drop audio samples. We cannot ascertain from these logs why these dropouts are occurring.

Looking at the corresponding Roon logs, we can see that Roon is successfully delivering the audio stream to the Node 2i. This does not appear to be an issue with WiFi strength or quality, the stream is being delivered with high throughput, low latency, and no recorded dropped packets. The Node 2i simply stops processing the audio stream, causing Roon to stop playback after the device becomes unresponsive.

03/18 20:45:24 Info:  OnPlayFeedback Playing
03/18 20:45:24 Trace:  [Lossless, 16/44 FLAC => 16/44] [100% buf] [PLAYING @ 0:00] Amsterdam - Requiem
03/18 20:45:24 Trace:  [zoneplayer/raat] synced to endpoint Bluesound NODE 2i clock: realtime=22726319129 rtt=3000us offset=-152041680us delta=-152041680us
03/18 20:45:24 Trace: [Bluesound NODE 2i @] [raatclient] SENT [55]{"request":"stream","stream_id":977355946,"first_seq":-1,"nak_port":-1,"buffer_size":10,"ready_threshold":0.2}
03/18 20:45:24 Info:  [zoneplayer] Open result (Queueing): Result[Status=Success]
03/18 20:45:24 Trace: [prebuffer] ready 149940/441000 (34%) @ 0/230 sec
03/18 20:45:24 Trace: [Bluesound NODE 2i @] [raatclient] GOT [55] {"status":"Buffering"}
03/18 20:45:24 Trace:  [zoneplayer/raat] Endpoint Bluesound NODE 2i State Changed: Prepared => Buffering
03/18 20:45:24 Trace:  [zoneplayer/raat] [zoneplayer/raat] selected Bluesound NODE 2i as clock master
03/18 20:45:24 Debug: [raat/tcpaudiosource] connecting to
03/18 20:45:24 Debug: [raat/tcpaudiosource] connected
03/18 20:45:24 Warn: [raat/tcpaudiosource] send failed: The socket has been shut down
03/18 20:45:24 Warn: [raat/tcpaudiosource] disconnecting + retrying
03/18 20:45:24 Debug: [raat/tcpaudiosource] disconnecting
03/18 20:45:33 Trace:  [Lossless, 16/44 FLAC => 16/44] [100% buf] [PLAYING @ 0:00] Amsterdam - Requiem
03/18 20:45:34 Warn:  [zoneplayer/raat] Endpoint failed to become ready in 10s. Proceeding in state Buffering
03/18 20:45:34 Trace:  [zoneplayer/raat] Endpoint Bluesound NODE 2i State Changed: Buffering => Ready
03/18 20:45:34 Trace:  [zoneplayer/raat] wait for ready in 10015ms
03/18 20:45:34 Trace:  [zoneplayer/raat] Adjusting playback start offset from 50ms to 220ms
03/18 20:45:34 Trace:  [zoneplayer/raat] Doing 'ASAP' Start since we are just playing to one device
03/18 20:45:34 Trace: [Bluesound NODE 2i @] [raatclient] SENT [56]{"request":"start","min_offset":220000000,"stream_sample":0}
03/18 20:45:34 Trace:  [zoneplayer/raat] Endpoint Bluesound NODE 2i State Changed: Ready => Playing
03/18 20:45:34 Trace: [Bluesound NODE 2i @] [raatclient] GOT [55] {"status":"Playing"}
03/18 20:45:34 Trace: [Bluesound NODE 2i @] [raatclient] GOT [56] {"status":"Success","time":33015513848}
03/18 20:45:34 Debug: [raat/tcpaudiosource] connecting to
03/18 20:45:34 Debug: [raat/tcpaudiosource] connected
03/18 20:45:34 Warn: [raat/tcpaudiosource] send failed: The socket has been shut down
03/18 20:45:34 Warn: [raat/tcpaudiosource] disconnecting + retrying
03/18 20:45:34 Debug: [raat/tcpaudiosource] disconnecting
03/18 20:45:34 Trace: [Bluesound NODE 2i @] [raatclient] GOT [55] {"status":"Dropout","samples":54087}

Based on your previous testing with other endpoints and our findings here, I think the next step is to work with the Bluesound support team to determine why the device is failing during playback when connected via WiFi.



I am reporting back in case someone has or will have the same problem. Unfortunately Bluesound Node 2i’s WiFi implementation has problems with 5GHz with some routers.

I have managed to get around the problem using powerline network adapters and connecting via Ethernet.

Hi terman,
Had some similar problems with starting streams on Flex2i connected wirelessly.
See this post:

It was a matter of server speed, as I had changed to i7 core maschine the problem with starting streams was solved. But occasionally with wifi connected players i have sudden stops or skips with Qobuz content. It is a bit strange but looks like a problem with bluesound. All cable connected device stream without problem.

Maybe you can test it with another server maschine…
Best regards

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.