Slow Roon track startup

Hi @Peter_John_Leeds,

Thanks for reaching out to us here. Can you please let me know if this behavior is the same for all of your endpoints (Bryston DAC/Node 2i) or just one/some of them? Is the behavior the same if you setting the zone to “System Output”?

How is the iMac connected in this setup? You mentioned that the Node 2i is on WiFi but is the Core on WiFi as well? Is there any change if you try temporarily connecting the Core via Ethernet to the Time Machine router?

Also a word of caution in regards to your Time Machine router, we have often seen Apple networking gear have unsatisfactory performance (as mentioned in our Networking Best Practices Guide), so if possible you may want to try a different router brand, even as a temporary test to see if it helps.

– Noris

Noris:

If I am using Roon there is a lag on playback. SOMETIMES but not often it does not lag but most times it does. My Core is the iMac and it is sharing the same wifi as the Bluesound. The Core is physically attached to the Time Machine/router by ethernet. The wifi is being used by my daughters’ phone and it is being used to stream Netflix, so it is sharing. I know that I should be a dedicated user/source for my audio, but…

It is interesting that you mention the caution about the Time Machine since I have had nothing but success with it and up until I relayed the issue with playback lag (and the latest mac and Roon update) there were no issues at all, no playback lag…

I have thought of physically attaching the iMac/core to the Bluesound using a physical cable but it would be long, have to be run to my sound room and the whole idea of the Bluesound is to go wireless. Right now I am committed to the Time Machine as it is crucial to the others in my house to say nothing of the fact it serves as a backup for the computer which contains all my music and is my only backup for my high res files. I will try a couple of things tonight (such as switching zones and changing wifi channels) and see what happens.

Thank you for your concern

PJ

1 Like

Hi @Peter_John_Leeds,

Thanks for letting me know the above. After your initial testing is concluded it would be useful to have some more information as to the exact failure state if it is still present, info such as:

  • Does this issue occur for all your zones, including “System Output”?
  • Even if temporary, is there any change if connecting the Core via Ethernet to the primary router?
  • Does this lag affect both Local and streaming files or just one and not the other?

I tried using different wifi channels to no avail. If using wifi there is lag. There is NO problem if I switch System Output to default (the computer). The music plays out of the computer and there is no wifi. Playback is immediate and no issues. Once I switch back to using the Bluesound through the wifi the lag is back. Sometimes the track will play up to 15 sec before it actually plays through the Bluesound and often the first few seconds are skipped over.

I do not stream music of any sort. I don’t agree with this type of music system and I believe in owning the music I listen to. All my files/music is Local.

My Core is connected via Ethernet to the primary router. There is the only one Time Capsule and it runs the whole house. It too is connected to the the only wifi box (the one from the service provider we use) via ethernet. Whether the wifi source to the Bluesound comes from the primary wifi box OR the Time Capsule is no different; there is lag in playback and the first few seconds of the song are missed. Sometimes it is not so, but not often.

If I do select the option of Play from here and let it be there is no lag with later tracks…only on the INITIAL selection/startup of track selection is there an issue. Seems like loading into memory? If I go to System Output and select the computer and then manual select every track, say, EVERY time it is quick and immediate. I have tried to play with the Roon settings to no avail.

Seems like a buffer issue/loading into memory???

I know lots about audio, but the computer end is not my speciality. I hope this helps.

PJ

Hi @Peter_John_Leeds,

Thanks for the update here. I have a few further suggestions regarding your case:

  1. Are you able to reproduce this behavior when using the BluOS app to stream your music to the endpoint or is it just occurring in Roon?

  2. Can you try to see if the behavior is the same if you connect your endpoint via Ethernet as a temporary test? I noticed that you mentioned that your Core is connected via Ethernet but I did not see a mention of the endpoint being connected via Ethernet. Please try this test first.

  3. Let’s start tracking the times when this issue occurs. Can you start noting the exact minute/date when this behavior next occurs (e.g. 4:11PM on 6/15/19) and let me know this info? I wonder if perhaps diagnostics will have any additional info surrounding this issue.

  4. BlueSound logs might have some additional info as well. You can get these logs by navigating to Bluesound’s IP Address in a web browser -> Diagnostics -> More -> Copy + paste the text into a text editor and send it as a shared Dropbox / Google Drive / send.firefox.com link.

– Noris

This might take a few days; getting the cable to go from the computer to the Bluesound will take some time; I have a killer cold right now.

The behaviour is the same (lag) if I use the BluOS app from my phone. In fact, the ability to change the music using my phone as a controller is revolutionary to me and I use it often. Again, on selecting “play from here down” there is the initial lag but once left alone to play it is fine (like if I use the computer to play)

Your last suggestion might take some help; I am not the most computer savvy person. I will do my best.

PJ

Hi @Peter_John_Leeds,

Since this behavior carries over to the BluOS app, I would be taking a closer look at the Node 2i hardware and networking aspects.

I would try to run the direct Ethernet line as I previously suggested and see if this helps, and possibly check the firmware on your Node 2i via the BluOS app to make sure you are using the newest one available.

If it does not help, I would download the BluOS diagnostics using my instructions and provide them to Bluesound for analysis, as they would be able to better identify hardware issues.

– Noris

Noris: I just got an ethernet cable (nothing special, bought from Best Buy) and connected the router to the Bluesound with the cable. There is no lag at all. None. However, I now have a 25 foot cable from my computer to my Node 2i that the wifi is supposed to make obsolete. I would much rather have the wifi working since it was working without any lag since the last Apple update and Bluesound update. I think it must be a wifi issue, but if you can help…

PJ

Hi @Peter_John_Leeds,

Apologies for the delay in getting back to you here, I have been traveling these past few days. This does seem to be related to the WiFi since Ethernet works as expected, I would try checking your WiFi channels as indicated in this post as it may help:

I t is definitely wifi as I have updated (or hit the update button) on the Bluesound and in either case of the player or remote both are update. No change. Switching to the ethernet cable again…no lag.

I will play around a bit more but it is more of a nuisance than an “issue” in that I can’t hear anything etc…but when it was fine before…

I will update after a day or two with some experimenting.

If I select an album, say, and “play from here” to select the whole album, only the first track is slow or lags, the rest is all fine. Weird.

1 Like

Noris: I posted elsewhere but I spent some good time with Bluesound on the matter and it is not them. They went through my settings (Node 2i and router) and with the Bluesound node or using the ethernet cable either Roon or Bluesound no issues. It is definitely a Roon+Bluesound issue. I never saw this before 1.6 Since my ethernet cable is trouble free I am using it but obviously if I can go back to wireless…

I will keep looking into this myself and play around…but if a bug fix comes out…

PJ

Hi @Peter_John_Leeds,

Thanks for the update here. Can I please ask you to reproduce this behavior and then send me both Bluesound logs and Roon logs when this behavior occurs via WiFi? I would like to take a look to see if there are any clues as to why this behavior occurs.

– Noris

Noris: I am bringing this up as I have found a completely unexpected result in an experiment I did regarding the issues this thread touched on.

To repeat, when using the ethernet cable hookup option with Roon to my Bluesound Node 2i (with all latest updates for both) I have had no issues whatsoever. Runs flawlessly.

If I decide to use wifi to transmit the signal to the Bluesound Node 2i Roon has issues; tracks are slow to load (if at all) and dropouts are common.

Since I contacted you last on this I have used the ethernet option exclusively and to no issues; I decided if that worked so be it.

However, earlier this week I decided to try an experiment to see if the wifi would work again.

Roon using wifi with the Bluesound was even worse. On many albums, the tracks would skip down the line as the Roon would try to play them and the error message would come up and the next track would try. I never remember it being this bad.

We recently changed our wifi network from the “old” network to the “new” network about 8 months ago. We use the cable company router AND the Apple Time Capsule simultaneously. Both are transmitting the same wifi network with no ills. I mainly want the Time Capsule for the backup hard drive for my music.

I got the idea to try and disable the wifi on the Time Capsule (as you had mentioned that could be an issue) and to some avail (no thanks to Apple…the wait on the phone was over an hour to ask) I found the way to disable the wifi transmission from the Time Capsule. Still bad performance with Roon. So with only the one router transmitting wifi still the wifi capability of the Bluesound using Roon was very poor. Again, using the Bluesound app for music playing was without issue; either using the ethernet or wifi. So it is definitely a Roon/Bluesound/wifi issue.

Everything else in the house; TVs, iPhones etc no change with the disable of the wifi from the Time Capsule.

I decided as “what the hell” to change the wifi network on the Time Capsule back to the “old” wifi network and then go into the Bluesound app and change the wifi network to the same…the “old” one.

Roon works just fine with the “old” network". The old network was not a 5G (2.4 I think) but there are no track delays or skipping or whatever. The network connection has dropped off once, but compared to the “new” wifi network (which is 5G) the old one works just fine.

When I got Roon new I was using the “old” wifi network and setup Roon with this network in place. I have tried to go into Roon to see if there is a setting or whatever that I can change to get Roon to recognize the “new” network…I can do so with the Bluesound Node 2i but I recall a drop screen when setting up Roon that allowed for such. I cannot find it now.

I am wondering if there is a way to “reinstall” Roon or go back to the initial settings and change the original wifi network Roon works with…I have tried with Bluesound to no issue (that is how I got it to work with the “old” network).

Could it be Roon doesn’t like the 5G networks? I can’t see the other systems (TV/phones etc) being an issue…they weren’t before and had no trouble switching over to the “new” network.

Any ideas would be appreciated. Obviously if it works as it does now I am going to use it (since the Roon/Bluesound is the only thing using the “old” wifi network) but should it happen the Time Capsule craps out I would be back to using the one wifi network the “new” one and getting Roon to work with the “new” network would be a priority.

Got me baffled for sure.

PJ

1 Like

Hi @Peter_John_Leeds,

We have managed to reproduce this behavior in the QA lab using BluOS gear via WiFi and we’re working directly with Bluesound to resolve these issues when streaming via WiFi. In the meantime, we would suggest using a direct Ethernet connection instead of WiFi for your 2i devices.

The Node 2i’s internal Wifi, can be iffy with 5g.

See: Bluesound Node 2i problems on WiFi

I have the same problem as well. In case this helps, my WiFi is Orbi with an RBR50 and two RBS50s as satellites. The poster above mentions his old WiFi network works with the Bluesound devices, so thought this might help you FWIW. To verify, things work fine with any combination of speakers I use except when a Bluesound speaker is in the mix. Then these 15 second delays occur on new tracks and a lot of the time, they never even load.

I would love to see this issue rectified since both my Bluesound speakers can’t be hooked up with wiring because of their locations. Wireless capability was the whole reason I got them to begin with. So they are bricks for now.

1 Like

Thanks for the feedback @eddieb! Bluesound is currently working on this issue, we cannot comment on when the new BlueOS firmware will be released public, but once it is, it should help with this issue.

Good news. It appears Bluesound has fixed this problem. I noticed today that there is a new firmware update available. It’s version is 3.10.0 dated August 18. I installed it on my PULSE Mini 2i and it plays everything flawlessly.

I also have a PULSE Flex 2i. Before installing the new release, I tested it to verify it was still messed up. It was. It still showed the same symptoms as before: taking 15-20 seconds to start a song, not even able to load half the songs, etc. Basically unusable. Then I installed the update and now, like my PULSE Mini 2i, it plays perfectly now.

I updated my devices via the BluOS app. But you can also download the update from the site linked below and use a flash drive to update your devices. Good luck!

1 Like

Thanks for lettings us know the update helped here @eddieb!
@Peter_John_Leeds - Have you by any chance taken the update?
Has there been an improvement in behavior?

I have the update…

I have kept the Roon running on the 2.4 Ghz wifi and have had no issues so I have not tried it on the 5G network as of yet.

As I am at work I will give it a go later tonight and see from there. Using the 2.4G network as I have it has been flawless on the wireless performance so I did not see the need to change (if it ain’t broke…).