Bluesound Powernode Edge - shows as not Roon Ready certified?

Hi! I just got the new Bluesound Powernode Edge. It’s listed on the partner page here Bluesound - Roon Labs, but it shows up as uncertified in Roon. I thought being listed on the partner page meant that the certification process was done and that it should be certified? Or have I misunderstood something…?


Is there a firmware update available for your Bluesound?
I don’t have one but there are other devices that require a firmware update for Roon certification.

Indeed there is an update that might work….

BluOS 3.20.21. Released October 05, 2022.
• Support for Bluesound POWERNODE EDGE.

Cheers John


Thanks for the suggestions!

I have the latest firmware installed (3.20.21). Also did a hard reboot of the powernode and rebooted the core. Still uncertified…

Any other ideas?

Hi Fredrik, normally devices have to be certified by Roon before they are allowed Roon ready, to make sure that nothing is broken, even if it is a product from a company that has previously had Roon Ready certified devices. For example the LSX II and LS60 from KEF have been going through this recently.

Until you hear from Roon that the certification is live, I would use Airplay as that will work perfectly well and then when it is certified it will sound even better

Yeah, I do understand the certification process and need for it, but what is the official way to check that the process is finished? I thought that that the listing on the partner page was just that, but obviously it is not.

So where can one check if a product has finished certification?

Generally it’s automatic that Roon push out a back end announcement. Usually there will be some kind of a post to go with it (and then a minor delay as everything lines up timing wise).
Sometimes a Roon core restart is required if you want it quickly.

There was a similar discussion on the KEFS last week as KEF pushed out the RR update but Roon hadn’t pushed the button their side so it wasn’t working.

I’m sure someone will post something in the threads here as well. Maybe worth posting here again on Monday afternoon, when the Roon team is back at work.

How are you finding the sound of Edge?
I have a PowerNode 2i in my study as well as a lot of Sonos kit, and I really like the flexibility of the Bluesound gear, and if it had Chromecast built-in as well it would be almost perfect kit.

Hi @fredrikj,

I can see that it is indeed listed on the website but not certified in the app according to our databases. Let me look into this for you. Like others mentioned, it may just be a pending announcement but normally we hold a website launch for that as well.

I’ll get back to you.


Hi @fredrikj

This was an issue on our side and it has since been corrected. Please restart your core and your device and you should be good to go!


Sorry about the late reply… I bought the Edge for a small 2.1 system at my cabin. It’s not the best speakers on the system yet, so haven’t done any critical listening, but it seems more than good enough for my purpose.
I do agree with the flexibility of the Bluesound gear! I have a Pulse Mini in the kitchen and I really like it. The main reason for getting the Edge is that it just works.

1 Like


Thanks for looking into this!

I just rebooted my core and the device, but it still shows as “uncertified”. Does this take some time to propagate through your systems, so I should try later?

Hi @fredrikj,

The change should be immediate. Can you try restarting one last time (core) as well as any other remotes (Windows or mobile devices)?

Let me know when done and if the issue is still not resolved, it’s possible something is corrupted on our side. I’ll be able to check logging and see if that’s the case.


I’ve booted every remote (PI’s, remotes and Bluesound Edge and Pulse Mini) and the core, but still uncertified.

Checking on things for us now.


I’ve made a small change that may do the trick. Please restart your core and try again for me!


Still uncertified, didn’t help.
I also just got an update for the Edge, it’s now on firmware 3.20.25. Tried rebooting the Edge a couple of times after the update and also restarted the core.

Ok, try again. The firmware was likely the issue in conjunction with my change that I have since reverted.


Restarted core and edge, still uncertified

Hi @fredrikj,

I am working on getting in touch with our engineers and will get back to you soon.