Bluesound Pulse Soundbar 2i

QNAP NAS TS-563, Roon 1.6 (Build 416)

Hi, I’m having trouble with my Bluesound Pulse Soundbar 2i and Roon when I play hi-res albums. When I play the same albums through the BluOS ecosystem there’s no trouble. But using Roon, it plays the first bit of the song then the audio falls off even though it shows that it’s still playing in the Room Remote (Android).

Also, my other bluesound devices are working fine.

I have the soundbar hardwired and have an Asus ac-66u router. I tried rebooting every device but it didn’t change anything.

Not sure what other info you need at this point. Thanks.


Hi @J_B,

What kind of high-res albums are you playing here, does the behavior occur for both local and streaming tracks or just one and not the other? Have you made sure that you are using the newest firmware for your Soundbar 2i zone?

As per our Networking Best Practices, can you make sure multicast routing is enabled in the router?

ASUS Routers

We recommend enabling “Enable Multicast Routing” option in settings.

I looked for this setting previously but I couldn’t find it. Further research indicates that it’s enabled by default…

Hi @J_B,

Thanks for checking for that setting. For next steps:

  • Can you take a look to see if you are on the newest Bluesound firmware available?
  • Does this behavior occur if you use the Airplay output for the Soundbar?

Yes, I’m on the newest Bluesound firmware.

I tried the Airplay as you suggested. It works a little better (there were some brief interruptions in the songs but not that often). The main thing though is that with Airplay it down converting the sample/bit rate to 44.1/16 (from 96/24).

Hello @J_B,

The QNAP NAS TS-563 is below our minimum specifications for use as a Roon Core. It uses the AMD G-Series GX-420MC CPU performance is far short of the Ivy Bridge (2012) i3 we have listed in our recommended hardware document.

Could you try running your Roon Core instance on a Mac or PC in your house and streaming to the Bluesound zone? This will at least rule out the NAS as a factor in the issues you are seeing.


Hmm, ok well this only seems to affect the Soundbar and not my other Bluesound devices.

Also, I tried to install the server on my Gentoo machine but it’s not working. The forums yielded nothing, any tips? Can you make an ebuild for Gentoo? thanks.

Unpacking RoonBridge_linuxx64.tar.bz2…Done
./ line 202: /tmp/tmp.9n0pCn7fdA/RoonBridge/ Permission denied

What’s it checking that it needs permissions?

Hi @J_B,

Would you by any chance have a Windows or Mac PC around the house which meets the minimum requirements that you can use to check? That would be the simplest option in my opinion.

If the Gentoo PC is the only one that meets the requirements though, these links may help with the install:

Gentoo Forums - Setting up Roon (Note - You may want to use google translate to translate from Italian)

I finally had a chance to look at the links you sent me but I don’t see any solution. The problem is with your installer:

“./ line 202: /tmp/tmp.06bBf0aZEQ/RoonServer/ Permission denied”

I couldn’t find the temporary files it created so I can’t troubleshoot but what is your “” file checking for? If I knew that I could troubleshoot and maybe fix the permissions.

Ok I saw in the “Manual” section that it is available in the tarball. I’ll check this out and report back…

1 Like

Alright, so, I was finally able to install Roon on my Gentoo machine. I used a method that I will post about in another thread. Anyway, this machine is an octa-core AMD 4GHz (FX-8350) with 16Gigs of RAM and runs on an SSD, liquid-cooled etc. etc… It should be plenty fast and well above the minimum requirements for Roon.

All that being said, I’m still having the exact same problem as before. As before the Soundbar is crapping out a few seconds into the song. The other Bluesound devices are working perfectly fine with the same track-- even the ones on wifi. Also, as I stated before, native playing on the Soundbar is working perfectly fine too.

So, any suggestions? Do I have whacky settings in Roon? The only non-default option I’ve enabled is auto volume leveling. I can try turning that off but I doubt that’s the problem…

Hello @J_B,

Could you provide a copy of your Roon Logs for the QA team to analyze? The easiest way to send them over would be to use Firefox Send.

Additionally, it would be helpful to have a copy of your BluOS diagnostic logs as well. To retrieve those, you can enter in the IP address of your Bluesound SOUNDBAR 2i in a web browser, click “diagnostics”, then the “more” button. Copy and paste all of the text on the screen into a text file and include it in a zip file with your Roon logs with the name “Bluesound_log.txt”.


How’s this?

Roon Logs:

Bluesound Soundbar 2i Logs:

Ok, so thank you for suggesting looking at the Bluesound logs. I did so and discovered that the Soundbar was actually on Wifi! After plugging it back in to the LAN (it must have fallen out or something). Things were working as they should.

Although, it still seems strange to me why the native Bluesound could play the track but the RoonServer could not. Any ideas as to why?

Hello @J_B,

Glad to hear you got things figured out! We’re here if you run into any new issues.

As for why you were running into issues with Roon Ready streaming when the Bluesound app was not:

When using Roon Ready streaming, Roon decodes the original file to an uncompressed PCM bitstream before sending the audio to the device. This is what allows Roon to perform advanced DSP operations, format conversion, and multi-device playback synchronization in such a seamless manner across hundreds of devices. This does result in higher bandwidth usage than some other streaming methods on the market.

As an example, when using the BluOS controller and Tidal, the application simply points the Bluesound device to a .flac file on Tidal’s servers and starts buffering. A FLAC file for a modern recording often averages about ~750kbps vs uncompressed 16/44.1 PCM which is 1411kbps… not a small difference.


1 Like

Thank you, yes that makes sense although I wasn’t streaming through Tidal. Is there a way to increase the buffering in Roon to prevent this from happening again?

Hello @J_B,

There is no method to manually increase the buffer length for Roon Ready streaming. Roon features such as multi-zone playback would be incompatible with user adjustable buffer lengths. We’re always looking to make improvements to our buffering algorithm and network stability, so keep an eye out in future releases for adjustments in this area.


1 Like

Ok thanks!

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.