BluOS Card Locking Up

I use a BluOS board in an NAD M32. Since updating the card to v2.10 this morning (to use with Roon), I have had to reboot the card a number of times.

Playing a first song is fine, but if I interrupt it, and play a second song, the display starts rapidly cycling between the two song titles/info, even though only the most recently selected song plays. If I interrupt and play additional songs, at some point it starts cutting out, then eventually it locks up. At this point, Roon no longer sees the card, until I reboot (the card), at which point it can take up to 5 minutes for the M32 to reappear in Roon’s list.

Note that I also have a PS Audio DirectStream DAC, serving as an endpoint in the same location, which exhibits no problems. Both are wired to ethernet through the same switch. I mention this only to help rule out network issues.

Hi Michael, I have the NAD M12 with BluOS card and was planning to upgrade to v2.10 tonight but I’m nervous about doing this after reading your post. Are you only experiencing issues when playing through Roon or do you also have issues with the BluOS Controller app (without Roon)?

The problems I am experiencing are exclusive to using Roon. The BluOS app seems to work okay as usual. Then again, I haven’t used the BluOS app all that much today.

Roon seemed relatively stable earlier this morning, until I started interrupting playback, as I was jumping around between various songs - checking MQA vs non-MQA versions on Tidal, for example.

I gave up at one point, and switched to the DS Audio DirectStream (Roon Ready and stable), while working (it’s an office system). I am going to switch back to the M32 now, and see if I just leave it alone (let it play complete songs), if it is stable. I will post a follow up, if the M32 continues to have problems, under even these circumstances.

2 posts were merged into an existing topic: MQA and Bluesound

Hey @Michael_W – sorry for the trouble here. If you’re ever having a problem with Roon, make sure you flag @support and let us know these details about your setup.

Now that I’ve flagged this post, I’m sure @Eric will be along soon to gather some more information. In the mean time, let us know those details and we’ll get this resolved for you.


1 Like

Thanks, Mike.

Here are the details:

The issue earlier today was that the M32 seemed to be trying to play multiple songs at the same time - or rather, the display was flashing rapidly between previous songs and current song. The actual song being played was okay. Then stuttering began (within 10 minutes of the flashing). Then the card locked up. (Behaved like an out-of-memory situation, or too many processes running, if I had to guess.)

I rebooted the BluOS card. No go. I rebooted the Roon core. Fixed it - and it worked for a while. Then after about 30 minutes, the same behavior as before returned. Note that everything continued to work fine with the native BluOS app. Likewise, the Roon Core seemed to also be functioning fine with a PS Audio DirectStream DAC, so I switched to that, and used it for the rest of the day (without rebooting the Roon Core).

I am running Roon 1.2 (build 165). Core is running on Linux 16.04.1 LTS Server (no GUI), which is up to date. Machine is an i7, 8GB memory, 64GB drive (no music files). Files are stored on a NAS (WD PR4100) - about 2000 albums.

Controllers are running on macOS 10.12.3 (Mac Pro 2013) and iOS 10.2.1 (iPad mini 2).

Outputs are a PS Audio DirectStream DAC, the M32/BluOS, and an AppleTV (via Airplay). No stuttering or any other problems with the other devices.

All components are wired ethernet. Router is Apple Time Capsule (newer vertical model). Switches are NetGear (unmanaged) + HP (managed). Media is a mix of DSD64, 24+16 bit PCM (ALAC). Original problem did not seem to be related to the media type.

A little while ago, I rebooted the Roon Core a second time, and the missing M32/BluOS reappeared (as it had before reappeared upon Core reboot), and so far the issue described above has not reappeared.

I originally assumed the problem was with the BluOS card, but now I am thinking it might be the interaction between the card and Roon Core - especially because the Core is running on Linux. Maybe the combination of the “Uncertified” BluOS + the Linux Core? Next time, if the problem occurs again, I will reboot only the Core, to see if that temporarily fixes the issue.

Again, without rebooting the Core, I could use Roon fine with the PS Audio DAC. But the M32 was not being found. Rebooting the Core was the only way to get it to “see” the M32 again.

Hope this is helpful.

Hi @Michael_W ----- My sincere apologies for the slow response here. I wanted to touch base and see if any new observations or progress has been made here. If you are still experiencing the reported behavior let me know and I would like to grab some logs from you so our developers can take a closer look at what is going on here. Many thanks!


Thanks for responding. I experienced the lock up a second time. This second occurrence took place when playing the same Tidal MQA track using the BluOS app, and then quickly switching to using Roon. I wanted to see how much fidelity I was giving up (for now, until Roon sends whatever BluOS needs to enable MQA unfolding/decoding).

The BluOS card behavior suggests that both Roon and the BluOS app may think they have exclusive use of the card. The display flickers quickly between the two apps (displaying different title layout/content + playback progress indications).

I find that as long as I don’t switch rapidly between controller apps, the problem does not occur. I will attempt to capture the logs, the next time the card gets into this state.

Again, thanks for following up!

Hi @Michael_W ---- Appreciate you sharing these observations with me! I will be on the look out for your feedback, just flag me down using (@Eric).


Hey @Eric,

I saw behavior tonight, that may be related to the issues I’ve been seeing with BluOS and Roon. To refresh, I am using an NAD M32 w BluOS card installed. I use a separate Roon server, running on a 6th gen i5 Intel NUC.

A little while ago, I played a Tidal track. When it ended, the display on the M32 continued to “play” silence - i.e. the progress indicator simply continued. The song was maybe 3:00 minutes long, the counter is currently about to reach 33:00 minutes.

If I hit pause, on the M32 touch screen, the command is ignored. It is as though BluOS thinks it is still receiving a stream from Roon. I am guessing that if I play another song, the display will flicker back and forth between the last song that is still “playing” and the new selection.

I have seen this flickering/toggling between song info many times, at this point. I have to shut everything down for 15 minutes or so, to recover. Even rebooting the BluOS card doesn’t always help. It just picks right up where it left off, flickering/toggling rapidly back and forth between song info for songs it has already finished playing. The card will lock up, if it gets into a state where it thinks it is playing 4 or 5 songs - all at the same time. Note that only one song actually plays - the most current song - or in the case of a few minutes ago - silence continued to “play”.

I tried just now to find a set of logs to send you. I couldn’t find them explicitly, but did find a way to generate a “support package” -will that do? If so, how do I get it to you?


Hi @Michael_W ----- Thank you for the follow up and sharing this observation with me. I will be contacting you momentarily via PM with instructions momentarily on how we can go about grabbing some logs from you.


I’ve just encountered this behavior on my M12 (the switching back and forth of the display). No lock-up as of yet, but I’ll try to diagnose more…

It will be good to have a second set of eyes, and on a different model (M12) as well.

@Eric Just calling your attention to the fact that there is another example of this behavior that has cropped up.

Thanks Paul.

I have a NAD M32 and am experiencing this behaviour.

I have also found that if I queue up a full album, it will play that then after the last song the time will keep counting and the radio will not kick in. This is does not happen when I play individual tracks.

I had a similar issue with M12/Roon/Tidal setup. I had Roon set for exclusive mode and when I disabled this mode it seemed to correct the issue. Do you have something using exclusive mode which is “fighting” with the NAD unit?