BluOS devices do not show up via Roon Ready mode after updating to BluOS version 3.20.45 [BluOS team aware]

Hi @OffRode and @ged_hickman1 as you know I have the same problem with both the Nad BluOS 2i module and a new Bluesound Node but I received notifications repeatedly this week denying it was their problem, telling me to speak to Roon, and claiming the problem was solved. And yet this post received an almost immediate response that BluOS have replicated the problem and are trying to fix it! It’s difficult to fathom how they didn’t acknowledge an identical problem happening at exactly the same time. Roon themselves have not bothered to respond seemingly abdicating any accountability in terms of this problem.

1 Like

Seems with update 1223 that with the missing libraries and ongoing ARC issues they have enough plates spinning and a shortage of hands on deck to ensure they won’t be bored anytime in the near future.
I’m wondering what I’ve done right that all my stuff is working fine…………jinxed it :joy:

It’s always great and reliable until it’s not.

1 Like

Always have a good backup plan :wink:

Edit: curiously and curiously more…………

Also saw a fellow lost his Dynaudio actives, perhaps total coincidence going on.

Honestly, the first-level tech support generally don’t know that much and just read from the script (reboot, reset, make sure you are on latest version…). Lennbrook just has more of them then Roon does, so you get a reply faster. But since they are evaluated on how fast they can close tickets, if it is at all possible to say “Blame Roon, not our problem, issue closed” they will do it. If you hit a rep who had already been forced to escalate the issue and knows that this is a BluOS problem, then you’re lucky and get “Issue confirmed, we don’t know when R&D will fix it, issue closed.” instead…

Hello All,

Thank you for the reports here. We have been able to reproduce this issue in the lab using BluOS firmware version 3.20.45 and power cycling the BluOS device.

We are in active communication with the Bluesound team and they are working on this issue. We are standing by and ready to assist them in any capacity they need to resolve this for all of our mutual customers.

In the meantime, we have found that performing a reboot of the Roon Core can help restore the Roon Ready functionality for the BluOS device. Please give this a try if you are impacted by this issue, thanks!


Core reboot doesn’t work for me. I’ve done it half a dozen times already :smiley:


Loading previous firmware will mitigate the issue. I found a copy I saved on my computer. Loaded it up 3.20.25. Everything was back to normal. Took the latest update again and factory reset just to prove the point. And the player was gone once again. Loaded up the old fw again and I was back in the game. Updated to latest. Still good. Tried to power off at the mains. No issue. So, it’s when factory resetting the latest fw - the certification will break. So no more factory reset for me until they release a stable update.

They really need to publish the old firmware files instead of leaving everyone with broken devices. By the way - I’m using NAD M33


Good news that putting an older firmware solves this problem.
I’m in the same situation, but I can’t find the version 3.20.25.
Where could I find it?
Thank you so much.

That’s the thing… you can’t

They only provide latest FW available

Hallo All
I have the same problem. I don‘t see my bluos devices in Roon since the firmware update 3.20.45.
Greats from Switzerland

Downgrading to an older version may be able to temporarily resolve this issue.

I own a NAD M10 V2 all-in-one streaming amplifier, which was always Roon-ready and I always upgraded to the latest firmware online. The latest upgrade version is BLUEOS 3.20.45.

A few days ago, I accidentally restored the machine to factory settings, and after rebooting, I encountered the same issue as you: the device only appeared in “other network devices” in AirPlay mode, and disappeared in Roon-ready mode. I contacted technical support from our country’s distributor, but the methods they suggested couldn’t solve the problem.

Finally, I found BLUEOS v.3.20.25 from last year’s web-ftp directory list on NAD’s official website, which is applicable to M10V2. I downloaded and extracted the .img file to a fat32 USB stick and inserted it into the machine to revert to version 3.20.25. After that, the problem was solved, and Roon-ready came back. I then upgraded to the latest version 3.20.45 online, and Roon-ready did not disappear.

I found the old version firmware in the web-ftp list of NAD official website, the link is:Index of /
Other devices of Blueos should also have corresponding download locations.
You should be able to find the corresponding old version of the firmware by looking in the folders one by one.

1 Like

Hallo weisun
this link does not work for 2022

It is true that the subdirectory cannot be accessed today,yesterday I was able to access the subdirectories one by one,but just now I tried the link to directly download the firmware is available:
sorry i don’t know why,maybe NAD is updating their ftp server, maybe it will show up after a while.

Why are people factory resetting after a firmware update ? Seems odd that you should have to do this. Is it something NAD encourage ?

For general users, it is not impossible to reset the factory settings by mistakenly touching the menu on the panel. After all, they are not professional technicians and cannot avoid misoperations. However, this error cannot be avoided after the original manufacturer’s firmware is upgraded.This is irresponsible to the customer.

My Node 2i has had three issues in three years and each time it happened was after a firmware update and a factory reset corrected the issue.

Thank you so much. i have take the Firmware 3.18.07 an now every thing work again.
After i have take also the new version 3.20.45 and everything works fine.
I have take the Firmware for my node and Puls Flex on the Web Site from BluOS
Node 2 (3.18.07)

Pulse Flex (3.18.07)

Node 2i (3.18.07)

CORE reboot had no effect.

Thanks but nothing for N130?
Where are files on Bluesound server ?