BluOS devices do not show up via Roon Ready mode after updating to BluOS version 3.20.45 [BluOS team aware]

Roon ready is not displayed in my BluOS app. Roon Nucleus and NAD M12 with MDC BluOS™ 2i (last update 2/28/23) what can I do to get Roon working again?

:mega: Staff Note :mega:

Have you tried rebooting everything first?

1 Like

In my experience with a NAD C368 and MDC card, after running upgrade on the card you need to do BluOS factory reset on the card, from M12’s front panel, to get Roon to recognize the device properly.

Boris hi hi, did you see my post yesterday about the new BluOs release? Didn’t notice anything about c368 in particular but perhaps take a look.

I took a look at it, moot point for me as I’ve long returned the C 368 (Nova 150 with double the power at half the price sits in its place), but I made sure my Flexes and Nodes are updated. Those work as well as before.

I believe the problem is with the MDC card itself, and how it acquires the device name for communication with Roon. Release docs do not say anything about that, so I am not sure if it has been fixed.

My bad, I thought you were still fiddling with it :joy: Don’t blame you at all shouldn’t be like that. If you have as good of luck as we have had with the peachtree you won’t have any issues, my son uses my hand me down constantly and it’s been bulletproof. Beautiful piece of kit as well. Hope things are going well in Texas I’m back in Southern California for a bit of time.


Texas is fine, nice and warm. How’s the skiing in SoCal? Heard you got snowed in there :slight_smile:

It took couple weeks to get Bluesound to acknowledge that there is a problem (got better workarounds from Roon forums in the meanwhile), but the dealer was nice about swapping it for a Nova 150. I won’t swear that it sounds better, but I think extra power might be pumping the bass in my Missions a bit more… And the casing is very nice. Looks like Peachtree can’t figure out what they want to charge for it, but I got it when even the mocha version was only $999 which seems to be a great value .

Looks like it will be driving the Missions for a while, nobody even seems to know when backordered Rose RS520 might finally sail across the ocean. But I think it is more than enough for now anyway.

Interestingly, all the BluOS devices I have that don’t use the MDC card, those are working just fine with Roon.

1 Like

The grandkids are up at the cabin right now, took them two days to get up the hill not me I’m not feeling it. That ice storm was enough for me, still have a couple of things to fix in Tx still.

First time I was in So Cal, I noticed that if you so much as spit in the window, traffic stops because they think it is raining… Snow must have been… interesting…

1 Like

My NAD M12 is not showing up as Roon Ready via my Nucleus.
I have already asked NAD support and implemented all the suggested measures. Unfortunately the NAD M12 is still not showing up as Roon ready in my Roon, what can I do to make the Roon ready connection work?

@johannes_rieder, please don’t open duplicate threads. Thanks.

I’ve merged the topics.

Unfortunately, my NAD M12 is still not running as Roon ready, can someone please help me? BluOS refers me to Roon!

There are a couple of other threads about this topic, search a bit

1 Like

Roon Core Machine

Running Roon Server Legacy

Networking Gear & Setup Details

Deco XE75 3 Units
Mix of wired and wireless endpoints.

Connected Audio Devices

I have 9 BlueSound NAD endpoints but only 7 are now seen by Roon.

Number of Tracks in Library

Description of Issue

After updating Bluesound firmware to version 3.20.45 some of the devices which are Roon Ready are no longer seen by Roon. One is a Pulse Mini the other is a Flex. I have another Pulse Mini and Flex of the same vintage which are still seen by Roon. All devices are seen and operate normally using the BluOS Controller.

Troubleshooting I’ve done so far:

  1. Reset and restored the problem devices and then tried them wired to the router.
  2. Switched off all devices on the entire network, rebooted the router and added each device 1 at a time.
  3. Rebooted Roon Server and Roon Controller multiple times.
  4. Restored Roon Database from a backup done prior to the update.

I know that Legacy is no longer supported but I’m hoping someone may have a suggestion that will help remedy the issue. Thanks.

More Bluesound devices are disappearing from Roon. Today only 6 are displayed in Audio setup. There should be 9.

This morning 2 more have vanished. Now there are 4 where there should be 9.

Can you ping the now offline Office Flex - ?


Thanks for the reply Mike. Odd things are happening post the latest Bluesound firmware update. This morning some of the devices were not visible in BluOS either though rebooting them reestablished connection in BluOS but not Roon.

Whether the update is responsible for these issues or the network I’m not sure.

Just pinged the Office Flex: average ping 24 ms, 0% packet loss.

It seems to be a network issue. First with the end points being seen, then disappearing, then re-appearing upon a reboot.