Brand new BRYSTON BDA-3 with ROCK: no native DSD if volume is not 100%?

Core Machine (Operating system/System info/Roon build number)

Roon Optimized Core Kit / NUC7i7BNH / Roon Server Software Version 1.7 (build 537) stable

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)


Description Of Issue
Just received the Bryston BDA-3: top machine which sounds great, but…
I can’t get DSD natively out of Roon unless volume is 100%, either by setting it to max when in Device Volume, or if I set Fixed Volume. Lowering from 100 I get static (first time it happened when I lowered the volume with music playing I nearly had a stroke :slight_smile:
Other option is DoP but it converts to PCM, making the device’s top-quality specs kind of useless.
This makes listening to mixed tracks in resolution PCM and DSD impossible. Also my pre amp has no remote…
Please tell me I’m missing something …
PS: I checked past posts, but didn’t find a solution that fully applies
PPS: it came as a surprise that a device like the BDA-3 is not recognized by Roon. Will it be in the near future?

Converting to DoP does not in fact convert to PCM. It just encodes the DSD, hiding it in a PCM envelope. Everyone along the way thinks it’s PCM, but when a DoP compatible device sees it, it knows to “open the envelope” and use the raw DSD inside.

Now that said – I have the BDA-3.14, which is a combo BDP-Pi and BDA-3 in one BDA-3 box. I could not get it to play DoP either. I didn’t really pursue it very far because I have one album in DSD and I found its PCM version on Qobuz, so I don’t really need the feature.

Thank you Thomas,
I could have sworn it did switch to PCM, judging from the LEDs in the front panel… I think 'm loosin’it …

Still, by converting to DoP we loose the volume control: music is silent for any value less than 100… instead of being deafened by white noise that Device Volume setting gives you !

For me Volume control by any Roon remote is paramount: really there’s no way to get this to work?
It feels like a big disappointment finding this behaviour by machines and software in this league… (I mean Bryston - Roon pair).
It’s something I didn’t expect, if there’s no workaround apart from converting in PCM

Definitely wait for an official response from @support. My BDA-3.14 is not officially certified as Roon Ready yet, whereas the BDA-3 is officially Roon Tested. Therefore, your situation may be different from mine. Hopefully you can get a satisfactory solution.

Do you have sample rate conversion active in the DSP engine? How is it configured? Read also: Conversion To PCM
Pictures of your signal path might help too.

Thank you @BlackJack
I’ve been trying with many settings: always the same result:
if I want native DSD in my DAC, I lose volume control from Roon.
Reading the help pages you pointed out (thanks), starts making me realize the reality of it…
If I want volume control in my Roon remotes, I need to convert to PCM somewhere along the line…
It starts to look like two listening separate setups: one for PCM and one for DSD.
I hope to come to a definitive setup by which I can listen to my music at its best, possibly using all my hardware’s potential
Posting screenshots shortly

My understanding from reading some books on digital audio is that DSD is a very difficult, if not impossible, medium in which to conduct DSP. Digital volume control is DSP. I believe if you want volume on DSD, the way to do it is in the analog stage, i.e., feed the BDA-3 to a high quality preamp (maybe like the BP-17 Cubed) and adjust the volume in the analog domain.

These are some of the reasons why DSD is falling out of favor as I understand.

@Kuryan_Thomas, the BDA-3 is feeding a Brytston preamp (BP20+ separate power supply, ancient, but still doing its job). Trouble is it doesn’t have a remote …

My problem here is becoming figuring how to integrate DSD with PCM listening, or ditching the DSD path althogether and convert it to highest PCM.
Mind you, I haven’t yet sat to judge if there are any differences in sound quality between the same track in DSD and PCM.
Furthermore I don’t even have many DSD tracks (just a lovely, hissfree edition of Kind of Blue in DSD128).
It’s just that I received the Bryston BDA-3 today and I was eager to use it to its full potential.
Had I known of these DSD pitfalls, I might have gone for a BDA-2 (with no DSD)…

I’m not sure why Roon support has not responded here. You could try calling or emailing Bryston. Their customer support is first rate. You talk to real live people.

So you have sample rate conversion active in the DSP engine and configured it to process native DSD and it doesn’t work for you?


Hello @Marco_Sassone,

The Bryston BDA-3 USB volume control controls the volume at the USB chipset level which is before the DAC in the signal chain.

Thus, when you lower the volume using the USB volume control, it will (attempt) to truncate the bitstream causing it to no longer be bit-perfect by the time it reaches the DAC.

To use the volume control on the BDA-3 while playing DSD content, you must use the IR remote.


Yes @BlackJack, Enable Native DSD Processing is on “Yes”

But I tried many combinations: whenever I managed to have a Lossless signal Path and a DSD LED on on the DAC (with Sample Rate Conversion Enabled or Disabled , and then inside of it with all the other possible permutations I could think of ) music plays fine (excellent, actually) as long as Volume is 100. At the first notch down, a loud white noise covers the music (which can still be heard very faintly under the noise).
This is not ok if you imagine listening to normal/high volume and using a iPad as remote and touching by mistake the screen on the volume …

In any other setting, as soon the Signal Path shows a green light High Quality, Volume is functioning correctly, but LED on DAC is on highest PCM rate, hence not native DSD

This is how I expected (and wish) it to be: native DSD lossless, but with NO volume control:

This with volume control but NO DSD:

I’m confused now.

So I assumed that Roon’s DSP Volume was used.

I believe he has the BDA-3 connected to a preamp.

Yes, I do, thanks @Gerald_Schrader

Maybe, maybe not. It’s irrelevant for the question at hand.

The OP wants to control volume digitally via Roon. The manufacturer writes in the manual that the BDA-3 has no volume control. @john writes that it has two (device volume --> USB; doesn’t work with DSD) and IR controlled (should work). Who’s right now? Why is the Signal Path showing a BDP-1?

thank you @john
it’s now clear BDA-3 has no volume control, neither via its remote[BR2].pdf
so I believe you are referring to preamp IR remote.
My Bryston BP20 hasn’t got one…
I think, in order to have volume control from Roon remotes, I’ll have to resort to PCM conversion.
As I said earlier, I’ll come to term with it, I just wanted to be sure I wasn’t missing something, as I have a great machine but won’t use it at its full potential (still to be seen if differences between DSD and PCM are audible, as well).
Further, on a side note, I just found out that BDA-3 SPDIF is not playing signal from my Denon player
playing SACD. Regular CDs play fine though … uff !

Most-likely a copy protection issue (read the manual of the Denon player). Usually SACD (DSD) playback supports only the analogue outputs and HDMI (with compatible AV-Receivers that support the copy protection) if available.

because I didn’t like the generic loudspeaker icon for such a highly regarded machine, so I chose something that looked similar.
I now reverted to the generic icon and loaded default settings. Restarted ROCK and stated afresh

Still same result, though
but now the volume bar has turned red… never seen this before: maybe she overheard we’re talking about her ?:slight_smile:

If I set to Convert to DSD over PCM (DoP) the only difference is that lowering the volume from 100, where plays fine, there’s silence instead of white noise (better than drilling your ears)

you’re right, I’m afraid…
and guess what, Denon DCD2010AE hasn’t got HDMI output… SPDIF only… :roll_eyes: