Bricasti M12 seen on network but not on Roon Nucleus [Solved: Firewall disabled]

Roon Nucleus hooked up via Ethernet to a netgear switch on an Xfinity Router. Network sees Nucleus (IP address Bricasti M12 hooked up via an Ethernet cable to an Xfinity POD and network sees Bricasti on network. (IP address
So Roon Nucleus sees about 8 items to “Enable” some are also connected via the POD but the Nucleus does NOT show the Bricasti. Why?

Hello @Steven_Klein1,

Make sure that you are running the latest firmware on the Bricasti M12.

If there is no firewall inhibiting the Nucleus from seeing the Bricasti M12 on the network, the next most likely cause of this is that the Bricasti M12 isn’t currently running the Roon Ready process on the network module due to a firmware issue.


I live 30” from the Bricasti factory and just back this am, M12 is up-to date.

How do I go about seeing if there is no firewall inhibiting the Nucleus from see the Bricasti?



Roon Nucleus now able to choose Briacsti M12…yippie!!!

1 Like

Hello @Steven_Klein1,

Glad to hear it, enjoy the tunes!

I’m going to mark this thread as solved, if you run into another issue feel free to open a new thread.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.