[Bug found?] No manual IP address on Roon remote [Ticket In]

Roon remote doesn’t not allow manual input of IP address for connecting to the Rock.

Click on “help”, then click on the text-box where supposedly to input the IP address, the app will simply goes back to the searching page.
I tried clicking on the “help“ to bring up the text box again, but still the same.

Tested on iPhone8, iPhone 11, IPad Pro 2021, and Windows 10 laptop.

Not sure what you are trying to do here. Are you trying to connect to your Roon Core machine for the first time? If so, if Roon is on the same network subnet it should automatically show the core and a button to connect to it show show. If it is not showing up there then it is either on a different subnet or your firewall or security settings may not be letting you see the core.

Can you give us more details of your network?

I can confirm this happened to me as well. I needed to type my core’s IP address manually since I was connecting to my home network over a VPN. I had this exact issue. I ended up installing an older build of Roon and was able to connect.

I was so surprised that no one started a thread about this. Spent almost an hour to search for similar cases but found none.

You are right, I was trying to connect my Rock for the first time. But it is not the point. Just see me as someone who is curious about what Roon remote is, and installed it on different devices across platforms.

The App itself is flawed. Whether I have a well-configured core or not, it should allow me to enter the IP address into the textbox just as what the caption suggests.

From my perspective, I have never seen the screen you are looking at. I was trying to find out what you were talking about. I am not presented with “Help” anywhere when starting roon on a new machine and connecting for the first time, unless, I disable the core so that the remote can’t find it.

I did this and now see what you are talking about.

We can’t enter an IP into the circled box so that it can then scan for the IP.
Which is how I assume this is supposed to function? Unless Roon decided to disable that function?
Either way, I agree that this is probably a bug and @support needs to send it in to be addressed.

1 Like

Hi everyone :wave:

I wanted to thank you for bringing this to our attention — it looks like our developers have already worked on a fix for this.

Please, stay tuned. It will be part of subsequent releases :nerd_face:


This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.