BUG: Headset pause/play button on Android does nothing

Core Machine (Operating system/System info/Roon build number)

Roon Version 1.7 (Build 537) stable on Android 10. Pixel XL. The roon core is Roon 1.7 (Build 537) on Ubuntu.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

built-in WiFi on my phone

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Bluetooth Headset: Aeroplex by Aftershokz

Description Of Issue

When I press the pause/play button on the headset, nothing happens. It should trigger pause/play.

All other audio-related apps do something. Music/audiobook apps pause and play. Phone apps answer/disconnect. Roon does nothing.

The Roon app doesn’t quite fully integrate with Android as other apps do eg the Qobuz app.
This is still a tad annoying as the Roon app still doesn’t make the most of the DACs inside my Android based FiiO M11. The Qobuz app does…Roon app does not :frowning:

This is incredibly basic. Pause/Play is a fundamental feature. Not taking advantage of some unique piece of hardware is one thing, not being able to pause is really broken.

I’d be happy to fix that for them, if I had access to the source code :smiley:

You could always do some temp work for them :joy:

Hello @Alan_Robertson1,

Can you please reproduce this issue and let me know the exact local time + date + track you hit the play/pause button on your headset? I wonder if there’s any activity at all when you press it in the Roon logs, I can enable diagnostics mode for your Core + Android device once I have the timestamp.

The play pause button works on my Shure BT2 Bluetooth adaptor with Roon on my Androids phone and DAP. However the control buttons on the DAP itself do not.

Do you need to enable diagnostics before I do the pause/play? Or can I do this, and you check logs later?

Well, this is interesting. It now works… I’ll try a different headset and see if also works… It had failed many dozens of times before…

1 Like

It now also works with my Jabra Elite 85h headset (which sounds a lot better anyway).

Logs can be checked later, Roon does a “rolling log” where older logs are automatically replaced by new info.

Glad that it works for you now! I’m not sure why it didn’t before, but do let me know if the issue returns.

Will do!
Of course, various things auto-update, and I didn’t check the versions of anything before. I’ll also track that if it returns. At least now I know it’s intended to work.


It has returned. No reboot of my client or server.

And it worked again after a dozen or so failed attempts. Then some kind of message popped up and said something like “Roon lost control…” (with some other words). It was only up for a fraction of a second.

Hi @Alan_Robertson1,

How about 1923 MDT today with my Jabra Elite 85h. Several times up to 1925.

Switching to my AfterShox: it failed at least 5 times around 1927.

It has also failed with my Aiwa Exos 9 4.53 “boom box”.

At various times it has also worked. More failures than successes.

Hi @Alan_Robertson1,

Can you please use these instructions and send me a copy of your log set? You can private message it to me if you wish by clicking my name -> message on this forum.

Where was the Jabra connected, was it connected to a phone/tablet or directly to the Core? If it was connected to a phone/tablet, what is the model/manufacturer of the device?

The details of the device were provided in the bug report. Android device: Google Pixel XL running Android 10. Nothing has changed. I’ll grab the logs tomorrow. Thanks!

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.