Bug: IP address of networked AirPlay device changes when ios device attached to laptop

Thanks for your patience while I have been discussing your report with our tech team, @DaveN.

I asked one of one of the team members to run a quick test yesterday with his setup to see if he could readily reproduce this issue and unfortunately he could not. However, I would like to get the details of your setup into a ticket for further testing to ensure that we are testing in the same/similar environment in which you are experiencing this behavior.

Here is what I will need:

  • Please provide the make, model, and specs of the device hosting your Roon core.

  • I see in your screenshots that next to “settings” it reads “Trinity (server)” so I am assuming that the laptop where you are experiencing this behavior is acting as a Roon remote. Please also provide the make, model, and specs of this device.

  • Please provide the model and specs of the iPhone and iPad being used.

  • Please provide the specs of the Airport Express being used.

  • Please provide a brief but accurate description of your network configuration/topology, being sure to provide insight into any networking hardware you are currently implementing.


Hi @eric ,

OK, here’s the info you need …

My Roon Core and Roon remote are running on the same laptop, specs as follows:

MacBook Pro (Retina, Mid 2012) running OS 10.13.3
Processor: 2.7GHz Intel Core i7
Memory: 16 GB 1600 MHz DDR3
Graphics: NVIDIA GeFore GT 650M 1 GB
Intel HD Graphics 4000 1536 MB

iPhone 6 64GB running iOS 11.2.6

iPad Mini 64 GB running iOS 11.2.6

Airport Express (Firmware version 7.6.9) set to extend our existing WiFi network.

Network Details
Our home network is run by a BT Home Hub 6. The majority of items in our household are assigned dynamic IP addresses but both my laptop and the airport express have static IP addresses (set outside the DHCP range of the router).

The router creates both a 2.4 GHz and 5GHz network. The laptop and airport are both linked to the 5GHz network. That said, the problem discussed here also occurs on the 2.4GHz network.

Hopefully the above contains the info you need but let me know if there’s anything I need to clarify.

Also, as I suspect this might be relevant, when the iPhone or iPad are plugged in to my laptop it takes between 25 and 30 seconds for Roon to report a change in the IP address of the airport express. When it’s unplugged the address reverts to the correct assigned address in around 15-20 seconds.

This is great @DaveN, your diligence and attention to detail are both VERY appreciated!

As mentioned I am going to be having our tech team bang on this a little and see what they can come up with. Once the mentioned “testing ticket” has been passed back I will be sure to share the team’s thoughts/findings with everyone asap.


1 Like

Thanks @eric, and hopefully the tech team will be able to track down the problem. It’s not a huge issue, now that I’ve worked out what was causing the dropouts, but it would be good to get it resolved.

I’ll look forward to hearing from you.

David, have you considered, rather than setting your devices to fixed IP addresses, allowing the router to always assign the same IP address to your devices via address reservation instead?

I used to always do fixed IP but somewhere was told of some issues with that, many security related, so went with address reservations instead and have had no issue with that. All of my home devices are now assigned the same unique IP address, whether wired or wireless, based on MAC address reservation from the router. The 169.xxx IP scheme is one I was always told is the default for devices that cannot make connection with a router to assign one. I know on my Windows devices if I boot up and it can’t find the router for some reason then I get a message stating that it is assigning a system default address instead and it’s always a 169-something.

You might give this a try and see if it makes a difference. Of course don’t forget using this method to turn off fixed IP on your devices and put them back to DHCP.


1 Like

@Larry_Herrett, thanks for the suggestion, and the detailed explanation. I’ve just implemented it - using DHCP addresses for my laptop and the airport express, then setting the router to stick with that address for each device - but it hasn’t made any difference to this problem.

Thanks again,


Boo! It was worth a try.

Unless you had a specific preference you might just leave it with the router assigning the fixed IP addresses that has always worked well for me. I probably have in my house at least 15 wired and wireless devices and I always know what IP address they are going to have based on the assignment.

Hopefully Roon support can figure this out for you, at least you know the workaround.

PS: Do you think it might have anything to do with the fact that you have the IP addresses of your devices outside of the DHCP range? What happens if you temporarily bring them inside the range does the problem persist? I am on my phone at a traffic light answering this LOL so I did not scroll back through the prior answers to see if this was touched upon.

I did that when I switched them to DCHP assigned addresses, as I also thought it might make a difference. Sadly, it didn’t. But thanks again for another suggestion - we’ll get it sorted eventually :slight_smile:


Any luck solving this problem? I have the exact same issue, the only differences are in our hardware. I’m running a mid 2010 Mac Pro as my Roon core and that’s where I plug in my iPhone to charge. As soon as I do that (just like you), Roon changes the IP address of my Airport Express and will no longer stream to it. If I unplug my iPhone, Roon will eventually resolve the IP back to what it needs to be for correct streaming to the Airport Express. Today’s Roon updates did not fix the problem.

HI Piomice, sorry for the delay, I’ve been travelling over the summer. As for your question: I hadn’t checked in a while - but tried just now and can’t seem to replicate the problem. I haven’t tested it thoroughly, but on first inspection the problem seems to have gone for me.


Thanks so much for the replay. I’m also no longer able to reproduce this, which bothers me because when I first posted to this topic, I could make it happen at will. But I honestly can’t remember if there was a Roon update since then? Also, Apple updated the firmware on the airport express just recent (to enable Airplay 2), so I’m wondering if that made a difference?

If I see it again I’ll post back.

Best regards,


HI Mike,

No, I’m not sure if there was an update either. As for the Airport Express: did you update to firmware v7.8? The reason I ask is that I updated but then had to downgrade again as it simply wouldn’t work with Roon, i.e. no sound. I did read somewhere on the forum that Roon haven’t added Airplay 2 support yet so I’d be keen to hear how/if you got it working.




I did update to 7.8 and I can also confirm that it does NOT seem to work with Roon (same problem, it seems to connect but does not actually output sound). The Express definitely works with iTunes, however, so I know the path to the endpoint device (an old Vector Research VRX-9000 vintage receiver in my case) is valid.

Because this is not my primary listening system, I’ll hang in there with v7.8 on the airport for a while to see if the next Roon update fixes the issue. If it works after the next update, I’ll give you a shout.

1 Like

Hello, just to say that I have this same problem with an Airport Express showing as 169.254.?.? in Roon, when everything else thinks it is, in case having a second config helps you isolate the problem. Let me know if you want config details.

And, thanks to Mike’s detective work, here you can see the Airport Express magically regaining its correct IP address in Roon 30secs after disconnecting my iPhone from my iMac: https://youtu.be/njW5v9V8DVI