Bug: IP address of networked AirPlay device changes when ios device attached to laptop

For a few weeks now I’ve been troubleshooting an issue whereby Roon wold appear to lose the connection to my Airport Express. Specifically, the IP address of the Airport Express (as reported by Roon) would change from the actual network address (in this case 192.168.1.50) to a self-assigned address (169.254.41.247). At this stage I should add that the actual IP address doesn’t change, and other apps (e.g. iTunes) can still stream, but Roon was having problems.

I had assumed that this was a problem with my network, and/or Airport Express, but I think it’s a bug in Roon. When I don’t have my iPhone or iPad cabled to my laptop there isn’t an issue, but as soon as I plug either of them in the network address for the Airport Express changes - I can watch this happen if I have the Settings -> Audio tab open at the time.

Has anyone else experienced this problem?

@support

@DaveN

I’m going out on a limb - this is odd but maybe you dont have the iOS devices setup to allow internet tethering properly… you might have a network interface priority order issue.

If you open network preferences and click the little dog in the lower part of the list and select Service order and move the iOS devices down below the wifi (and ethernet if you use it) then apply and see how that works for you.

I thought you might have worked it out with that suggestion, but I’ve just checked and that isn’t the issue, as the following screen grabs indicate. The first is with my iPhone connected to my laptop, the second with it removed. Exactly the same thing happens when I attach my iPad. This is a bit of a puzzle, and nothing I’ve tried so far makes any difference.

iPhone Attached

No iDevices attached

This might seem odd question…why are you connecting the iOS devices to your laptop? Nothing to do with the Roon application I assume. Is it possible this device is pairing with the Fatman and overriding the network address? Is the address thats OK a fixed or DHCP address? I don’t see any other addresses listed in your post so not sure what your network looks like. Maybe some more details there will help.

Its also odd that they do not appear in the network interfaces available when connected.I recall that they normally would. But I just tried this on my desktop and they didn’t show up either but all my Airplay devices seem to have the right addresses still.

How is the Fatman connected to the network? I’m assuming Airport10,115 is maybe an Express or Extreme? or does it have some other connectivity? This then via the USB?

I’m connecting the iOS device to my laptop simply to charge it.

As for further details …

My network is run on a BT Home Hub 6.

Router: 192.168.1.254
Laptop: 192.168.1.11 (fixed IP, set on the device)
Airport Express (the ‘Airplay > Fatman’ device referenced above): 192.168.1.50 (fixed IP, set on device)

In short, both the Airport Express have fixed IP addresses (outside of the router’s DHCP range of 64-253) and the audio device is hooked up to the Airport Express via the audio port.

One further test I just tried (which I think rules out the iPhone connecting with anything on the network when it’s plugged in to the laptop) was to plug in the phone with it switched to airport mode. It still changes the IP address for Airplay in Roon even though it isn’t connecting directly to the network via its own wifi or bluetooth interface.

Also, I don’t know if this will help to shed any light on the issue but the change in IP address reported by Roon isn’t instantaneous - it takes about 20-25 seconds to alter the IP address when the iPhone is plugged in and about 10-15 seconds to reset to the correct IP when it’s disconnected.

This is a bit of a puzzle.

If you temporarily switch back to all dhcp do you still see the issue?

Yes, that doesn’t help.

Two other things.

First, if Roon is playing and I connect the iPhone (or iPad) it will continue to stream to the airport express despite the apparent IP change. But if I plug it in and then start trying to stream from Roon it fails to output anything. The play indicator at the bottom of the screen moves through the track, but there’s no output.

Also, just in case it’s relevant, I’m running Roon Server on my laptop in addition to the Roon app, though I’m fairly sure I had this problem before I switched from just using Roon.

Just checked. Using Roon as a standalone app versus Roon and Roon Server makes no difference. I have exactly the same problem in both modes.

Ok I think we should flag @support now…in case someone has seen this internally before. It’s certainly an odd situation indeed especially as airplane mode still impacts things.

I’ll try on my mbp shortly and see what it does, I can run up a Core there or server, but I don’t have airport express handy right this min but can go find one.

Hang in there David…in the meantime use a stand alone charger :smile:

@wizardofoz and @Ratbert, thanks for your help, as I would like to get to the bottom of this. Now I’ve worked out what’s causing the problem it isn’t really much of an issue - I just need to avoid plugging in either my phone or iPad - but it was a frustrating couple of weeks trying to isolate the cause.

@wizardofoz, let me know if you have any luck replicating the problem.

In the meanwhile, I’d be interested to hear if @support have run into this issue before.

I’m seeing exactly the same symptoms here too…how strange. Looks like a bug but not sure where…I’ll do some more digging.

I’m using Airport Express and its showing up the same Airport10,115 with a self assigned address maybe 20-30 secs after the iPh gets plugged in. not even trying to play anything to it yet.

Interestingly the AirPort Utility shows it as the Assigned address as does my router listing and MacOS can also ping it at the same DHCP assigned address.

@support I think might have some weird issue with the iOS playback device that is new in this recent update to support playback on the phone or iPad via headphones/speaker or attached DAC.

It’s good to hear it’s not just me. And yes, it is rather odd. Let me know if you manage to find out what’s going on.

I’ve been doing some digging around with arp in terminal, and while I don’t really know what I’m doing (I’m not a network expert, by any stretch of the imagination), I did find out that plugging the iphone in does seem to make a difference. If you run the following it will delete the arp table:

sudo arp -a -d

If you then run ‘arp -a’ to list the interfaces you’ll see that the airport express is listed at its correct IP address. Here’s what I get:

trinity:~ djn$ arp -a
? (192.168.1.11) at 20:c9:d0:44:8f:67 on en0 ifscope permanent [ethernet]
? (192.168.1.50) at 20:c9:d0:ac:21:1a on en0 ifscope [ethernet]
? (192.168.1.254) at 40:c7:29:2:aa:7f on en0 ifscope [ethernet]
? (192.168.1.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]
? (224.0.0.251) at 1:0:5e:0:0:fb on en0 ifscope permanent [ethernet]
broadcasthost (255.255.255.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]

If I then plug in the phone, wait for 15 seconds (or so) and then run ‘arp -a’ again:

trinity:~ djn$ arp -a
airplay-fatman-itube.local (169.254.41.247) at 20:c9:d0:ac:21:1a on en0 [ethernet]
? (169.254.255.255) at (incomplete) on en0 [ethernet]
? (192.168.1.11) at 20:c9:d0:44:8f:67 on en0 ifscope permanent [ethernet]
? (192.168.1.50) at 20:c9:d0:ac:21:1a on en0 ifscope [ethernet]
? (192.168.1.109) at dc:41:5f:8:78:84 on en0 ifscope [ethernet]
? (192.168.1.131) at c:47:c9:31:51:1c on en0 ifscope [ethernet]
? (192.168.1.254) at 40:c7:29:2:aa:7f on en0 ifscope [ethernet]
? (192.168.1.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]
? (224.0.0.251) at 1:0:5e:0:0:fb on en0 ifscope permanent [ethernet]
? (239.255.255.250) at 1:0:5e:7f:ff:fa on en0 ifscope permanent [ethernet]
broadcasthost (255.255.255.255) at ff:ff:ff:ff:ff:ff on en0 ifscope [ethernet]

I don’t know if that shed’s any light on the issue, but it’s interesting that the ‘airplay-fatman-itube.local’ address doesn’t show up until the phone is plugged in. I should also add that this entry persists after the phone is unplugged. The only way to get rid of it is to delete the arp entries.

I too see this

pauls-airport-express.local (169.254.33.104) at (incomplete) on en0 [ethernet]

even without the iPh connected and one for my wife laptop too.

both have IP addresses in the DHCP space listed in arp -a too

And even odder I see much less showing on the list when I connect the iPh … very very odd indeed…and the APE disappears from the DHCP address in that list too

Yep, there’s definitely something odd going on, and I initially thought this might be an OS bug rather than anything to do with Roon, but other apps (e.g. iTunes) can still stream to the Airport Express without issues when the iPhone is plugged in.

Might still go either way… Im on MacOS 10.13.3 and it doesnt seem to happen when the core is on another MAC and control is on the mac with the iPhone attached

Fair point, and that’s a scenario I can’t test with my setup. That said, if it is an OS bug it’s one that only trips up Roon as other apps and devices can still stream to the airport express with the phone is plugged in.

This does not happen when I run the core on my 10.11.6 iMac that has a LAN and Wifi connection. Maybe its a MacOS issue.

My guess is support will be along any tick of the clock to chime in.

Yep, some input from support would be good as I’ve run out of ideas :slight_smile:

@wizardofoz — Thank you for flagging us down here!

@DaveN and wizardofoz, thank you both for the feedback here! I have a meeting with our tech team today and will be asking for some feedback on this behavior. I had been using an Airport Express for testing purposes sometime ago and never ran into this behavior previously.

I will be sure to update this thread asap, your patience is appreciated!
-Eric

1 Like

@eric, thanks for looking into this, and if there’s anything I can do to help track down the problem please let me know.

1 Like