Build 161 constantly losing core connection [Solved, Mac Mini Sleep]

I have a late 2012 MacBook Pro Retina client and Mac Mini 2014 running as a headless server. I have used this setup for over a year successfully. In Build 158 I lost the ability to see and play W4A (apple lossless) files (the bulk of my collection. With build 161 Roon the client will start and then lose it’s connection with the core in less than 1 minute, typically. I had Roon rescan then rebuild my storage directory and no help. It’s been 6 weeks since I have been able to use Roon. What’s up? I sent a bunch of diagnostics for the build158 problem, this build was supposed to fix it. Now it’s worse.


Hi John,
Roon uses the codecs within the OS so I wonder if your setup has changed. Do you recall updating to a new osx or any other updates ?

@support will need some info and logs from you. Flagging them here.

Hi @John_McElfresh ----- Thank you for the feedback and my apologies for the troubles. I wanted to reach out to clarify the issue(s) you are currently experiencing after build 161.

In your initial report you had mentioned that you had lost the ability to playback M4A content. Can you confirm if this has persisted after the update?

In regard to this most recent report, I would like to start by evaluating your network configuration and topology. May I kindly ask you to please describe what your current setup is like and provide details about any networking gear you maybe implementing (router(s), extenders, repeaters, switches, etc).


Having the same disconnection issues too. Core running on iMac i7, client on same iMac along with iPad/iphone. Loses connection every few seconds on all clients. Reconnects after a few more seconds then disconnects again over and over. All running 161.

1 Like

Forgot to mention…
I did do a move of my server from a Mac mini (wired 10/100/1000 to switch) to my iMac, moved local storage too. Seems RoonAppliance is crashing over and over. Moved back to the Mac mini system and all working fine so consider my post ignorable.


First, I should say that both the MacBook Pro (late 2012) and Mac Mini (late 2014) have been updated to OS10 Sierra. My network is simple, with the Mac Mini connected to a 16 port gigabit switch which is directly connected to a Verizon Quantum router. My NAS (where the music is housed) is also connected to the same switch. My MacBook Pro is on the wireless network from that same router. This hasn’t changed in over a year, with Room working fine since installation until recently.

I tried reinstalling Roon yesterday. At first it looked fine, I could access everything. Shortly, though, the remote lost connection to the server and hasn’t reconnected. This seems to be the issue. I have not changed my configuration at all and double checked my settings. I have access to each of the components (Mac Mini, NAS, etc.) from the MacBook pro independent from Roon. BTW, The M4A problems seems to have been solved, as I could access the files during the short period the remote was connected to the Mini.

Any thoughts?


It looks more and more like a network issue. Can you just put the wifi device that loses connection on a wired connection and see what happens?


I will do that this evening when I get home.


Nick, Troubleshot my network at home (evidently WiFi issues are common in Sierra upgrades). Roon worked fine for 30 minutes or so. I closed the remote. 2 mins. later opened it again and it couldn’t find the core.

M4A files play fine when connected.

Re-connected to wired network and Roon found the core again. Any ideas?


Good that you have isolated the issue. I have no experience with mac OS so can’t really advise.
It seems like a new OS comes out every few months and stuff happens. Must be web forums with fixes on out there.


The problem seems to have disappeared with some network adjustments. I’ll watch for fixes in Sierra to improve response, but at least I can use Roon again. I sure missed it!


Great. Can you outline what the adjustments were ? It could be valuable for others that hit the same issue.

It seemed that once the Mac Mini had fallen to sleep the Roon wouldn’t wake it, so I turned sleep off on the Mini, though I do allow the hard drives to sleep. I’m guessing there will be a fix fr Sierra at some point.


I’m having the same problem with Sierra. Roon keeps losing the connection repeatedly, then reconnects on its own. Frustrating. I had already turned sleep off, so that’s not the problem. Don’t know what is. But my MacPro completely lost the internet with Sierra and I haven’t figured that out either. Hopefully, an update will fix it.


As of yesterday, I’m having the same problem. Did you find a resolution?