Build 269 issue - wireless connection to ROCK


Was there a change in OS X Build 269 that does not allow wireless connection to a ROCK?

OS X Build 247 works fine but Build 269 does not. OS X is running on a Mac Mini (late 2014) with a I5 processor and 8 gig of Ram. OS is Sierra 10.12.6.

This is really frustrating because I have no available ethernet ports and I can’t stop Roon from downloading the update and it updates the next time Roon is started.

So my process to listen to music has become delete Roon build 269, install Roon build 247. Repeat each time I want to listen to music. Not the user friendly solution I was hoping for.

Thanks, Keith

Hi @Keith_Gierman ----- Thank you for the report and sharing your feedback with us.

I must admit that I am bit foggy on what the error is here. Based on the above it sounds like you are unable to control you core from a remote device, is this correct? If so, I would recommend confirming that there are no active firewalls on your system OR antivirus applications (with build 269 installed).

Furthermore, can you please expand on your setup description using this link as guide.


There hasn’t been a change and @support can help here, but this is a really bad idea. The format of the Room database can and does change from release to release, and downgrading like this can corrupt your database, which is why downgrading is not supported.

1 Like

Up to the update to build 269 for OSX Roon has worked flawlessly as configured below. It still works fine using iPad Pro for control.

Core: Intel Nuc I5 gen7 running ROCK
Control: iPad Pro 9.7 running iOS 11.0.3, Roon 1.3 build 269; Mac Mini running OSX Sierra, Roon 1.3 build 269
Output: (2) Raspberry Pi 3b with Allo dac HAT running dietPi with Roon 1.3 build 120. One Pi is on 1st floor and is normally controlled with iPad Pro. Other Pi is on second floor and is normally controlled with Mac Mini.
Intel Nuc and the 2 Raspberry Pi’s are connected to Router via Ethernet. iPad and Mac Mini are connected via WiFi.

The problem is that the Mac Mini on build 269 will not find the Roon server running on the Nuc. Build 247 finds it fine. When build 247 is updated to build 269 it works until the Mac is restarted. When restarted Roon build 269 on the Mac will not find any Roon devices on the network. The only way to get beyond that screen is to move the core to the Mac. Obviously I don’t want to do that again. Again control works fine with the iPad and no issues have occurred with it. The only issue is with using the Mac Mini as a control device with build 269. Build 247 worked fine for several months and the problems started with that update. No other configuration changes have been made since initial installation.

I missed mentioning that the Nuc is running 1.3 build 269.

The only variable involved is the Mac Mini running either build 247 (works) or build 269 (doesn’t work after reboot of Mac).

There have not been any other system changes or updates and problem is 100% reproducible.

Hi @Keith_Gierman ---- Thank you for touching base with us, the insight is appreciated.

Moving forward, while I understand that everything is working as expected under build 247, I would like to have a better sense of what troubleshooting you have performed with the MacMini running build 269. Can you please verify if you have confirmed/tried any of the following:

  • Have you tried taking the MacMini off of WiFi temporarily of course) and testing with hardwired connection to your router?

  • Have you confirmed that the MacMini does not have any active firewalls OR antivirus applications?