Build 521 - No more DSD upsampling with new Roon release

**Core Machine (Operating system/System info/Roon build number)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
Since I upgraded to new Roon release today, I do not have access to DSD upsampling anymore.

I see the different DSD options and if I select DSD64/96kHz nothing is happening.

Also, I do not see the Sigma-Delta Modulator settings in the new release…

This all worked perfectly prior to the new release…

Hello @Daniel_Babeux,

Sorry about the trouble, let’s figure out what’s going on here. Could you provide a set of Roon Logs by using the instructions found in the “Option 2” instructions here:


Hi John,

I would prefer sending the file via WeTransfer. I do not have a Dropbox account. Can you provide an e-mail address to which I can send the file?



Here is the saved file:

Hello @Daniel_Babeux,

I am getting a “file does not exist” error when clicking the link.

You can use WeTransfer if you would like, just make sure to use the “Get Transfer Link” option during upload. You can send a private message to me with the link.


Can you try again? I think I forgot to share the link previously.

Hello @Daniel_Babeux,

What zone are you attempting DSD playback to? If it is the opticalRendu zone, try going to Roon Ready > Settings in the Sonore Web Configuration and ensuring that DSD is set to “DoP”.


Hi John,

This is so strange…I already had my OpticalRendu DSD Support set to DoP. Taking no chances, I pressed ‘Save changes’ button in ‘Roon Ready Settings’ menu which caused Roon Ready to be reconfigured and restarted. I now have access to the DSD menu again in Roon. However, when I look at the signal path, it is still not playing in DSD mode…

Hello @Daniel_Babeux,

You need to reconfigure your DSP settings now that the device is reporting DSD support.



I already did so, when I got complete DSD Roon menu back…Every DSD menu settings are exactly like they were before the update. Still no DSD operation in Roon. I rebooted my PC with no changes…

Fixed my issue. I had to disconnect my DAC power cord as well as my OpticalRendu power cord. I restarted the DAC and then the OpticalRendu. I now have DSD in the signal path.

This procedure was provided by Sonore, whenever there is an issue with their product. I remember using that procedure to solve some handshaking process between the OR and my Benchmark DAC and decided to try it out. Everything is now fine!

Well back to the drawing board…Although I can see the DSD LED lit up on my Benchmark DAC, Roon is skipping track by track when trying to play some music…

Just to be sure, you’re not using Speaker Setup do you?

No. Essentially, when I do the Sonore procedure (previous e-mail), the DSD LED on my Benchmark is lit up. As soon as I try to play some music, either the skipping tracks dance starts (DSD LED lit up on DAC) or music is playing but at original sampling rate (no DSD) and DAC LED display original sampling/bit rate. This used to work fine prior to 521 build.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.