Build 88 Focus button crashes consistently (on OSX)

Roon version 1.1 build 88 stable (64-bit) on OS X 10.11.2, Retina MBP.

Pressing the Focus button in any context inside Roon instantly crashes the program.

Things I have tried:

  1. Moving /Users/charlesrazzell/Library/Roon to /Users/charlesrazzell/Library/Roon_Old and rebuilding library from remote SMB share. (Same crash)
  2. Reinstalling build 70 (No crash)
  3. Going back to build 88 (Same crash again on pressing Focus)
  4. Test the “Focus on Similar” button in build 88 (works fine, no crash)
  5. Using Roon Remote on iOS (build 69) stable to control Roon 88 on OS X, press Focus button on iPAD touch screen (works fine, no crash).

Summary: every attempt to directly access the Focus function on build 88 on OS X fails with a crash that leaves: (com.roon.Roon.86112[4096]) Service exited with abnormal code: 5 in the Console log.

However, the associated database functionality seems to still work, since I can access it fine via an iPad acting as a remote.


1 Like

Hi @Charles_Razzell – thanks for the report, and sorry for the trouble. I’m going to follow up via PM and we’ll get some more information so we can find out what’s going on here.

Stand by!

I’m getting this as well - clicking the Focus button or using the / shortcut causes Roon to quit immediately. I’m running El Capitan on a MacBook Pro. Has the cause of the problem been found yet?

1 Like

Hey guys – we actually just finished our analysis of this today for @Charles_Razzell and also for @James_Bracken.

From what we can tell, it looks like something has prevented Roon from installing a critical file during the recent update. Our best guess right now is that this is related to the recent false positives we’ve heard about from Avast.

We are waiting on word back from Avast about resolving the false positives, but whether you’re using Avast or not, our advice for now would be to delete Roon from your Applications folder. Then, disable Avast completely (if you’re using it) download Roon from our website and copy it back into your Applications folder. I think Roon should able to successfully copy the missing file, resolving this issue, but let me know if you’re still stuck here guys.



Sorry to report, I do not have Avast installed and never have had. I run Mac OS X without any anti-virus protection installed, and on this particular machine I’ve never installed any 3rd party security s/w whatsoever (not even a trial).

If you can tell me which file you think is missing from my install, I can positively verify its absence or otherwise.


1 Like

@mike I’ve never run Avast on this Mac either, but can check for any missing files.

1 Like

Sorry guys – I was a little unclear here. Avast may be related or not, but the underlying issue is that the Roon installation seems to be missing a file.

Can you guys let me know where you’ve installed Roon to? Your applications folder?

If so, just delete Roon from the Applications folder (your database is stored separately, in your Library folder), then download Roon from our website and copy it back into place.

Try that and let me know if you’re still stuck – just want to try the simple fix first, before I have you searching for missing files :wink:

I’ve just deleted Roon from the Applications folder and downloaded a new copy, but the Focus button is still causing Roon to quit I’m afraid.

1 Like

Same experience as Chris, fresh install to /Applications and Roon still crashes immediately on pressing Focus button.

The following dynamic libraries are found in my folder

Charless-MacBook-Pro-2:Resources charlesrazzell$ cd /Applications/ charlesrazzell$ find . -name \*.dylib

Should I look for something else?


1 Like

I also tried attaching a debugger to the running Roon process and triggering the crash.

Executable module set to "/Applications/".
Architecture set to: x86_64h-apple-macosx.
(lldb) cont
Process 603 resuming
Process 603 stopped
* thread #1: tid = 0x2bed, 0x000000012a627cfc, queue = '', stop reason = EXC_BAD_ACCESS (code=1, address=0x0)
    frame #0: 0x000000012a627cfc
->  0x12a627cfc: movq   (%rax), %rax
    0x12a627cff: callq  *0x130(%rax)
    0x12a627d05: movq   %rax, %rdi
    0x12a627d08: movq   (%rax), %rax 
(lldb) register read
General Purpose Registers:
       rax = 0x0000000000000000
       rbx = 0x00000001075293a0
       rcx = 0x0000000000000000
       rdx = 0x0000000000000000
       rdi = 0x0000000000000000
       rsi = 0x0000000000000000
       rbp = 0x00007fff591a2a40
       rsp = 0x00007fff591a2820
        r8 = 0x0000000000000040
        r9 = 0x00007fe0e15008e8
       r10 = 0xffffffffffffffff
       r11 = 0x00007fe0e8300001
       r12 = 0x0000000118cd01a8
       r13 = 0x000000000000000b
       r14 = 0x0000000107660918
       r15 = 0x000000010e27a110
       rip = 0x000000012a627cfc
    rflags = 0x0000000000010206
        cs = 0x000000000000002b
        fs = 0x0000000000000000
        gs = 0x0000000000000000

(lldb) thread backtrace
* thread #1: tid = 0x2bed, 0x000000012a627cfc, queue = '', stop reason = EXC_BAD_ACCESS (code=1, address=0x0)
  * frame #0: 0x000000012a627cfc
    frame #1: 0x000000012a6278dd
    frame #2: 0x000000012a621d93
    frame #3: 0x000000012a621b85
    frame #4: 0x000000012a621a77
    frame #5: 0x0000000106a69e38 Roon`mono_jit_runtime_invoke + 1592
    frame #6: 0x0000000106c18b0e Roon`mono_runtime_invoke + 110
    frame #7: 0x0000000106c1e89a Roon`call_unhandled_exception_delegate + 426
    frame #8: 0x0000000106c1e52a Roon`mono_unhandled_exception + 218
    frame #9: 0x0000000106b0610b Roon`mono_handle_exception_internal + 3899
    frame #10: 0x0000000106b051c8 Roon`mono_handle_exception + 24
    frame #11: 0x0000000106b5a5f2 Roon`mono_amd64_throw_exception + 114
    frame #12: 0x0000000107136607
1 Like

I’m getting the same thing.

Focus button makes Roon crash instantly, every time.

1.1 (build 88), 64 bit.

Mac OS 10.11.2.

No A/V software. Tried fresh download of Roon app; still have the issue.

Don’t know if this is relevant, but I use Roon on the Mac as a remote control. I run Roon Server (build 88, 64 bit) on a Windows machine.

Love the latest version of Roon, though. Thanks!

1 Like

This issue is repeatable by me as well.

Can send you @mike what ever you need to assist in solving this discussion.

iMac 12, 1
OS X 10.11.2
Build 88
Running SSD for OS, Media on disk attached storage.

I’m have the same problem.

Focus button makes Roon crash instantly, every time.

1.1 (build 88), 64 bit.

Mac OS 10.11.2 (MacMini)

New installation of Mac OS and ROON.

When I use remote on my iPad (build 69) focus button is working fine, no crash.

Just out of curiosity: does Roon crash as well when you press “/” on the keyboard instead of pressing the Focus button?

Pressing “/” also causes the crash for me. Works fine on the IPad but Focus is now unusable on my MacBook

Sorry again for the trouble here, everyone.

We understand the issue and have a fix in the pipeline for our next release, which should go live as soon as our QA has had a few days to confirm this is resolved and put the build through the paces.

I’ll update everyone with timelines as it comes together. Appreciate everyone’s help and patience here!


Build 94 is live with a fix for this issue guys – thanks for your patience!