Build 88 Roon quit unexpectedly


Roon quits on core after I deleted approx 19K Tidal tracks from my library. Most of these were auto-selected by Roon after my first install.

Crashed three times in succession.

Running Mac Yosemite Roon version 1.1 Build 88.

All was well enough before then. Some difficulty adding Beatles albums to library but everything else hunky-dory.

Waiting on you.


Hi Tom,

Since you deleted so many tracks, you may want to run Library Maintenance.

Setting > Setup > Library - Clean Up Library

Might consider a backup first.

See if that helps. *** of course, that’s if the program stays open long enough!

Cheers, Greg

Also, has it finished (or can it before crashing) syncing with Tidal?

Cheers, Greg


Good suggestion. I have done that and will report back if problem continues.


Well, it continues to crash.

Starts up normally. Syncs with Tidal.

I saw and deleted the Tidal tracks vestiges using Library Maintenance.

But it crashed a few minutes later.


We’ll have to wait for the Roon guys. They’ll probably want your log files.

Good luck.

Cheers, Greg

Need to clarify:

After reading threads w similar topics I launched Roon and immediately navigated to the Settings/Services tab. I noticed the spinning syncing indicator. It crashed while in this mode. So to clarify/correct an earlier answer I gave: No Tidal wasn’t finished syncing.

Thanks for the prehelp.


Okay. Nobody official acknowledged my problem so I tried to find out some info by searching through the Roon Community Forum.

I logged out of Tidal on all my devices other than the Roon core.

On the core I quit Roon, deleted the cache, ran Roon, logged out of Tidal under Services.

Roon did not crash.

Logged back into Tidal and waited for it to sync. It crashed after a few minutes of syncing.

I am now ready for some genuine Roon Tech Support.

Thank you.


Hey @dbtom2 – we’ve seen two other users having stability issues with similar symptoms. We’re investigating but I’ll follow up later tonight to get some logs from you.

Sorry for the trouble!

1 Like


Add me to the list.

Earlier I told you I reinstalled Roon (64 bits) and everything seemed to be OK, but in the last 10 minutes I have had two crashes after restarting. I just restarted again, and an immediate crash.

Running Windows 10, latest version of Roon.


Everything on my MacMini Yosemite was stable until I decided to do some housekeeping. I was getting inconsistent action when I selected “Add To Library”. Not a biggie but my library was getting unwieldy.

I deleted about 19,000 Tidal tracks (using FOCUS) that were added when I first installed Roon last June. I was looking to narrow down the size of my Tidal Favorites.

The deletion worked - in Tidal - but Roon started crashing right away. Roon doesn’t crash when I disconnect the Tidal login in under Settings/Services so I figure it has something to do with Tidal.

Thanks guys – we’re still gathering information on this, so your patience is appreciated as we work to reproduce this and get it resolved.

In the meantime, assuming you have a backup, you might want to find your Roon folder and rename it to something else temporarily, like Roon_old.

Then, you can safely reinstall Roon and you should be able to use Roon with a new database, while we look into these issues. If the crashing doesn’t start until you add your Tidal account, please let me know ok?

Sorry again for the trouble here. Talk to you guys soon!


I couldn’t get Roon to stay open more than a minute or two before it crashed…

I just disabled Tidal from services and it seems to be running fine and not crashing.

I wonder if this is related to both Tidal and the number of additional tracks loaded into the library when Tidal is running (though I don’t think the number of tracks should be a problem with a 64 bit system).

Still crashing when I add Tidal… …Runs fine without Tidal.

I went into Tidal app and deleted all the Artists, Albums and Playlists. I deleted the most recent first and reran Roon while hoping that the recent Tidal additions were the cause of the syncing problems.

Performed the Library Maintenance in Roon. Interestingly, though Tidal kept crashing as it synced, the number of orphan tracks listed under Library Maintenance decreased in size as I reduced the number of Artists, Albums, and Playlists in Tidal.

Deleted the Roon Cache folder.

Did everything I could in several iterations to start Roon with a ‘clean’ Tidal database.

No luck. Still crashes.



Thanks guys – we’ve made some progress in our investigation over the last few hours, and we’ve uncovered what we think could be the cause. We’re still confirming the issue, but once that’s complete we’ll start testing a fix and prepare to release it to everyone.

For the moment, I don’t really have a good workaround to offer. We believe that starting with a completely new TIDAL account should resolve the issue, but that’s pretty inconvenient, and might not be 100% effective in every case – certain behaviors (like adding then deleting content from the new account’s library) might trigger this issue again.

Apologies for the trouble all. We’re working hard to get a fix out to everyone as soon as possible, so thanks again for your patience everyone.

Thank you Mike,

I needed to clean up the Tidal part of my library anyway. I made note of the Artists, Albums, and Playlists that I want to keep so adding them won’t be a big deal.

To recap:

The “Add To Library” function has been intermittent for me since the very beginning of my Roon subscription last spring. It worked most of the time.

When the Beatles catalog became available on Roon I couldn’t add certain albums. Others added fine. This got me looking at the extent of Tidal tracks in my library. Almost 20,000 in addition to the 26,000 of my own. I deleted about 19,000 Tidal tracks and that’s when Roon started crashing.

I can still listen to my music using either Roon or the Tidal app. No worries, just a few more mouse strokes.

Thank you for acknowledging that progress is being made to fix this issue.

Tom T.

Should I expect the fix to be included in the pending build? Or will it be after that one?


This thread seems to be the same problem as in this thread which I posted a similar problem and Roon staff responded a solution is being tested currently.


Hey @dbtom2, apologize for leaving you uninformed. Fix for your issue is on the way - it will be in our next release.

Thanks for your patience.

Hi Vova,

Help me adjust my expectations.

  1. 24 hours?
  2. 5 days?
  3. February 1?
  4. Any of the above?

Thank you.