Build 970 Feedback

Try rebooting the core if you haven’t done so already

After I installed the latest version my Roon app on my iPhone 13Pro crashes after 10 seconds. I don’t even have to start any music. It still crashes. I have rebooted my NUC but it hasn’t resolved the issue. It still crashes on my phone.

If this situation is even a remote possibility, the Restore process itself should create a fresh database before proceeding with the restore.

Why write code when the user can be saddled with the task? :smirk:


I have tried Roon on my iPad Pro 3rd gen and it works perfectly. It still crashes on my iPhone 13 Pro.

A post was split to a new topic: Roon Server Not Responding

I rebooted my iPhone. It solved the problem😄


I read that as If the restore is not working, then there’s a chance that the roon update, caused corruption in the database.

No joking, while everyone else was having these issues on older builds I had none. It all started after the update.

I don’t really have anything special saved, I just didn’t want to reanalyze 100,000 tracks. Thanks for post directing towards the troubleshooting. Before seeing the post you made, I basically did what the troubleshooting post said, except I just deleted the RoonServer folder and restarted. Which created a new empty database. Then I restored an older backup and redirected a few storage paths.

Fingers crossed it’ll not corrupt itself again.


I thought for a little while that roon had managed to make an update without fu…ing up something new, How wrong can one be… now all my remotes crashes after seconds in now playing mode. Two iPads and one Macbook pro.

Add images

Amazing day! Roon played all day in the office without interrupt. When I returned home and fired up it was great for hours until [I] chose to shut down. Thanks Roonlabs team for your pride, persistence and perseverance. Well done.


Sorry if I am asking the obvious, but you updated the remotes as well right? I ask because this isn’t happening to me on my iPads, nor is it happening on my iPhones.

This version is really crap. So many problems
At first it said corrupted build, i downloaded again and now it is having tidal login issues.

Have checked the play store?

1 Like

Open a support thread.

Reboot your Roon Core and try logging into Tidal again.

Can say this build was much better than the last, has managed to stop the remote on windows freezing all the time which was the main bug for me. Happy days!!

Mine it’s working as expected for the time being. Since I updated yesterday, it has been running without issues

struggling with Roon already for years, until end of 2021 on my QNAP TVS 671, since beginning of 2022 on Rock

the last versions were a little bit more relyable, but 970 is worse, it doesn’t start anymore

ticket opened: Roon on NUC10i with Rock and LINN: immediate CRASH

Windows server, windows endpoint, wired network. The update disabled my dac audio device, had to reboot, set it back up again, got a second “mystery” update with no change in version number, disabled device again, couple more reboots, more setting up audio device and zone again (several times before remembering all the previous settings).

After all that, it’s been working great for a couple of days now. Fixed my main complaint of Now Playing screen not advancing with track change, so thanks for that!

I update everything whenever there is an update, I hate the nagging if i dont