Burst of noise when play starts

When I start playing a track or an album, there is usually a short burst of white noise before the track begins. This did not happen with the previous version of Roon.

I am using Roon 1.8 (build 764) from a Samsung tablet that accesses the core on a desktop computer running Debian 10 (Linux). The audio zone is a Bluesound Node 2i connected to a McIntosh amplifier. All of connections between the router, the desktop, and the Node 2i are wired. I use the TIDAL streaming service.


Suggest seeing if enabling a ‘Resync Delay’ helps.

Option is under Settings–>Audio–>Device Setup.

1 Like

Thanks for the suggestion. I’ve tried delays up to 1000 ms, but the problem continues.

1 Like

What DAC are you using?

Because my Bluesound Node 2i is connected to my McIntosh amp with coax cable, I assume I’m using the DAC of the amp. Correct me if I’m wrong!

To help narrow this down a screen shot of the signal path would be helpful.

One thing to try (temporarily) would be to see if you get the burst of noise when using the analog outputs of the BlueSound node.

Here are a couple of shots of signal paths, with the Bluesound Node 2i connected to the McIntosh amplifier via coax cable.

Thanks for the screenshot, standard looking signal path for sure !

Did you get the burst of sound when using the analog outputs of the Bluesound ? (not a permanent solution, but this may help eliminate Bluesound-digital-McIntiosh as the issue)

Yes, I just tried the analogue connection (RCA cable from Bluesound Node 2i to McIntosh amp) and had the same issue.

When I play albums and tracks directly from the Tidal app on my tablet to the Bluesound node, I do NOT hear the short bursts of sound.

Hello @Paul_Murtaugh,

There weren’t any changes in Roon 1.8 in this area, so I don’t think Roon itself is the culprit here.

I would test this by playing to the System Output zone of a Mac or PC and seeing if you’re getting the burst of noise. Roon uses the same streaming protocol (RAAT) for streaming to Mac/PC and Roon Ready devices, so it stands to reason that if the Core were generating this noise that it would affect all RAAT zones.

If you’re unable to reproduce this behavior on a Mac/PC zone, I would reach out to Bluesound for further assistance. I believe they have some changes around RAAT planned in their next firmware update, but I cannot be certain if they’d address the behavior you’re seeing.


1 Like

The issue seems to be something about the interaction of the Node 2i with the Roon app when streaming MQA tracks, but I don’t understand the technical details. I discovered a workaround: in the DSP settings (righthand side of the track banner), I changed the crossfade time from zero to one second. Of course, this causes the sequencing in an album that I play without shuffling to be slightly different from what the artists intended, but life is full of compromises!

For the record, I’ll summarize my correspondence with Bluesound support. I wrote:

  • I have a Bluesound Node 2i connected to my router with ethernet cable, and connected to my McIntosh MA 5300 amplifier with coax cable. I use a Roon core on a linux computer, controlled via the Roon app on my Samsung tablet. In the Roon settings, I have enabled ‘Decoder and renderer’ MQA capabilities on the Node 2i. When I am streaming an MQA album and decide to switch tracks, there is a short burst of noise before the selected track begins. This does NOT happen (i) when I am playing a non-MQA album; (ii) when I turn off MQA decoding on the Node 2i; or (iii) when I bypass the node and direct the audio output to my tablet. It DOES happen when I connect the Node 2i to the McIntosh amp using RCA cable instead of coax.

And they responded:

  • Node 2i has the BluOS firmware which has the capacity for ROON as a decoder and renderer. But from ROON app end, we can not guarantee that it can be used as a dedicated MQA decoder. So try to stream the MQA file via using the BluOS Controller app which will definitely resolve your issue.

He’s right that the problem does not occur when I use the BluOS app, but of course I want to use Roon … hence the workaround.

Hi @Paul_Murtaugh ,

Can you please confirm you also see this issue on the newest BluOS Firmware? There was a BluOS firmware last week which contained may help with MQA issues.

Yes, I still see the issue with the latest firmware for the Node 2i (3.14.2).

BlockquoteThis does NOT happen …(ii) when I turn off MQA decoding on the Node 2i;

Am I reading your description properly that the problem goes away when you turn off MQA decoding on the Node 2i? If that’s the case then can the problem be resolved by doing the MQA decoding in Roon?

That’s correct, the problem goes away when I turn off MQA decoding on the Node 2i. I had assumed that the Node 2i would do a better job of decoding than the Roon core, but maybe that’s wrong. Is it possible to tell from these screenshots of the signal paths with Node 2i decoding turned on (bs-on.pdf) and off (bs-off.pdf)?

Hi @Paul_Murtaugh ,

Thanks for the screnshots!

Yes, you can see in the first one that full decoding is taking place while the second one has Core Decoder turned on.

Can you please confirm if local MQA content also exhibits the same behavior? You can download MQA samples from the 2L Test Bench (right-click on the file size → save as).

I downloaded two MQA samples, and put them in a directory on my desktop that Roon checks for content. With MQA decoding and rendering enabled on the Node 2i, I do NOT hear the bursts of noise when I start playing or switch between tracks (which show up as albums in my library).

Hello @Paul_Murtaugh,

Have you spoken with Bluesound support about this issue? We’re unable to reproduce it using our in-house Node 2i.

Given that we have not received any other reports of behavior like this on other devices, it’s likely that Bluesound will be best positioned to get this fixed. We’ll continue testing on our end and we’ll be sure to let you know if anything changes.


Yes, I talked to Bluesound and gave a detailed account of their response, a few messages back. Basically, they attribute the problem to Roon, and you attribute the problem to Bluesound. But, I agree, if you haven’t had other reports of the behavior, it’s not really something you can address. I’m fine with the workaround using crossfade in the DSP settings.

Hello @Paul_Murtaugh ,

Can you please try to update to an even newer BluOS firmware? There has been another firmware release since your post, please verify if the new firmware helps with the behavior. Thanks!