Cambridge Audio CXN no longer working on USB


(Geoff Bulte) #11

JOhn
I don’t have exactly the words “Disable MQA USB HID Protocol” but there is a button to disable MQA USB in the advanced options in the Audio tab, which I did. Unfortunately no improvement. On the CXN the display flickers between “96Khz” and “No Signal” as Roon skips through the playlist.
Geoff


(Mike O'Neill) #12

If it adds any hints …

I feed my CXN via AirPlay , then by coax to my Audiolab M-DAC for my headphones this gives me 44.1 only .

I just added a RPi with Riopeee to run the M-DAC directly on USB , this gives me 96 (the limit on USB). I then thought that the CXN would give me 192 when running effectively as a DAC only so I tried the USB feed from the RPi.

I saw 96 indicated, so I reset the USB from 1 to 2 and then saw 192 Hurrah !!

BUT Roon , via RPi sees the M-DAC and allows adjustment as an audio devie etc but Roon does NOT see the CXN in the same way. It sees it as an AirPlay speaker but not as a DAC

Is this the same issue I wonder. I have reverted to RPi -> M-DAC and Airplay to the CXN but something is not quite right. I havent had time to dig deeper yet. My firmware on CXN is up to date as is CA Connect and Roon

Mysterious ? CA have no intention of becoming Roon Certified from their last comms

Mike


(Mike O'Neill) #13

I dont see any Device Setup for the CXN as a USB DAC , just as an AirPlay speaker

Mike


(John) #14

Hello @Geoff_Bulte,

I would recommend you reach out to Cambridge Audio support and tell them you are having issues with the CXN using USB on Linux. The errors that are shown in your log indicate that the device is having issues communicating with the Linux audio stack, which is something that is not specific to Roon. This issue is happening before Roon can even see or identify the device, so unfortunately there isn’t much we can do here.

If you get some guidance from Cambridge about what may be causing this issues or further troubleshooting steps, I’d be happy to assist. If they provide you information that fixes your issue, please share it here so that other users can find this information!

-John


(Mike O'Neill) #15

Hi

There is a second thread talking about this

It looks like the CXN will work when set to Class 1 USB ie up to 92 khz, but doesn’t work when set at Class 2 , up to 192 khz

Linux is not recognising the CXN hence Roon doesn’t either

Mike


(Geoff Bulte) #16

Hi
I contacted Cambridge Audio and they agreed to roll back their firmware update for me. Unfortunately the problem persists so it appears it’s not CAs fault. Any ideas?
Geoff


(Mike O'Neill) #17

Did CA indicate a specific roll back for you or in general. A roll back will rob you of Tidal in CXN if I am not mistaken ? That was the main change in the recent firmware upgrade.

It would be better if they fixed the Linux issue without roll back

Mike


(Mike O'Neill) #18

Have you been following this pone as well

https://community.roonlabs.com/t/roon-and-cxn-dsd-disappointment-dsd-suggestions-please/43009/116

same story . I did some testing with a Windows 10 ed point and the Linux one of the RPi

Mike


(Geoff Bulte) #19

They rolled back to the previous version but the problem persists suggesting/confirming it wasn’t a CA problem. They did undertake to investigate becoming Roon ready


(Mike O'Neill) #20

I know they have no interest in Roon Ready , they don’t think its big enough to warrant the effort.

Its funny that your NUC is not seeing the CXN, I used a Wireless Laptop (Sony Vaio) , then USB cable to the CXN , it showed the CXN as a connected DAC both on Class 1 & 2 selected on the CXN

I played 24/192 tracks via this set up with no problems.

Just a dumb thoughts , did you disconnect the CXN from the network completely ? I set it to “wired Only” then pulled the LAN plug , that way the CXN was simply a DAC standalone. Otherwise you may get IP conflicts

You can see the signal paths etc on the other post

Mike


(John) #21

Hello @Geoff_Bulte,

  1. Is your Cambridge Audio CXN the V1 or V2 revision?
  2. After discussing with the tech team, they enabled a possible workaround on your account, which should change some low level details related to how Roon communicates with the DAC. Please reboot your Roon Core to allow this change to register. You should now see the “Disable MQA USB HID Protocol” toggle that was mentioned before in Device Setup for the device. Let me know if enabling this setting changes the behavior you are seeing using both the USB 1.0 and USB 2.0 options on the CXN device.

-John


(Geoff Bulte) #22

John
Some progress… Selecting the “Disable MQA USB HID Protocol” enables USB 1.0 and I can successfully play tracks. However, USB 2.0 will still not register, appearing briefly when Roon tries to enable it before disappearing as an option.

Geoff


(John) #23

Hello @Geoff_Bulte,

Can you confirm the exact version of the firmware you are running on the CXN, as well as if the device is the V1 or V2 revision? I’m going to forward this info to the tech team for further investigation.

-John


(Geoff Bulte) #24

John


CXN is V1, firmware is v009-a-131+a
Good luck - it would be nice to get those high frequencies back on USB 2.0 even if I can’t hear them
Geoff


RoPieee End point disappears (1second)
(John) #25

Hello @Geoff_Bulte,

We’ve made another change on your account that may help get this issue fixed for you. Please reboot your Roon Core to allow this change to register. Let me know if you see any changes!

-John


(Geoff Bulte) #26

Success USB 2.0 now working. Thanks for the fix. Does this mean I can upgrade the CXN firmware?
Geoff


(Mike O'Neill) #27

@john

What did you adjust and can you do it for me?

I still have a USB class 2 issue with my CXN and Roipeee , mine is V1 too

The best I can get is 24/96 on Class 1 . Roon doesn’t see CXN class 2

Mike


(John) #28

Hello @Mike_O_Neill,

At this current moment, this “fix” can only be applied to computers running ROCK or Nucleus. We’re hoping to have a solution for users on other platforms in the near future. I will be sure to let you know when this happens!

-John


(Mike O'Neill) #29

Thanks

Mike


(Paul De Koning) #30

Hello John,

I just received my RoonNuc with Roon rock and I am facing the same problems with my Cambridge Stream Magic 6V2. When i use the option USB 2.0 on the stream magic, it is not detected by Roon. With the option 1.0 I can detect the DAC but no music playing and Roon skips through the songs/

The roon version I use is 1.6

Thanks in advance for your support.

Paul