Can no longer connect to Nucleus

I am a new Roon Subscriber. Purchased Nucleus two weeks ago and had a professional A/V consultant install SST drive and set up system using iPad and iMac as controlling units. Nucleus connected via HDMI cable directly to Router. System worked fine for five days. I began downloading my CD’s via Apple USB SuperDrive and listening to music without problems.

After five days, I turned off the Nucleus to connect new SuperDrive, turned the Nucleus back on and my iPad and iMac can no longer locate the Nucleus Core. Message is “Waiting for Remote Core” and it never connects. I have tried rebooting the iPad, Mac, Router, Modem, and Nucleus individually and all at once multiple times; but no success connecting. The USB SuperDrive is getting power from the Nucleus and will load a CD, but it will not download it to the Nucleus.

I had the A/V Consultant come back to troubleshoot the problem. He tested all cables and ports on multiple devices. He opened up the Nucleus and inspect the circuit board and connections and could not spot any problems.

When the Nucleus power is off there is a blinking green light next to HDMI port. When the Nucleus is turned on an orange light appears, the green light continues blinking for about 5 seconds, then both lights go off.

I was really enjoying Roon. How do I get it connected and working again?

Steve Sennewald

Hi @Steve_Sennewald,

Are you able to reach the Nucleus Web Administration Interface?

Can you share a video of this with us here?


I am unable to reach Administrative Interface or any Nucleus/Roon menu. When starting the Roon app it immediately searches for Remote Core and never gets past the message “Unable to Locate Core”.

Attached is video. Initially the Nucleus is off, and there is a blinking green light. When the Nucleus is turned on, the green light continues to blink, an orange light appears; then both lights go off and stay off.

I made a video with my iPhone I would be happy to share with you. It is a .mov file and this community board will not allow me to add it this response. I can email it to you if you give me an address.

I am a new Nucleus user. Just casually reading Nucleus support posts and I came upon this thread. I should think that a manager with technical support would find a way to get to the bottom of this or receive the video through some email account.

Hi @Steve_Sennewald,

You can upload the file here:

Since you can’t access the Web UI, can you also try connecting the Nucleus to a monitor via HDMI and let me know if there is any output there when you power on the device? You can share a picture of this via the same link above.

Would you also kindly verify the following:

  • What was the date the Nucleus was purchased?
  • Where was the Nucleus purchased from?
  • What is the serial number of the Nucleus (can be found on the bottom panel)?


1 Like

I uploaded the video of the lights on the rear of the Nucleus to the link you provided. Initially the Nucleus is powered off and a green light blinks. Then the Nucleus is powered on, the green light continues to blink, then an orange/yellow light starts blinking for 5-8 seconds, then both lights go off and stay off.

I initiated the purchase of the Nucleus via the Buy button on Roon website, which redirected me to Amazon. I purchased on Amazon and it was delivered on March 11. The serial number is 54B2038B9D8F.

How necessary is it for me to connect the Nucleus to a monitor? The only monitor in the house that might conceivably work is my 65" Panasonic TV (circa 2010). It would require me to unplug the Nucleus, move it to the TV room (where there isn’t an internet connection) and mess with TV wiring. I’m not really equipped for tech support at my house.

Dylan, What do you think of the video I uploaded two days ago?

My A/V consultant believes that the lights going out when the Nucleus power is turned on indicate the circuit board has failed.

Hi @Steve_Sennewald,

I’ve sent you a PM with next steps.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.