Can’t connect to WD NAS after software update

Core Machine (Operating system/System info/Roon build number)
NUC running ROCK

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
ROCK connected via Ethernet to Netgear Nighthawk router.
Other devices connected via Ethernet and wifi.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
My music is on a WD My Coud PR2100 NAS. I’ve had it connected this way for years, without event.

The path is \\MyCoudPR2100\Public

I just upgraded the NAS software to My Cloud 5. Now, Roon does not recognize this storage; it says the directory is not available.

I’ve tried adding it via smb and IP, but nothing works.

I can access the music files on my Mac, via the finder, and on my iPad, via the Files app. But when I try the various means in the Roon app I just get a message in a red box saying there was an unexpected error.

I’ve been fiddling with this for hours. It shouldn’t be this hard.

By the way, I was able to connect to the NAS on my Mac using smg. I tried copying in the path from finder into the Mac Roon app, but this failed the same way as noted above. I started by rebooting the router and my ROCK, but maybe I’ll try those again.

EDIT: a reboot didn’t help.

Second EDIT: by the way, this is a true NAS with a Pentium N3710 , not just a hard drive.

I figured it out by myself. On my NAS I had to change Windows Services from smb 3 to smb 1 smb 2 smb3.

I was lucky enough to find a thread from someone who was having trouble connecting using his Windows 7 machines.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.

Hello @Steven_Goff, glad you found a solution here! Please let us know if you have further questions.