Can’t flash ROCK image to flash drive

Installing ROCK on a NUC. When I got to the step to flash the ROCK image on a USB drive using Etcher, I get the error “Something went wrong. If it is a compressed image, please check that the archive is not corrupted.” This is on a Mac. Tried both the gz file which I found in the trash and the img file. Unlike the gz file, the img file has “-100000175” after “factoryreset”. I thought it would be identical to the gz file - just without the gz at the end, but it’s not. Any clues as to what might be wrong? Thanks

Are you running MacOS Catalina? If so, see this thread …

Found another post that had the same problem. Turns out it’s a known problem with the new Catalina OS on the Mac. Tried it on my wife’s Windows machine and all was fine. Here’s that post: Archive Corrupted Error in Etcher

So now yet another app is crippled by Catalina … better go and complain on their forum too…Oh its free software so maybe that’s ok…well maybe if everyone isn’t jumping on the latest software OS updates it might not be such a bad thing…

OK off my soap box now.

1 Like

These workarounds may be of use

Moving your image inside balenaEtcher.app seems to do the trick.
You can do this by selecting “Show Package Contents” on balenaEtcher.app and dragging your image inside of it. Then you can select your image as usual from Finder and the flashing will go ahead. Make sure you select the image inside balenaEtcher.app

Or

sudo /Applications/balenaEtcher.app/Contents/MacOS/balenaEtcher