Can’t login from a Grimm MU1 music server

Hi I Have never used Roon before.
I purchased a very expensive music server from Holland,
The company is “Grimm” the model is “MU1”

I have been struggling for over one week to get the music server to work with Roon.
I contacted the dealer who sold the unit and received no reply!
I logged an assistance request with the manufacturer but they told me to contact the dealer!

Since I couldn’t get Roon running on the MU1, I decided to try getting it to run on a windows laptop. This process was quick and easy. It worked first time.
On the windows laptop I could run Roon and play music. I could also run Roon remote on an iPad and use that to control the Roon core on the laptop.
All this was achieved with my Laptop plugged into my isp router and my iPad connected wireless to my wifi router

I read that Roon could have problems with subnets so to “simplify” I turned off the wireless router, plugged the laptop and the MU1 into the isp router, started a wireless service on the isp router and connected to that using the iPad.
This “simplified” setup allowed me to easily run Roon core on the laptop, and control via the iPad “no problems”
Unfortunately I still could not get the MU1 to work!

The MU1 appears to have a stripped down Unix OS running with a custom clock and custom FPGA resampling. It appears to require a Roon extension to be installed by the person who owns the Roon account for the MU1. The MU1 is headless so all configuration needs to be don by a Roon remote.

When I try to connect to the MU1 Roon core I get a message …. “Unauthorised: Please enter your account’s password properly”.

After several attempts I thought I may have messed up my password, so I did a password reset via Roon which worked perfectly for the windows machine but NOT the MU1!

I also tried using the windows machine as a remote (wired connection), just in case the wireless was flaky. This did not work.

I don’t understand why my password works on the windows machine and not on the MU1.
My time is running out on the Roon trial!

Roon Core Machine

Grimm MU1
Don’t know what’s in it …… Linux 4.19.10tinycore version1.8build923

Networking Gear & Setup Details

No vpn
Simplified isp only …
Huawei HG659
Note my internet gets 900mbits down and 100mbits up.
Apart from the MU1 my connectivity and speed seem stable and fast.

Connected Audio Devices

My MU1 is connected to a Nad M51 dac via AES/Ebd digital
For the simplified test my laptop just outputs to its own speakers
I don’t cast music!

Number of Tracks in Library

0 tracks, I put 3 small test tracks on my laptop for testing.
I use Tidal and Qobuz.
I got Tidal working easily on the laptop, but can’t get the MU1 to run/login

Description of Issue

I can’t login the MU1 headless music server even thought I can easily do so on a windows laptop.

Add images

Hi Greg, it’s not obvious to me what’s wrong with the Roon setup on your MU1.
It really should be the dealer to sort it out for you, so try again to contact them.

My MU1 came with Roon set up by the dealer with a temporary Roon account and I just logged in to Roon and changed the account to my own with no problem.

In the meantime, you should be able to access the MU1’s own web interface by typing in it’s IP address from any laptop or tablet (the IP address and hostname is displayed on the MU1’s front screen when you scroll through the settings). This won’t get Roon working, but it will at least confirm that the basic networking to the MU1 is ok.

The Roon MU1 “extensions” are primarily to allow Roon data to appear on the MU1’s front screen. You shouldn’t need them in order to access Roon in the first place. I don’t know enough about Roon account login issues to help further. The dealer should be getting enough margin to provide top customer service for this high end product.

1 Like

@Justin_V from Grimm audio has helped in the past with Grimm grimness.


Thank for the support.

I can access the Grim via the ip address and have tried using the advanced options on this interface.

first I selected “Reset MU1 settings, after which I turned everything off and back on … including the network No joy. After that I selected “Reset Roon database” and a full restart … still not working.

Prior to doing that I successfully upgraded the MU1 to version 1.4.4.

I live in New Zealand. I contacted Grimm for dealer information and was told that my only option was to purchase from Australia.
I found a dealer in Brisbane Hugo Sharp from Indie HiFi. He agreed to fit a 2TB internal drive for no extra cost over the retail price displayed on his website and ship for free.

I sent Hugo a lot of money, and two weeks later he had my MU1 on a FedEx service. Unfortunately for some reason that is unclear to me my shipment failed Australian export, so it sat in Brisbane for three weeks while NZ FedEx struggled to get the issue resolved.
I asked Hugo for an explanation via email and got no reply, I asked Hugo for support a week ago, got no reply, I asked Hugo for support again a couple of days ago when Eelco Grim suggested I contact my dealer! Still no reply.

JustinV from Grimm sent me a support email last night so it’s great to have some support from Grimm.

This has not been a fun process!
My MU1 is awesome with music input though the optical input, but I still can’t use it to stream music from Roon!

It is disappointing to me that such an expensive streamer cannot use upnp streaming and “must” have Roon.

Your suggestion that my MU1 is trying to login as my dealer makes a lot of sense.
Hopefully someone who works at Roon might be able to reset that at the Roon end of things.

Is my post in the correct location to receive attention from Roon technicians?
Thanks again for your support, I appreciate it.

Thanks ged, we are working on it through our own ticket system as well!

1 Like

Hey @Greg_Farrer,

I just caught up on this thread, and wow, what a journey you’ve been on so far! I’m sorry it’s taken so long to follow up with you on this issue.

After taking a look into your account, I do see that your MU1 has been seen online recently. Are you still running into issues getting things squared away?

I’ll be monitoring this thread for your reply :+1:

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.