Can’t run Roon from QNAP NAS

Core Machine


Network Details


Audio Devices


Description of Issue

Roon seems to be running on the QNAP NAS, but I can’t reack the core from any device - iPad, iPhone or HP laptop on my network. Screenshots attached.

Sorry…how do I send screenshots?

Like this …

Thanks! Easy really when you know how…

Did you try to click the blue button labeled “Select a different Core”?

No…thought this would be dangerous!

It’s not dangerous, it just brings up the Core selection screen.

Right…just tried that…

Have never changed the location of Roon on the QNAP NAS…

Looks like you’re in trouble. RAATServer, RoonGoer and RoonServer should be folders and not files (with little loudspeaker symbol like music file?). Also the log file “ROONSERVER_QNAP_LOG.txt” is missing. Is this a brand new installation?

If not, you’re maybe a victim of the Qlocker ransom ware?

The many (last screenshot 10, previously 2) important (error) messages indicated by your NAS don’t look promising. Anyway, things definitely not look as they should. I’ve never seen this before and therefore don’t have further advice beyond: Check the error messages and make sure your NAS isn’t compromised by Qlocker.

Maybe @crieke knows more?

Would agree. Looks kind of bad. These have to be folders :sob:

Thanks for your help - you were absolutely right! It was the QNAP dreaded ransomware what done it. So, total rebuild of the NAS and re-install of Roon fixed it - but a nuisance indeed! So now the long awaited Roon Ready KEF’s are in full-on mode. Again, thanks…

@BlackJack, @Bernd_Kurte
Yes, they are folders. However, in the Roon Server app, when selecting the storage location, I display these folders as a file with a loudspeaker icon. I decided to do so, to prevent selecting these folders as a database location, in case a user reinstalls the app and wants to select the previous database (which would result in a new database in the subfolder of RoonServer or RAATServer…)

Bildschirmfoto 2021-04-28 um 18.20.51


Thanks Christopher! A rebuild of my QNAP NAS was required, now complete. On small glitch on which I’d appreciate advice. When I open the Roon “app” on the QNAP, it shows an HDMI port as HDA-Intel - HDA ATI HDMI…but this is not shown when I navigate to the audio section of the iOS or WIndows Roon app. I used to be able to see it and play to it (there’s a Denon AVR at the end of the HDMI cable). Any advice…thanks as ever.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.