Can’t see Roon Nucleus+ on my Network or Fing

Roon Core Machine


Networking Gear & Setup Details

Arris TG2492LG-85 Router

Connected Audio Devices

My Endpoint is a Trinnov Alt32

Number of Tracks in Library

Description of Issue

My Nucleus+ won’t see the network I have tried rebooting my Router and also the Nucleus+ and the Network still can’t see the Nucleus, I also looked for it on FING and it’s not on there also.
I have tried different Ethernet cables and still nothing

What do you see when you hook the nucleus up to a TV or monitor by HDMI?

Nothing I can’t see anything

Can you post a pic of the Screen? Does anything display at all during boot up?

And I have tried both HDMI A & B from the Nucleus and nothing

And you power cycled the nucleus because we need to see if the thing breathes at all?!

Basically as @Bernd_Kurte says, a photo of the monitor AFTER a Nucleus reboot to see what, if anything is displayed at all would be a good start.
Thank you

Yes I have powered it on/off from its power button, it does turn off and then turns back on but no information on a monitor when booting up

As you can see the power light is on and working

You might try unplugging the power cable for a couple minutes.

I done that countless times

Have you tried cycling the Input button on the monitor to make sure it is on the right input?

Yes done that

Hi @Michael_J_Mccann ,

This does look like the Nucleus has a hardware issue and needs to go in for repairs, can you please let me know:

  • Where was the Nucleus purchased - from a dealer or direct from us?
  • What was the Nucleus date of purchase?
  • What model Nucleus is this?
  • What is the serial number found on the bottom panel?

Thank you.

1 Like

This topic was automatically closed 45 days after the last reply. New replies are no longer allowed.