Cannot Add Mac OSX Network Share (worked previously)

Core Machine (Operating system/System info/Roon build number)

Nucleus v1.7 Build 610

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Unifi W/LAN w/ Draytek Router. All devices hardwired

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 218s and a Trinnov

Description Of Issue

Previously working share to clients iMac stopped working. When I started trying to solve the issue I could see in the storage tab the Roon thought there were 1670 tracks in there. I force a rescan I get that the folder is empty. Checked all OSX settings and they seem correct.

Have since deleted the share in OSX and started it again from scratch. Have deleted the network folder in Roon and tried to start it from scratch. However all I get now is Error Loading Folder unexpected error. Every once in a while it gets through then I get empty folder error instead. I have verified the IP address is correct or have used the hostname instead both same issue.

May or may not be related. Roon Metadata will not show up on the Crestron automation system in the house. I am waiting for feedback from the programmer if this could be related.

Any help or pointers would be greatly appreciated!

Hi @Liam_McLaughlin,

Thanks for reaching out!

Can you please confirm if the Nucleus is plugged in directly to the router, or are you using some kind of network switch in between?

Which instructions did you use for this setup? I would follow this guide:

If you want, you can also look into adding either USB or SSD storage on the Nucleus and store your library directly on it. The added benefit is that the Mac doesn’t need to be powered on to access the music files.

The network is all unifi switches. The Nucleus is connected to one of three switches linked in the rack with SFP connections. The Draytek router is connected to these switches also. The system worked fine before, I am not sure at what point something updated and it stopped working whether it was the Mac or the Roon. The latest instructions you have linked to are those which I have followed. Does the error message I reported mean anything to you?

Hi @Liam_McLaughlin,

Can you please share a screenshot with the values you are inputting into Roon and the error message?

While you are troubleshooting the Mac connection, you may want to temporarily try attaching a USB drive with your media to the Nucleus to use in the interim.